ASUS ZenStates - Page 21 - Overclock.net - An Overclocking Community

Forum Jump: 

ASUS ZenStates

Reply
 
Thread Tools
post #201 of 214 (permalink) Old 09-22-2019, 03:18 PM
New to Overclock.net
 
infraredbg's Avatar
 
Join Date: Nov 2014
Posts: 49
Rep: 14 (Unique: 6)
Version 0.8.0-beta is up on my site https://zenstates.protonrom.com/ and github https://github.com/irusanov/ZenStates
infraredbg is offline  
Sponsored Links
Advertisement
 
post #202 of 214 (permalink) Old 09-23-2019, 02:07 AM
Stock is too casual~
 
Veii's Avatar
 
Join Date: Aug 2018
Location: Austria / Bulgaria
Posts: 246
Rep: 11 (Unique: 9)
Thank you @infraredbg
Could you share some insight, of the difference between old R15/Aida64 Low L2/L3 mode for Ryzen 1st gen and now the R15/R20 mode ?
Wonder what the difference between that new one and the Aida64/Geekbench is

The R15/Aida64 mode old one gave some quite significant boost on my side , around 60cb in R15 and 100-110cb on R20
it had a bit stranger spiking Inter-core latency curve, and got about a 0.8ns hit on ram latency ~ but overall real perf was better , even tho ram latency got a hit

Mojave#1 Ryzen Threadripper 1950x [email protected] ([email protected] with 105BLCK) + Liqtech 360 | ASRock X399 Taichi (3.23Beta) | G.Skill [email protected]3800CL14 | RX 580 Red Devil [email protected]/2200(micron) | Seasonic Focus Platinum | Samsung 960 EVO x2 & 860 Evo
Win#2 Ryzen 1700x @3.8 + Dark Rock 3 | X370 Taichi 1.0.0.3 ABBA by The Stilt (converted to X470) | Patriot Viper Steel (PVS416G400C9K)@3466C14 (64.2ns) | Hynix-MFR 3333CL14(72.5ns) / OLD | Gigabyte 970 G1 1595/1900(Hynix) | Samsung 850 Evo
Veii is offline  
post #203 of 214 (permalink) Old 09-23-2019, 02:53 AM
New to Overclock.net
 
infraredbg's Avatar
 
Join Date: Nov 2014
Posts: 49
Rep: 14 (Unique: 6)
Quote: Originally Posted by Veii View Post
Thank you @infraredbg
Could you share some insight, of the difference between old R15/Aida64 Low L2/L3 mode for Ryzen 1st gen and now the R15/R20 mode ?
Wonder what the difference between that new one and the Aida64/Geekbench is

The R15/Aida64 mode old one gave some quite significant boost on my side , around 60cb in R15 and 100-110cb on R20
it had a bit stranger spiking Inter-core latency curve, and got about a 0.8ns hit on ram latency ~ but overall real perf was better , even tho ram latency got a hit
It's mostly relabeling to match the profile labels in Crosshair VI Hero bios, although new bioses have other profiles now. I think it was just mislabeled or they were labeled that way in earlier bioses - I don't remember.
It was late last night and I wanted to get some sleep, but will try to write a better description later today or tomorrow.
I think this version is incompatible with older SMU versions (25.83 and earlier). Disable SMU Features doesn't work with newer versions - it's disabled by AMD. I have the checkbox disabled for Zen2, but it is still enabled for Zen/Zen+.
Will probably need to disable it based on SMU version and cpu gen. Also PBO settings might not work anymore and might lead to 5.5x multiplier - Pstate control works on Crosshair with 1800X and latest 0075 bios, but still need to test more and with older bioses.
Not all features seem to work, e.g. there is some problem with disable/enable performance boost, also you can set FID/DID/VID for the 3 states, but all 3 seem to be active all the time - the enable/disable checkbox doesn't seem to have effect.
Also, can't fully switch to manual overclock, i.e. force fixed frequency, unless you switch the windows power plan to high performance. In fact Manual Overclock on Zen/Zen+ controls the P0 state and nothing more - you can do the same from the PStates panel.
infraredbg is offline  
Sponsored Links
Advertisement
 
post #204 of 214 (permalink) Old 09-23-2019, 07:55 AM
New to Overclock.net
 
Join Date: Aug 2019
Posts: 10
Rep: 0
Quote: Originally Posted by SL9 View Post
Hello @infraredbg , I tried to use this tool on a 2600x on MSI B450M Mortar motherboard. But upon clicking the apply button, the processor is locked at its lowest possible frequency 5.5*100MHz = 550MHz.

Actually, to trigger this, no change is needed at all, just launching zenstates and click apply right away with the default parameters.

Is this an incompatibility with non-ASUS motherboards? Thanks!
0.8.0-beta
2700x+b450f+2605bios
Still the same problem
gobu is offline  
post #205 of 214 (permalink) Old 09-23-2019, 08:03 AM
New to Overclock.net
 
infraredbg's Avatar
 
Join Date: Nov 2014
Posts: 49
Rep: 14 (Unique: 6)
It seems the PBO settings don't work with newer AGESA/SMU and older gen, so I will have to disable them for all CPUs.
Only scalar works, but it is using the same CMD as Zen2, so I will have to change that, too. Otherwise it might lock further commands and you have to restart the machine.
As it turns out, I don't really have a clue how to control PBO settings on the fly with new bioses. "SMU Power Limits" is also locked and can't be disabled.
The command gets rejected by the SMU.

So, instead of relying on detected CPU generation, I will have to check the SMU version and then enable/disable features based on that.
This means the app features will be rather limited with Zen/Zen+ and newer AGESA/SMU. As you have noticed, the menu options in bios are also limited for Zen/Zen+.
AMD CBS contains just few items and AMD PBS is completely gone.

Unfortunately I can't do much more about that. Will try to figure out PBO settings, but the old way doesn't work. Will compile a new beta version today.

Quote: Originally Posted by gobu View Post
0.8.0-beta
2700x+b450f+2605bios
Still the same problem
Thanks. This means I will have to disable PBO (Performance Enhancer) settings for the time being, until I figure out how to control them on these new bioses.
Will leave scalar only, which seems to be the only one working.
Wait for the new build and I will be glad if you report again.

Btw, can you tell me which is your SMU version? If it is 25.83 or newer, then the current ZenStates version won't work, I'm afraid.
Also, can you do another test. Please select Performance Enhancer 4 and hit apply. Does the multiplier go back to P3 state?
Don't worry, PBO settings displayed won't apply at all.

Last edited by infraredbg; 09-23-2019 at 08:09 AM.
infraredbg is offline  
post #206 of 214 (permalink) Old 09-23-2019, 08:49 AM
New to Overclock.net
 
Join Date: Aug 2019
Posts: 10
Rep: 0
Quote: Originally Posted by infraredbg View Post
It seems the PBO settings don't work with newer AGESA/SMU and older gen, so I will have to disable them for all CPUs.
Only scalar works, but it is using the same CMD as Zen2, so I will have to change that, too. Otherwise it might lock further commands and you have to restart the machine.
As it turns out, I don't really have a clue how to control PBO settings on the fly with new bioses. "SMU Power Limits" is also locked and can't be disabled.
The command gets rejected by the SMU.

So, instead of relying on detected CPU generation, I will have to check the SMU version and then enable/disable features based on that.
This means the app features will be rather limited with Zen/Zen+ and newer AGESA/SMU. As you have noticed, the menu options in bios are also limited for Zen/Zen+.
AMD CBS contains just few items and AMD PBS is completely gone.

Unfortunately I can't do much more about that. Will try to figure out PBO settings, but the old way doesn't work. Will compile a new beta version today.



Thanks. This means I will have to disable PBO (Performance Enhancer) settings for the time being, until I figure out how to control them on these new bioses.
Will leave scalar only, which seems to be the only one working.
Wait for the new build and I will be glad if you report again.

Btw, can you tell me which is your SMU version? If it is 25.83 or newer, then the current ZenStates version won't work, I'm afraid.
Also, can you do another test. Please select Performance Enhancer 4 and hit apply. Does the multiplier go back to P3 state?
Don't worry, PBO settings displayed won't apply at all.
SMU 43.22.00 according to ZenStates
PE4 did nothing at all

Last edited by gobu; 09-23-2019 at 11:29 AM.
gobu is offline  
post #207 of 214 (permalink) Old 09-23-2019, 11:25 AM
New to Overclock.net
 
infraredbg's Avatar
 
Join Date: Nov 2014
Posts: 49
Rep: 14 (Unique: 6)
You should be able to see the SMU version displayed at the top right corner of the app.

New beta version is up, hopefully works on your system. Had to disable PE/PBO/XFR settings.
https://zenstates.protonrom.com/
Attached Images
 
infraredbg is offline  
post #208 of 214 (permalink) Old 09-23-2019, 11:33 AM
New to Overclock.net
 
Join Date: Aug 2019
Posts: 10
Rep: 0
Quote: Originally Posted by infraredbg View Post
You should be able to see the SMU version displayed at the top right corner of the app.

New beta version is up, hopefully works on your system. Had to disable PE/PBO/XFR settings.
https://zenstates.protonrom.com/
Yeah, I'd eddited my last reply
It's 43.22.00
gobu is offline  
post #209 of 214 (permalink) Old 09-23-2019, 11:43 AM
New to Overclock.net
 
Join Date: Aug 2019
Posts: 10
Rep: 0
Still have that problem
Attached Images
 
gobu is offline  
post #210 of 214 (permalink) Old 09-23-2019, 12:12 PM
New to Overclock.net
 
infraredbg's Avatar
 
Join Date: Nov 2014
Posts: 49
Rep: 14 (Unique: 6)
Have you uninstalled previous service with the uninstall.bat?
If yes, then I have no clue at the moment.
infraredbg is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off