Is my CPU faulty? - Overclock.net - An Overclocking Community
Forum Jump: 

Is my CPU faulty?

 
Thread Tools
post #1 of 6 (permalink) Old 11-25-2019, 08:12 PM - Thread Starter
New to Overclock.net
 
Join Date: Nov 2019
Posts: 4
Rep: 0
Is my CPU faulty?

Hey guys so I am a first time builder. I have an issue where games are not performing the way I think they should be. Even though I do get a lot of fps (around 120+), the games like modern warfare, fortnite etc. do not feel smooth. Also when I aim in it feels like the cursor is stuttery when I make small and steady adjustments.

I play on a 60hz 1080 monitor and tried to lock the fps to many different caps to see how it effects things (ex 60,80,120,unlimited), they all feel different when playing games but none of them feel smooth/ the way I think they should.

I am basically asking for your opinion/advice of how to check if this a hardware issue, a monitor issue, or maybe a software or settings issue.


Lastly, my parts are

CPU: Ryzen 5 3600
Motherboard: MSI MPG x570 Gaming Edge WIFI
GPU: Nvidia Geforce RTX 2070 Super
SSD: Samsung 970 EVO M.2 NVMe
Memory: Corsair Vengance LPX 2x8GB DDR4 DRAM 3200

Here are the link to my latest benchmark:
https://www.userbenchmark.com/UserRun/22052734
I have ran CINEBENCH and it looks like my CPU is underperforming. I am getting a scores like 3056, 2978.


Please advise if it is possible that my parts are bottle-necked or how I can check if I really do have a faulty part. Let me know if I can provide more info.
MarcinAMD is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 11-25-2019, 09:07 PM
New to Overclock.net
 
gerardfraser's Avatar
 
Join Date: Jan 2009
Posts: 734
Rep: 87 (Unique: 67)
No your gear is not faulty.

Buy a freesync monitor or gsync monitor,that would work.

Turn on Vsync on the 60Hz monitor so it only runs at 60FPS.Since you have a Nvidia card there are many options in the control panel.
gerardfraser is offline  
post #3 of 6 (permalink) Old 12-04-2019, 08:28 AM
New to Overclock.net
 
loki993's Avatar
 
Join Date: Dec 2008
Posts: 332
Rep: 6 (Unique: 6)
Dont run vsync, vsync will add input lag and ruin the experience in games like he's playing, vsync is terrible with FPS games. Are your frames consistent or do they bounce around a ton? with a 3600 and a 2070 I would think you should be able to easily get 60 frames consistently and I would think you should be able to be rock solid at 60 because that setup is capable of much more at 1080. Im not sure what kind of smooth you are looking for but if you have played at over 100 frames, on a 144 hz monitor that is capable of showing it, for a period of time, 60 just isn't going to look as smooth. It doesn't sound like that's the case though so I'm not sue aht smooth you are comparing it to.
loki993 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 12-04-2019, 08:56 AM
New to Overclock.net
 
speed_demon's Avatar
 
Join Date: Nov 2006
Location: Wisconsin
Posts: 1,680
Rep: 95 (Unique: 74)
+1 on leaving Vsync off for FPS games.

I was playing the new modern warfare on old hardware and had no stutters or lag. You should be having a silky smooth experience with what you've listed as specs.

Maybe try booting to safe mode & using Display Driver Uninstaller to remove video drivers - Then reinstall the video driver when you boot back to windows. I've heard that Geforce Experience can create problems with games where there weren't problems before so it looks like it's best to not install it.

Quis custodiet ipsos custodes?


speed_demon is offline  
post #5 of 6 (permalink) Old 12-09-2019, 09:27 AM
New to Overclock.net
 
mulkman's Avatar
 
Join Date: Jun 2009
Posts: 132
Rep: 3 (Unique: 3)
Maybe try using MSI afterburner to check utilization of CPU / Memory / GPU during gaming. That will indicate if your getting a bottleneck anywhere by checking percentage levels.

Last edited by mulkman; 12-09-2019 at 09:31 AM.
mulkman is offline  
post #6 of 6 (permalink) Old 01-14-2020, 01:17 PM
New to Overclock.net
 
Join Date: Jan 2020
Posts: 1
Rep: 0
turn on vsync from the Nvidia drivers ( global settings ), play your games in fullscreen turn off vsync from in game settings.
i had this similar issue with Path of Exile (showed 200+ fps but felt like 40), doing this fixed it ( Using an RX Vega 56 ) with a Freesync 144hz monitor.
Vega56User69 is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off