*Solved* Cannot find Pagefile.sys on C Drive - Overclock.net - An Overclocking Community

Forum Jump: 

*Solved* Cannot find Pagefile.sys on C Drive

Reply
 
Thread Tools
post #1 of 24 (permalink) Old 12-06-2013, 01:45 PM - Thread Starter
New to Overclock.net
 
Destrto's Avatar
 
Join Date: Apr 2013
Location: Richardson, TX
Posts: 2,250
Rep: 80 (Unique: 63)
Hey guys, I was working on Mom's computer (Windows 7 Home Premium 32bit) earlier and noticed that at every restart she gets this Windows error page that states:

"Windows created a temporary paging file on your computer because of a problem that occurred with your paging file configuration when you started your computer. The total paging file size for all disk drives may be somewhat larger than the size you specified."

Now, I have tried a few steps in fixing this, however, I have not been able to so successfully.

Things I have done already:
Selected "show hidden files and folders"
Unselected "Hide protected operating system files"
Unselected "Automatically manage paging file size" from Virtual memory options.

Oddly though, is that when I go into C: Drive I do not see pagefile.sys, nor does a search find it. However, I DO find one in the spare D: Drive that is installed. I have tried following the steps in THIS guide, but as I've just explained, there is no pagefile.sys file to be found on C: once I have gotten to Step 6.

I have selected "Custom size" within the Virtual Memory window and set it to 0Mb as per the guide's directions. And the directions states that after restarting, I should be able to locate the pagefile.sys file from within C: and delete it, well, when I do this on my machine, there is no pagefile.sys file found. WHen I reenable it, it shows up in the D: drive instead of Drive C:. Even though in the Virtual memory window, Drive D: is still set to "None" for its Pagefile.

What I want to do essentially, is get the C; Drive's pagefile.sys file back; stop the pagefile.sys from being created on the D: Drive, and stop this annoying warning window every time the desktop restarts.

Can anybody help me figure this out? Any help is appreciated.

EK Club XCrossXFire ClubX
-OCN Water Cooling Club-
Destrto
(13 items)
CPU
AMD FX-8370
Motherboard
MSI 990FXA-Gaming
GPU
AMD PowerColor RX 580
RAM
G.Skill - Ripjaws X Series 16Gb
RAM
G.Skill - Ripjaws X Series 16 GB
Hard Drive
Samsung 850 500Gb
Hard Drive
Seagate 3 Tb
Power Supply
Raidmax Vampire 800 Watt
Cooling
EK-Suprema​cy MX CPU ​Block
Cooling
XSPC 240mm​ Radiator
Cooling
XSPC 240mm​ Radiator
Cooling
EK-XRES 140 DDC 3.2 PWM Elite
Case
HBT Gravity6
▲ hide details ▲
Destrto is offline  
Sponsored Links
Advertisement
 
post #2 of 24 (permalink) Old 12-06-2013, 02:22 PM
Overclock Failed...
 
billbartuska's Avatar
 
Join Date: Mar 2005
Location: Greater Chicagoland Area
Posts: 13,565
Rep: 1249 (Unique: 969)
Start > Computer (right click, choose properties) > Advanced System Settings > Performance (Settings) > Advanced > Virtual memory (Change).

You should see this which identifies the location and size of the pagefile(s)


https://www.overclock.net/images/smil...lame-small.gif5 GHz Overclock Club https://www.overclock.net/images/smil...lame-small.gifMisinformation is available from a variety of other sources. Misinformation is just like real information but wrong
....and enough power to shoot the speaker cones through the walls.
billbartuska is offline  
post #3 of 24 (permalink) Old 12-06-2013, 02:37 PM - Thread Starter
New to Overclock.net
 
Destrto's Avatar
 
Join Date: Apr 2013
Location: Richardson, TX
Posts: 2,250
Rep: 80 (Unique: 63)
Quote:
Originally Posted by billbartuska View Post

Start > Computer (right click, choose properties) > Advanced System Settings > Performance (Settings) > Advanced > Virtual memory (Change).

You should see this which identifies the location and size of the pagefile(s)
Warning: Spoiler! (Click to show)


Yes, I've gotten there. According to the guide I linked, I disabled (set the pagefile to 0Mb) on both drives.

This is what shows after a reboot. And I still get the warning popup.

Like I mentioned, when I go to look for the pagefile.sys file within C: Drive, there isn't one. According to the guide, there should be.

EK Club XCrossXFire ClubX
-OCN Water Cooling Club-
Destrto
(13 items)
CPU
AMD FX-8370
Motherboard
MSI 990FXA-Gaming
GPU
AMD PowerColor RX 580
RAM
G.Skill - Ripjaws X Series 16Gb
RAM
G.Skill - Ripjaws X Series 16 GB
Hard Drive
Samsung 850 500Gb
Hard Drive
Seagate 3 Tb
Power Supply
Raidmax Vampire 800 Watt
Cooling
EK-Suprema​cy MX CPU ​Block
Cooling
XSPC 240mm​ Radiator
Cooling
XSPC 240mm​ Radiator
Cooling
EK-XRES 140 DDC 3.2 PWM Elite
Case
HBT Gravity6
▲ hide details ▲
Destrto is offline  
Sponsored Links
Advertisement
 
post #4 of 24 (permalink) Old 12-06-2013, 02:52 PM
Overclock Failed...
 
billbartuska's Avatar
 
Join Date: Mar 2005
Location: Greater Chicagoland Area
Posts: 13,565
Rep: 1249 (Unique: 969)
You really can't eliminate a pagefile. Even if you set it to be zero, Windows will make one, though small, somewhere.
Windows won't run without it.

You use the screen I posted to size the pagefile and put it where you want it.

Without knowing your setup, you usually make the maximum pagefile size 1.5 times the size of the installed memory. It's best to put it on a drive other than the one that has the Windows folder on it, if you have more than one drive.

Run the computer normally for a few days, go back and see what the current pagefile size is. Then set that as both the MAX and MIN size. Not allowing Windows to dynamically change the size will keep the pagefile from getting fragmented.

https://www.overclock.net/images/smil...lame-small.gif5 GHz Overclock Club https://www.overclock.net/images/smil...lame-small.gifMisinformation is available from a variety of other sources. Misinformation is just like real information but wrong
....and enough power to shoot the speaker cones through the walls.
billbartuska is offline  
post #5 of 24 (permalink) Old 12-06-2013, 03:07 PM - Thread Starter
New to Overclock.net
 
Destrto's Avatar
 
Join Date: Apr 2013
Location: Richardson, TX
Posts: 2,250
Rep: 80 (Unique: 63)
Quote:
Originally Posted by billbartuska View Post

You really can't eliminate a pagefile. Even if you set it to be zero, Windows will make one, though small, somewhere.
Windows won't run without it.

You use the screen I posted to size the pagefile and put it where you want it.

Without knowing your setup, you usually make the maximum pagefile size 1.5 times the size of the installed memory. It's best to put it on a drive other than the one that has the Windows folder on it, if you have more than one drive.

Run the computer normally for a few days, go back and see what the current pagefile size is. Then set that as both the MAX and MIN size. Not allowing Windows to dynamically change the size will keep the pagefile from getting fragmented.

Like I said, there is not one visible. On either drive. I understand what you're saying, I've done a bit of research myself before posting here for help.

I'm not trying to resize the pagefile right now, I'm trying to figure out how I can remedy this warning page that I quoted in the OP. I get this warning page regardless of what I try right now, setting both drives to no pagefile, setting them to auto manage, and even setting them to a specific number in custom settings.

EK Club XCrossXFire ClubX
-OCN Water Cooling Club-
Destrto
(13 items)
CPU
AMD FX-8370
Motherboard
MSI 990FXA-Gaming
GPU
AMD PowerColor RX 580
RAM
G.Skill - Ripjaws X Series 16Gb
RAM
G.Skill - Ripjaws X Series 16 GB
Hard Drive
Samsung 850 500Gb
Hard Drive
Seagate 3 Tb
Power Supply
Raidmax Vampire 800 Watt
Cooling
EK-Suprema​cy MX CPU ​Block
Cooling
XSPC 240mm​ Radiator
Cooling
XSPC 240mm​ Radiator
Cooling
EK-XRES 140 DDC 3.2 PWM Elite
Case
HBT Gravity6
▲ hide details ▲
Destrto is offline  
post #6 of 24 (permalink) Old 12-06-2013, 03:15 PM
New to Overclock.net
 
linkin93's Avatar
 
Join Date: Dec 2009
Location: Australia
Posts: 6,189
Rep: 267 (Unique: 236)
It's simply foolish to always have a pagefile as 1.5x the size of your memory - what if you have 16GB or 32GB of RAM? It's going to eat up your drive for nothing. Win7 also sets it that large by default, if there's not enough room on the drive the installation will fail.

I have a static 2GB pagefile which is more than enough

The AMD ASRock Extreme Series Motherboard Club
Rkingsmiley.png FLAC > Essence STX > Beyerdynamic DT880 250 Ohm thumbsupsmiley.png
Quote:
Originally Posted by skitzogreg go_quote.gif

Hmm, I don't know of any other company that charges $15 for a kick to the testicles.
linkin93 is offline  
post #7 of 24 (permalink) Old 12-06-2013, 03:18 PM - Thread Starter
New to Overclock.net
 
Destrto's Avatar
 
Join Date: Apr 2013
Location: Richardson, TX
Posts: 2,250
Rep: 80 (Unique: 63)
Quote:
Originally Posted by linkin93 View Post

It's simply foolish to always have a pagefile as 1.5x the size of your memory - what if you have 16GB or 32GB of RAM? It's going to eat up your drive for nothing. Win7 also sets it that large by default, if there's not enough room on the drive the installation will fail.

I have a static 2GB pagefile which is more than enough

Please try to stay On Topic guys, and refrain from flaming others about their personal settings/opinions/suggestions. If you don't agree with it, leave it be.

EK Club XCrossXFire ClubX
-OCN Water Cooling Club-
Destrto
(13 items)
CPU
AMD FX-8370
Motherboard
MSI 990FXA-Gaming
GPU
AMD PowerColor RX 580
RAM
G.Skill - Ripjaws X Series 16Gb
RAM
G.Skill - Ripjaws X Series 16 GB
Hard Drive
Samsung 850 500Gb
Hard Drive
Seagate 3 Tb
Power Supply
Raidmax Vampire 800 Watt
Cooling
EK-Suprema​cy MX CPU ​Block
Cooling
XSPC 240mm​ Radiator
Cooling
XSPC 240mm​ Radiator
Cooling
EK-XRES 140 DDC 3.2 PWM Elite
Case
HBT Gravity6
▲ hide details ▲
Destrto is offline  
post #8 of 24 (permalink) Old 12-06-2013, 08:40 PM - Thread Starter
New to Overclock.net
 
Destrto's Avatar
 
Join Date: Apr 2013
Location: Richardson, TX
Posts: 2,250
Rep: 80 (Unique: 63)
Still cannot get this pagefile thing sorted out.

When I try to set it to a specific number, I still get the warning popup after a restart. Same goes for disabling it completely and setting it auto manage..

EK Club XCrossXFire ClubX
-OCN Water Cooling Club-
Destrto
(13 items)
CPU
AMD FX-8370
Motherboard
MSI 990FXA-Gaming
GPU
AMD PowerColor RX 580
RAM
G.Skill - Ripjaws X Series 16Gb
RAM
G.Skill - Ripjaws X Series 16 GB
Hard Drive
Samsung 850 500Gb
Hard Drive
Seagate 3 Tb
Power Supply
Raidmax Vampire 800 Watt
Cooling
EK-Suprema​cy MX CPU ​Block
Cooling
XSPC 240mm​ Radiator
Cooling
XSPC 240mm​ Radiator
Cooling
EK-XRES 140 DDC 3.2 PWM Elite
Case
HBT Gravity6
▲ hide details ▲
Destrto is offline  
post #9 of 24 (permalink) Old 12-06-2013, 10:02 PM
Windows Wrangler
 
Techie007's Avatar
 
Join Date: Apr 2013
Location: Ohio
Posts: 2,217
Rep: 340 (Unique: 250)
Quote:
Originally Posted by billbartuska View Post

You really can't eliminate a pagefile. Even if you set it to be zero, Windows will make one, though small, somewhere.
Windows won't run without it.

    Sorry to say, but this is simply not true.  I like to run my computers with no page files at all.  When properly disabled, there is no page file anywhere and Windows works just fine.  This is just as summarized in the article the OP linked: "By temporarily turning off virtual memory, you allow yourself to delete the (now-corrupt) paging file. Then when you re-enable virtual memory, Windows automatically builds a new paging file from scratch, and voilà, problem solved."

    @Destrto: How much space is free on C:\?  The only time I experienced this error was when I tried to create a pagefile on a HDD partition that I had assigned to letter B:\.  The pagefile would work in Windows immediately after setting it, but upon reboot, Windows would refuse to use the pagefile it had created on B:\, probably because of the unusual drive letter.  It would boot and give the same warning that you're seeing, and then create itself a pagefile on C:\.  After reassigning letter B:\ to letter G:\, the pagefile went on that partition with no difficulty.  In your case, my guess is that something, either permissions on the root of the drive, or a lack of space, is keeping it from creating the page file normally on C:\.

Techie007 is offline  
post #10 of 24 (permalink) Old 12-06-2013, 10:07 PM - Thread Starter
New to Overclock.net
 
Destrto's Avatar
 
Join Date: Apr 2013
Location: Richardson, TX
Posts: 2,250
Rep: 80 (Unique: 63)
Warning: Spoiler! (Click to show)
Quote:
Originally Posted by Techie007 View Post

    Sorry to say, but this is simply not true.  I like to run my computers with no page files at all.  When properly disabled, there is no page file anywhere and Windows works just fine.  This is just as summarized in the article the OP linked: "By temporarily turning off virtual memory, you allow yourself to delete the (now-corrupt) paging file. Then when you re-enable virtual memory, Windows automatically builds a new paging file from scratch, and voilà, problem solved."
Quote:
    @Destrto: How much space is free on C:\?  The only time I experienced this error was when I tried to create a page file on a HDD partition that I had assigned to letter B:\.  The page file would work in Windows immediately after setting it, but upon reboot, Windows would refuse to use the page file it had created on B:\, probably because of the unusual drive letter.  It would boot and give the same warning that you're seeing, and then create another pagefile on C:\.  After reassigning letter B:\ to letter G:\, the pagefile went on that partition with no difficulty.  In your case, my guess is that something, either permissions on the root of the drive, or a lack of space, is keeping it from creating the page file normally on C:\.

Currently around 90% free on C:, which is a 200GB drive. And the secondary drive (250GB) has absolutely nothing on it. SO insufficient space shouldn't be an issue. And the drive letters aren't anything weird, they are C and D.

What I've noticed is that when I do try to enable pagefile on either drive, reboot, and get the warning again, the pagefile has been added to the secondary drive. Regardless of which drive I state I want the pagefile to be implemented on, it gets placed on the D drive.

Odd thing is, even after disabling the pagefile like the guide suggests, I still get the error when I restart.

EK Club XCrossXFire ClubX
-OCN Water Cooling Club-
Destrto
(13 items)
CPU
AMD FX-8370
Motherboard
MSI 990FXA-Gaming
GPU
AMD PowerColor RX 580
RAM
G.Skill - Ripjaws X Series 16Gb
RAM
G.Skill - Ripjaws X Series 16 GB
Hard Drive
Samsung 850 500Gb
Hard Drive
Seagate 3 Tb
Power Supply
Raidmax Vampire 800 Watt
Cooling
EK-Suprema​cy MX CPU ​Block
Cooling
XSPC 240mm​ Radiator
Cooling
XSPC 240mm​ Radiator
Cooling
EK-XRES 140 DDC 3.2 PWM Elite
Case
HBT Gravity6
▲ hide details ▲
Destrto is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off