I need help fixing DPC Latency caused by storport.sys - Overclock.net - An Overclocking Community
Forum Jump: 

I need help fixing DPC Latency caused by storport.sys

Reply
 
Thread Tools
post #1 of 13 (permalink) Old 09-24-2017, 07:51 PM - Thread Starter
New to Overclock.net
 
WafflesTheWaffl's Avatar
 
Join Date: Sep 2017
Posts: 4
Rep: 0
Hi,
I am new to this forum. I made an account here because of an issue I have been having with DPC latency. I have spent hours trying to figure out how to fix it, but I have failed to find a solution.

To begin, I first noticed this issue after I cloned my Samsung SSD to my new Samsung 960 evo m.2 drive. After playing some games like battlegrounds, dark souls, and final fantasy, I noticed that each one of them would microstutter every 30 minutes or so with a buzzing noise. They last for only about a second and then the game continues like nothing happened. I did some research and found out about DPC latency so I downloaded LatencyMon and dpclat. I then played a game with both of them running in the background until one of these audio/video stutters occurred. As soon as it happened, I alt+tabbed to my desktop and brought the two programs into view. dpclat showed all green bars and then one massive red one followed by all small green bars again. LatencyMon just simply showed storport.sys as having the highest reported DPC routine execution time.
I am completely baffled. I uninstalled and updated all of my drivers (bios, audio, internet/lan from the ASUS website), uninstalled the 960 evo NVMe drivers to see if windows NVM drivers fixed the issue (they didnt), installed the latest samsung 2.2 nvme drivers again, disabled all of my overclocks, ran memtest and chkdsk, ran HD tune, used defraggler to optimize my m.2 and ssd, defragged my HDDs, updated my chipset, updated my gpu, disabled almost everything in device manager, turned off every service that wasnt made by windows, stopped every process that wasnt made by windows, ran sfc /scannow and successfully repaired corrupt files, installed (and then uninstalled after use) malwarebytes, adwcleaner, msert, and avira, used ccleaner to clean and repair registry, and others that I cannot think of at the moment. The issue still persists after all of this. It seems like the only resort would be to do a complete clean install of windows, but I have tweaked with too many settings to optimize this pc and it would take days to get everything back to where I had it. I am hoping someone can help me, as this problem started after I cloned my 940 pro to my 960evo (the 940 pro was previously my C drive with windows installed, but now it is the 960 evo m.2 running the OS).
Also, I dont know if it helps, but after cloning my SSD to my m.2 windows said it needed to be activated, so I activated it with KMS since my previous windows 7 key wouldnt work for some reason (I used my windows 7 key to get a free copy of windows 8, and then windows 8 automatically updated to windows 10). And I feel like this should be obvious, but running the samsung magician benchmarking tool for my m.2 shows a very high DPC latency spike for storport.sys, as does running HD tune, but I think this is just because of the heavy load the m.2 is under when using those tools. As of now, I turned my ram and CPU overclocks back to where I had them previously before I cloned my ssd to my m.2 since they shouldnt be the issue since I never had this program until I cloned my drive (I used samsung's migration tool to accomplish this).
Thanks in advance to whoever offers some advice!

Here is a quick summary of my specs (full speccy txt file and DPC checker results attached separately):



Spec Summary:
[W10ProV1703b15063 x64]
Operating System
Windows 10 Pro 64-bit
CPU
AMD Ryzen 7 1700X 54 °C
Summit Ridge 14nm Technology
RAM
16.0GB Dual-Channel Unknown @ 1529MHz (16-18-18-36)
Motherboard
ASUSTeK COMPUTER INC. PRIME X370-PRO (AM4) 33 °C
Graphics
BenQ XL2730Z ([email protected])
8176MB ATI Radeon RX Vega (ATI) 33 °C
Storage
238GB Samsung SSD 840 PRO Series (SSD) 29 °C
931GB Seagate ST1000DX002-2DV162 (SATA) 31 °C
931GB Seagate ST1000DM003-9YN162 (SATA) 29 °C
232GB Samsung SSD 960 EVO 250GB (Unknown)
1862GB Western Digital WD Elements 25A1 USB Device (SSD) 29 °C
Optical Drives
ATAPI iHBS112 2
ATAPI iHAS324 B
ELBY CLONEDRIVE SCSI CdRom Device
Audio
Realtek High Definition Audio
Operating System
Windows 10 Pro 64-bit
Computer type: Desktop
PSU is the EVGA Supernova 850 P2 (80 Plus Platinum), and my ram is in dual channel slots 1 and 3.

Speccy: https://drive.google.com/open?id=0B8snXLdwm3VhaDV3RTlRZUEzU2c

Screenshot 1: https://drive.google.com/open?id=0B8snXLdwm3VhTDNWYWZudWs1bXc
Screenshot 2: https://drive.google.com/open?id=0B8snXLdwm3VhN1FUc056aEdReUk
Screenshot 3: https://drive.google.com/open?id=0B8snXLdwm3VhVVplTHcwZnBtdzA

LatencyMon Results #1: https://drive.google.com/open?id=0B8snXLdwm3VhR01sQi0tUVRyb1k
LatencyMon Results #2: https://drive.google.com/open?id=0B8snXLdwm3VhdGhjREhIQ2FmSUU

Trace File 1 (biggest spike recorded with this one): https://drive.google.com/open?id=0B8snXLdwm3VhSnFScU1fZ0tqcnM
Trace File 2: https://drive.google.com/open?id=0B8snXLdwm3VhbS0wRGlDcnVvSWc
Trace File 3: https://drive.google.com/open?id=0B8snXLdwm3VhX1ZQVXR4T2hNZkE
WafflesTheWaffl is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 09-24-2017, 08:07 PM
New to Overclock.net
 
christoph's Avatar
 
Join Date: Jan 2009
Posts: 1,678
Rep: 30 (Unique: 26)
you're problem is windows 10, not the hardware, windows 10 stresses the drivers to make them fail, so the only driver you can have in windows 10 is a driver signed by microsoft


the problem is not going away as long you have windows 10

christoph is offline  
post #3 of 13 (permalink) Old 09-24-2017, 08:25 PM - Thread Starter
New to Overclock.net
 
WafflesTheWaffl's Avatar
 
Join Date: Sep 2017
Posts: 4
Rep: 0
but i didn't have this issue before... it only started after I cloned my SSD to my new m.2... so it should be fixable, right? I just need someone who knows how to read those trace files.
WafflesTheWaffl is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 09-25-2017, 01:12 AM
New to Overclock.net
 
christoph's Avatar
 
Join Date: Jan 2009
Posts: 1,678
Rep: 30 (Unique: 26)
Quote:
Originally Posted by WafflesTheWaffl View Post

but i didn't have this issue before... it only started after I cloned my SSD to my new m.2... so it should be fixable, right? I just need someone who knows how to read those trace files.

then make a clean install, the windows key is linked to you're msn account so it should activate by itself

windows still thinks that it's running of a SSD instead of the m.2 drive, so with a clean install and the proper drivers everything should be fine

christoph is offline  
post #5 of 13 (permalink) Old 09-28-2017, 06:42 AM
New to Overclock.net
 
Sellis97's Avatar
 
Join Date: Sep 2017
Posts: 1
Rep: 1 (Unique: 1)
This guy is a joke. He has no idea what he is talking about. The issue is caused by a faulty storage driver. Open Device Manager and scan for updates. The buzzing sound happens and your dpc latency skyrockets. You can do this multiple times and it happens everytime.

How to fix:

Click on IDE/ATAPI controllers tab

Now change the AMD Sata driver to SATA AHCI which is by Microsoft. And voila. No more stutters when Windows scans for driver updates. I had this problem too and it was driving me insane.
Sellis97 is offline  
post #6 of 13 (permalink) Old 09-28-2017, 07:01 AM
Some Guy
 
Bloodcore's Avatar
 
Join Date: Mar 2011
Location: Norway
Posts: 714
Rep: 46 (Unique: 42)
Quote:
Originally Posted by Sellis97 View Post

This guy is a joke. He has no idea what he is talking about. The issue is caused by a faulty storage driver. Open Device Manager and scan for updates. The buzzing sound happens and your dpc latency skyrockets. You can do this multiple times and it happens everytime.

How to fix:

Click on IDE/ATAPI controllers tab

Now change the AMD Sata driver to SATA AHCI which is by Microsoft. And voila. No more stutters when Windows scans for driver updates. I had this problem too and it was driving me insane.

This is the mostly correct answer.
Though I personally would just do a clean install and then install drivers directly from Samsung. (Would take 1-2 hours at most)
I'm not sure if the Samsung driver is better or worse in the DPC latency measurement, however it is better in throughput.

Windows 10 has no issues with SSDs or NVMe drivers.

Bloodcore is offline  
post #7 of 13 (permalink) Old 06-14-2019, 04:22 AM
New to Overclock.net
 
Join Date: Jun 2019
Posts: 1
Rep: 0
Quote: Originally Posted by Sellis97 View Post
This guy is a joke. He has no idea what he is talking about. The issue is caused by a faulty storage driver. Open Device Manager and scan for updates. The buzzing sound happens and your dpc latency skyrockets. You can do this multiple times and it happens everytime.

How to fix:

Click on IDE/ATAPI controllers tab

Now change the AMD Sata driver to SATA AHCI which is by Microsoft. And voila. No more stutters when Windows scans for driver updates. I had this problem too and it was driving me insane.
First of all, I AM SORRY for resurrecting a super old thread. I registered just to thank this man with all my heart. Ive been battling this issue for months, tracked DCP latency for weeks, tried browsing through an endless amount of threads online to find a solution from people with the same problem and I am just shocked and relieved at both how simple the fix was and that I somehow managed to stumble upon this thread. No more freezeups, no more sound stutters, no more storport.sys going bat**** after leaving the pc on overnight. THANK YOU.
rinleezwins is offline  
post #8 of 13 (permalink) Old 08-06-2019, 07:53 PM
New to Overclock.net
 
Join Date: Aug 2019
Posts: 1
Rep: 0
YOU LITERALLY SAVED MY COMPUTER AND I MADE AN ACCOUNT JUST TO SAY THANK YOU SO FREAKING MUCH.

Currently dancing around my house with pure joy to Celebration by Kool & The Gang because this nightmare is over.
Noah Schmidt is offline  
post #9 of 13 (permalink) Old 01-09-2020, 06:36 PM
New to Overclock.net
 
Veetus's Avatar
 
Join Date: Aug 2014
Posts: 5
Rep: 0
Quote: Originally Posted by Sellis97 View Post
This guy is a joke. He has no idea what he is talking about. The issue is caused by a faulty storage driver. Open Device Manager and scan for updates. The buzzing sound happens and your dpc latency skyrockets. You can do this multiple times and it happens everytime.

How to fix:

Click on IDE/ATAPI controllers tab

Now change the AMD Sata driver to SATA AHCI which is by Microsoft. And voila. No more stutters when Windows scans for driver updates. I had this problem too and it was driving me insane.
So I went to device manager, clicked scan for updates, the DPC latency is now amplified as expected.

But the next part I need guidance on, I found the IDE/ATAPI controllers tab in the device manager but I don't see how I can "change the AMD Sata driver to SATA AHCI."

How do I do this?

Thanks!
Veetus is offline  
post #10 of 13 (permalink) Old 01-09-2020, 06:37 PM
I Love this Hobby!
 
Gunderman456's Avatar
 
Join Date: Oct 2008
Posts: 7,759
Rep: 612 (Unique: 504)
Quote: Originally Posted by Veetus View Post
So I went to device manager, clicked scan for updates, the DPC latency is now amplified as expected.

But the next part I need guidance on, I found the IDE/ATAPI controllers tab in the device manager but I don't see how I can "change the AMD Sata driver to SATA AHCI."

How do I do this?

Thanks!
In Bios.

-Guide to 1st Case Modding for Better GPU(s) Performance/Cooling-
https://www.overclock.net/case-mod-wo...ing-guide
-Guide to 2nd Case Modding for Better GPU(s) Performance/Cooling-
https://www.overclock.net/case-mod-wo...e-fan-mod
Fast n' Cheap
(17 items)
Bit'O'Heaven
(16 items)
CPU
RYZEN 7 3700X
Motherboard
ASUS TUF GAMING X570-PLUS
GPU
MSI Radeon RX 5700 XT
RAM
G.SKILL Ripjaws V Series 32GB (2x16GB) DDR4 3600 16-19-19-39 CL 16 1.35V
Hard Drive
Corsair Force Series Gen.4 PCIe MP600 500GB NVMe M.2 SSD
Hard Drive
Seagate BarraCuda ST3000DM008 3TB 7200 RPM 64MB Cache SATA 6.0Gb/s 3.5" HDD
Optical Drive
LG 16X SATA Blu-Ray Internal Rewriter with 3D Playback and M-DISC Support BH16NS40
Power Supply
Fractal Design Ion+ 860P 80 PLUS Platinum Certified 860W Full Modular
Cooling
Noctua NH-D15
Case
Veddha GriderCase alpha V1
Operating System
Win 10 Pro 64bit
Monitor
Nixeus EDG 27" IPS Freesync 1440p 144Hz
Keyboard
Redragon K589 SHRAPNEL RGB Mechanical Keyboard
Mouse
Logitech G502 Hero
Mousepad
ALLSOP Redmond Mouse Pad
Audio
Cambridge Soundworks 5.1
Other
PulseLabz Challenger Gaming Chair
CPU
Intel i7 4770k @ 4.5GHz
Motherboard
Asus Maximus VI Rog Gene
GPU
Gigabyte AMD R9 290 @ Core 1160MHz & Memory 1350MHz
RAM
G.SKILL Trident X DDR3 16GB 2400MHz
Hard Drive
Samsung 840 PRO 256GB
Hard Drive
Seagate Barracuda 7200.14 3TB
Optical Drive
Pioneer Black Blu-ray 16X BD-R 2X BD-RE
Power Supply
EVGA SuperNOVA G2 1300W 80PLUS Gold Fully Modular
Cooling
Corsair H60 Push/Pull
Case
PC-JMK5-Cool 5 Open Frame Case
Operating System
Win 7 Pro 64bit
Monitor
Samsung 245BW 24" 1200p 60Hz
Keyboard
Logitech G15
Mouse
Logitech MX518
Mousepad
Corsair Vengeance MM200
Audio
Yamaha HTR-5830 Polk Audio 3.0
CPU
Intel Core i5-3570K @ 4.6GHz
Motherboard
ASRock Z77E-ITX mITX
GPU
Sapphire AMD HD 7990 @ Clock 900MHz & Memory 1100MHz
RAM
G.SKILL Ripjaws X DDR3 8GB 1600MHz @ 1866MHz
Hard Drive
Crucial SSD CT128M4SSD3 128GB mSATA SATA III 6GB
Hard Drive
Seagate Barracuda HDD 1TB
Optical Drive
LG DVD R/W
Power Supply
Corsair Professional Series Gold AX850 Fully Modular
Cooling
Corsair Cooling Hydro Series H100
Case
BitFenix Prodigy Mini-ATX Black Case
Operating System
Win 7 Pro 64bit
Monitor
Samsung TV 52"
Keyboard
Logitech K330 Wireless
Mouse
Logitech M215 Wireless
Mousepad
Corsair Vengeance MM200
Audio
Yamaha RX-V681 PSB/PolkAudio 5.1
▲ hide details ▲


Gunderman456 is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off