Overclock.net - An Overclocking Community - View Single Post - FIX: AHCI/SATA drives showing in "Safely Remove Hardware"

View Single Post
post #6 of (permalink) Old 05-20-2011, 08:30 AM
therock003
New to Overclock.net
 
therock003's Avatar
 
Join Date: Apr 2009
Posts: 629
Rep: 4 (Unique: 4)
Quote:
Originally Posted by t0adphr0g;12863711 
Ever since I set my BIOS to AHCI, I was plagued with my SATA connected drives showing up in the "Safely Remove Hardware" icon.

I understand that eSata, and USB devices should show up there. However, my internal devices, HDDs, CD/DVD/BluRay are showing up as well.

I didn't want to have to reinstall Windows 7, and set BIOS to SATA/RAID.
I wanted a better solution.
I found it!


This is a Registry fix.
You should ALWAYS back up your registry before you make changes - it only takes a second to do it, and if anything happens to it you'll need to reinstall...
Here we go...

Regedit your way to:
HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ services\ msahci
and create a new KEY called "Controller0"
inside Controller0, create a new KEY called "Channel0"
Now inside Channel0, create a new DWORD called "TreatAsInternalPort"
set this value to "1"
(this sets SATA port 0 (Drive C)to no longer show up in "Safely Remove Hardware")

Now, go back into the Controller0 folder again.
inside Controller0, create a new KEY called "Channel1"
Now inside Channel1, create a new DWORD called "TreatAsInternalPort"
set this value to "1"
(this sets SATA port 1 (Drive D)to no longer show up in "Safely Remove Hardware")

And so on, until all internal SATA ports are set to be treated as Internal.
My motherboard has 6 SATA ports, so I have set Channel0 to Channel5.

Here is an example of my registry change:

AHCIregedit.png

Your motherboard may have more or less SATA ports,
just remember to start with 0
6 Ports = 0-5 etc.

Now Reboot to allow changes.

Hooray! only external devices show up now!

Does this work the opposite way as well? Can i create this setting in order to make external drives appear in safely remove by setting the option "1"? Cause i dont get the safely remove for the eSata drive i have connected...

Also can i use safely remove on internal drives as well if AHCI is not enabled? Can this be done, and is it safe?

therock003 is offline