Deployment issues on Tomcat 8 - Overclock.net - An Overclocking Community

Forum Jump: 

Deployment issues on Tomcat 8

 
Thread Tools
post #1 of 2 (permalink) Old 12-11-2016, 05:17 AM - Thread Starter
New to Overclock.net
 
takoma's Avatar
 
Join Date: Sep 2016
Posts: 29
Rep: 0
Hi all,

I'm sorry to use this forum as a helpdesk but I have a rather urgent problem to solve:

My team has developed a Java EE website that was continuously tested and deployed during development on Tomcat 7. No issues there.
Now we have to move that code to the production server that happens to be Tomcat 8.0.29 (We were assured it would be Tomcat 7 before).

The problem is that when running on Tomcat 8, I can only log into the website using Firefox. Any Webkit based browser for exemple redirects me back to the index page after login, without me being actually logged in. I assume this is session related, as during the login process, we put client data in session and then use that data to render the index. So server cannot find the session after login when using webkit browsers...

If anyone has any idea, it would be really appreciated.

I can of course provide detailed infos but I don't know where to start...

Again, thanks

takoma is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-14-2016, 09:14 AM
New to Overclock.net
 
Mrzev's Avatar
 
Join Date: Feb 2008
Location: Texas
Posts: 2,258
Rep: 96 (Unique: 76)
This is one reason why I hate java. (most of my reasons are dumb tho) I had the same situation but the other way around. I created a simple websocket applet and when we installed it, it didnt work. I spent a ton of time debugging the issue, but it turns out the version on the server was the 1 before they added that feature.

Running into an issue like that going up a version is a bit odd though. It should be a simple fix in the java code though. Probably a flag or attribute they need to look for.



Mrzev is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off