getting issue while invoking a Asp.Net Core Web API from Xamarin - Overclock.net - An Overclocking Community

Forum Jump: 

getting issue while invoking a Asp.Net Core Web API from Xamarin

 
Thread Tools
post #1 of 2 (permalink) Old 07-05-2018, 03:42 AM - Thread Starter
Linux Lobbyist
 
Join Date: Jul 2018
Location: United Kingdom
Posts: 1
Rep: 0
getting issue while invoking a Asp.Net Core Web API from Xamarin

I am using the MobileServiceClient (Microsoft.Azure.Mobile.Client version 4.0.1) with the InvokeApiAsync method to do the call but always fails with a null exception. If I call an API that does not have authorization, it works fine.

So my question is if I can use the MobileServiceClient or this doesn't want to work with .NET Core. I don't want to call my APIs with HttpClient.
Ojusvee06 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-11-2018, 02:05 AM
Linux Lobbyist
 
Join Date: Jul 2018
Location: United Kingdom
Posts: 1
Rep: 0
I suggest you could create a custom HttpMessageHandler to add the token to the request and use MobileServiceClient send the request.
mohit0707 is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off