Odd username errors when translating pages - Overclock.net - An Overclocking Community

Forum Jump: 

Odd username errors when translating pages

 
Thread Tools
post #1 of 2 (permalink) Old 02-21-2012, 04:41 PM - Thread Starter
Retired Staff
 
zodac's Avatar
 
Join Date: Jul 2007
Location: Dublin, Ireland
Posts: 46,108
Rep: 509 (Unique: 309)

Before I start, I know this is an obscure bug, and not one that will get any priority. Nevertheless, I figured I may as well make a note for those users who do translate the site.

 

Reproducibility:

Yes, every time you translate it.

 

Repro Steps:

1) Go to Google Translate, and translate any forum on OCN (since they have a list of Moderators at the bottom).

2) Translate it into another language (for my example, I'm using Bulgarian).

3) Scroll to the bottom of the forum, and look at the Staff members in that forum.

 

You'll notice that some usernames have been translated (which they shouldn't have), and others have lost their formatting.

 

Expected:

That usernames would not be translated, and that the colour of their usernames would be consistent. In the example below, most Senior Mods keep their dark green formatting, but some do not.

 

In the following image, the blue box shows users who's names have been translated, while the red boxes show who no longer have the correct username colour.

 

dnhOz.png

 

Notes:

IE9.

 

I haven't check with any other languages; it's possible this bug only occurs when the language is in another script, so the more popular languages (French, Spanish, German,etc) won't be affected, but I haven't check yet.

 

URL:

http://translate.google.ie/translate?sl=auto&tl=bg&js=n&prev=_t&hl=en&ie=UTF-8&layout=2&eotf=1&u=http%3A%2F%2Fwww.overclock.net%2Ff%2F3%2Foverclock-net-related-news-and-information&act=url

 

You'll notice Bitemarks and Bloodstain's name has changed, and the colour of t4ct1c47, Chipp, Sin100 and ENTERPRISE (the username made up completely of random letters :)) are no longer correct.


I was not fired. sozo.gif



zodac is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-21-2012, 07:07 PM
Linux Lobbyist
 
Chipp's Avatar
 
Join Date: Dec 2004
Location: New York City
Posts: 21,999
Rep: 589 (Unique: 377)
The words themselves being translated is all due to Google's algorithms finding a translation for "enterprise" where there simply isn't one for "catmmm" or something else. Remember, that is all done on their end and is totally out of our control. Anything that can be translated with a reasonable degree of confidence will be.

As far as the color switching... that one is a little odd, and I'm honestly not sure whos issue it would be. Perhaps SJ can shed a little more light on what might cause that.

post-flame-small.gifKeep the standards high and the noise low. Do YOU have quality content?post-flame-small.gif

Can't get enough of Overclock.net? Keep up with us on Facebook!

For any time-sensitive issues, or anything pertaining to our business operations, email is a far better way to contact me than PM. Please remember you can contact any staff member via email to their username @overclocked.net.


Chipp is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off