[Official] Creative Sound Blaster Z, Zx & ZxR Series Club - Page 598 - Overclock.net - An Overclocking Community

Forum Jump: 

[Official] Creative Sound Blaster Z, Zx & ZxR Series Club

Reply
 
Thread Tools
post #5971 of 6002 (permalink) Old 07-27-2019, 01:47 AM
New to Overclock.net
 
EarlZ's Avatar
 
Join Date: Mar 2011
Location: Cebu City , Philippines
Posts: 2,498
Rep: 27 (Unique: 25)
Quote: Originally Posted by umeng2002 View Post
Make sure the SPDIF-Out volume is unmuted and all the way up in the Mixer panel. The SPDIF device cannot be disabled since it's being use to output the audio. make sure your speaker system is set to PCM and not DTS or DD.
Ive figured out what is causing the issue, windows sound mixer shows the selected device as speskers but upon checking with windows sound control panel it selects the output to spdif thus causing no audio.

What is the ideal volume level to set for digital to avoid distortion or signal amplification as I want my passive pre-amp to control the volume.

9700K / Gigabyte Z390 Master / Gigabyte 2080TI Gaming OC / 16GB G.Skill Trident Z RGB / Samsung Evo 860 & 850 500GB / Creative Sound Blaster Z / Acer Predator X34P
EarlZ is offline  
Sponsored Links
Advertisement
 
post #5972 of 6002 (permalink) Old 07-27-2019, 01:50 AM
New to Overclock.net
 
umeng2002's Avatar
 
Join Date: Jul 2010
Location: Florida
Posts: 3,133
Rep: 170 (Unique: 106)
100% volume for digital outputs. Anything less is technically a degradation of the signal.

CPU
AMD Ryzen 2700X
Motherboard
Asus Prime X470-Pro
GPU
EVGA GeForce RTX 2070 XC Ultra
RAM
TeamGroup T-Force 16 GB (2x8) Pro Dark (B-die TDPGD416G3200HC14ADC01)
Hard Drive
Samsung 840 EVO 250 GB
Power Supply
Seasonic Focus Plus Platinum SSR-750PX
Cooling
Corsair H80i (not V2 or GT)
Monitor
LG 34UC80-B
Keyboard
Logitech G413
Mouse
Logitech G503 RGB
Audio
Creative SoundBlaster Z (OEM)
▲ hide details ▲
umeng2002 is offline  
post #5973 of 6002 (permalink) Old 07-31-2019, 07:57 PM
New to Overclock.net
 
EarlZ's Avatar
 
Join Date: Mar 2011
Location: Cebu City , Philippines
Posts: 2,498
Rep: 27 (Unique: 25)
Quote: Originally Posted by umeng2002 View Post
100% volume for digital outputs. Anything less is technically a degradation of the signal.
Thanks, and is it 50% if I am using the analog out on the SBZ ?

9700K / Gigabyte Z390 Master / Gigabyte 2080TI Gaming OC / 16GB G.Skill Trident Z RGB / Samsung Evo 860 & 850 500GB / Creative Sound Blaster Z / Acer Predator X34P
EarlZ is offline  
Sponsored Links
Advertisement
 
post #5974 of 6002 (permalink) Old 07-31-2019, 08:00 PM
Indentified! On the Way!!
 
LancerVI's Avatar
 
Join Date: May 2012
Posts: 2,596
Rep: 153 (Unique: 114)
I have the Sound Blaster Ae-9. Sounds Amazing!!!!! The breakout box with a pair of Sennheiser 650s; I didn't realize how good it would sound. It's pretty amazing.

Just upgraded from X-Fi Titanium HD.
LancerVI is offline  
post #5975 of 6002 (permalink) Old 08-01-2019, 05:47 AM
New to Overclock.net
 
umeng2002's Avatar
 
Join Date: Jul 2010
Location: Florida
Posts: 3,133
Rep: 170 (Unique: 106)
Quote: Originally Posted by EarlZ View Post
Thanks, and is it 50% if I am using the analog out on the SBZ ?
For analog, it depends if it clipping or not. I would hope 100% volume doesn't clip, then you can just control the volume with an external amp. If you're running headphones right off the card, then set the volume to whatever you like.

I've never used the SBz with analog out, so I'm not sure of it's behavior.

CPU
AMD Ryzen 2700X
Motherboard
Asus Prime X470-Pro
GPU
EVGA GeForce RTX 2070 XC Ultra
RAM
TeamGroup T-Force 16 GB (2x8) Pro Dark (B-die TDPGD416G3200HC14ADC01)
Hard Drive
Samsung 840 EVO 250 GB
Power Supply
Seasonic Focus Plus Platinum SSR-750PX
Cooling
Corsair H80i (not V2 or GT)
Monitor
LG 34UC80-B
Keyboard
Logitech G413
Mouse
Logitech G503 RGB
Audio
Creative SoundBlaster Z (OEM)
▲ hide details ▲
umeng2002 is offline  
post #5976 of 6002 (permalink) Old 08-09-2019, 04:42 AM
New to Overclock.net
 
Vlada011's Avatar
 
Join Date: May 2012
Location: Belgrade, Serbia
Posts: 1,964
Rep: 38 (Unique: 28)
Quote: Originally Posted by LancerVI View Post
I have the Sound Blaster Ae-9. Sounds Amazing!!!!! The breakout box with a pair of Sennheiser 650s; I didn't realize how good it would sound. It's pretty amazing.

Just upgraded from X-Fi Titanium HD.

Really? I believed sound is amazing.
Everyone who visit me and we play games can't believe how sound is nice and look speakers, some ancient Creative Inspire...
I say it's not speakers, it's SBZxR. But I believe AE-9 is better and optimized for Windows 10.
Too bad I don't have money to replace SBZxR.

Is it AE-7 same board as AE-9 only without DAC? Or weaker sound card.
Dedicate high end sound card give you such clear realistic sound effects even when sound is loud.
No distortion. If I replace SBZxR with onboard audio, sound will be like I turn volume for 20% and sound quality will be lost.
Bass and treble will be higher 20-30%... etc and I will not hear some effects at all. No gaming without good sound card, at least SBZ.

I would like so much to try AE-9 and Audioengine A2+ or A5+.
That's paradise, one of best setup for gaming at the moment.

I don't use headphones but Sennheiser is only brand I would pay. They are specialized for them and I would never bought headphones from some of PC brands. Sennheiser cost 250-260$ but worth, have gaming and Audiophille headphones.

Last edited by Vlada011; 08-09-2019 at 04:58 AM.
Vlada011 is offline  
post #5977 of 6002 (permalink) Old 08-09-2019, 04:54 AM
New to Overclock.net
 
ZorracK's Avatar
 
Join Date: Aug 2014
Posts: 15
Rep: 0
I change my Sb card Creative Z bulk to AE-5!
What a change to flac and everything!
And I dont have any good speakers, just Creative T40 II
Totally worth it!

ZorracK is offline  
post #5978 of 6002 (permalink) Old 08-09-2019, 05:01 AM
New to Overclock.net
 
Vlada011's Avatar
 
Join Date: May 2012
Location: Belgrade, Serbia
Posts: 1,964
Rep: 38 (Unique: 28)
I have Inspire T5900. I wait to Audioengine A2+ become available in Black color.
Only White are availble close to me. Black and Red are sold. Next months is new shipment and I get new speakers.
AUDIOENGINE A2+ non wireless.

They are great, they launch and Wireless version of same speakers.
Only evidence how much people love them.
Vlada011 is offline  
post #5979 of 6002 (permalink) Old 08-10-2019, 08:50 AM
New to Overclock.net
 
PainKiller89's Avatar
 
Join Date: Apr 2012
Posts: 585
Rep: 7 (Unique: 6)
Which drivers should i use OEM or Pax? Please Advise for sound blaster z

PainKiller89 is offline  
post #5980 of 6002 (permalink) Old 08-23-2019, 12:55 PM
New to Overclock.net
 
Join Date: Aug 2019
Posts: 5
Rep: 0
Hi guys. I've bought a Sound Blaster Z in 2017 but it never worked very well. The problem is that I can use either DTS Connect or Dolby Digital Live to sendo 5.1 channels to my home theater (that only has optical S/PDIF input) and everything works fine in videos and games. But the thing is that in the middle of any game the sound vanishes and I need to restart Windows to get the audio back. I've tried three different drivers versions in Creative downloads page but the same thing happens.

Does someone had this problem and solved?
antonioli is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off