[Official] Creative Sound Blaster Z, Zx & ZxR Series Club - Page 601 - Overclock.net - An Overclocking Community

Forum Jump: 

[Official] Creative Sound Blaster Z, Zx & ZxR Series Club

Reply
 
Thread Tools
post #6001 of 6017 (permalink) Old 10-12-2019, 08:47 PM
New to Overclock.net
 
Join Date: Feb 2019
Posts: 16
Rep: 0
Looks like they solved the DDL/DTS issue in this last driver, I have applied the sbx.reg patch and at now no more issues using optical connection with DTS Connect.

// Windows 10 Pro // Sharkoon TG5 // Gigabyte GA-AX370-Gaming 3 // Ryzen 5 1600 // Cooler Master HYPER H410R // 2x8GB DDR4 2666MHz Crucial Ballistix Sport AT // Crucial BX500 240GB // WD Blue 1TB // Sapphire Nitro+ RX 580 8GB // Creative Sound Blaster Z // AKG K240 MKII // Sony Pulse Elite Edition // Samsung HT-C550 // Corsair CX650M // Logitech G213 Prodigy // Logitech G402 Hyperion Fury // Acer VA270H //
sngbird is offline  
Sponsored Links
Advertisement
 
post #6002 of 6017 (permalink) Old 10-18-2019, 04:20 AM
New to Overclock.net
 
Vlada011's Avatar
 
Join Date: May 2012
Location: Belgrade, Serbia
Posts: 1,972
Rep: 39 (Unique: 29)
What can you say about new driver for Windows 10 with SBZxR.
I didn't even knew they launch him.
Maybe they decide to back in life SBZxR.
I only use sound card without daughter board.

Last edited by Vlada011; 10-18-2019 at 04:24 AM.
Vlada011 is offline  
post #6003 of 6017 (permalink) Old 10-20-2019, 08:36 PM
New to Overclock.net
 
EarlZ's Avatar
 
Join Date: Mar 2011
Location: Cebu City , Philippines
Posts: 2,501
Rep: 27 (Unique: 25)
I installed the latest drivers and I can now get the Smart Volume to work via optical out to my desktop DAC.

9700K / Gigabyte Z390 Master / Gigabyte 2080TI Gaming OC / 16GB G.Skill Trident Z RGB / Samsung Evo 860 & 850 500GB / Creative Sound Blaster Z / Acer Predator X34P

Last edited by EarlZ; 10-21-2019 at 02:53 AM.
EarlZ is offline  
Sponsored Links
Advertisement
 
post #6004 of 6017 (permalink) Old 10-25-2019, 05:24 AM
New to Overclock.net
 
Vlada011's Avatar
 
Join Date: May 2012
Location: Belgrade, Serbia
Posts: 1,972
Rep: 39 (Unique: 29)
SBZXR is live AGAIN.
I always liked mine sound card.
I was so sad because they didn't support properly with drivers.
I disable Hardware ID in registry and now Windows can't update Sound Blaster Controller or driver automatically even if new version show up.
I do that and with NVIDIA driver because 399.xx last work best with GTX1080Ti.
Vlada011 is offline  
post #6005 of 6017 (permalink) Old 11-05-2019, 07:32 AM
New to Overclock.net
 
Join Date: Nov 2019
Posts: 5
Rep: 0
Sound in games get muffed when someone speaks

Hello people

Could anyone please tell me how I can try to solve this problem?

This happens in many games. When a character speaks, the sound of the game get low, muffled. I'm not referring about talking to other people in microphone. But to the game characters themselves (NPC's, Storytellers, etc).
In some games the sound returns to normal when the character stops talking, in others the sound of the game keeps muffled.

For example, I am currently playing a game of air combat, and early in the mission, I receive radio instructions from the commander, and the sound fades completely. I can't even hear the engine of the plane the whole game. . And it stays that way until the next mission, where the problem return.

The problem occurs in both, speakers and headphones.
I use updated Windows 10 and have a Sound Blaster Zx with the latest drivers installed.

Can someone help? You are my last hope. > _ <
phython is offline  
post #6006 of 6017 (permalink) Old 11-05-2019, 05:26 PM
Windows 10 Gamer
 
Join Date: Jun 2014
Location: NW Indiana
Posts: 2,499
Rep: 45 (Unique: 37)
Quote: Originally Posted by phython View Post
Hello people

Could anyone please tell me how I can try to solve this problem?

This happens in many games. When a character speaks, the sound of the game get low, muffled. I'm not referring about talking to other people in microphone. But to the game characters themselves (NPC's, Storytellers, etc).
In some games the sound returns to normal when the character stops talking, in others the sound of the game keeps muffled.

For example, I am currently playing a game of air combat, and early in the mission, I receive radio instructions from the commander, and the sound fades completely. I can't even hear the engine of the plane the whole game. . And it stays that way until the next mission, where the problem return.

The problem occurs in both, speakers and headphones.
I use updated Windows 10 and have a Sound Blaster Zx with the latest drivers installed.

Can someone help? You are my last hope. > _ <
Have you completely uninstalled all creative drivers, restarted, then reinstalled the driver?

The Dark Knight
(25 items)
CPU
i7 4930k
Motherboard
ASUS Rampage IV Black Ed
GPU
EVGA GTX 1070 SC ACX 3.0
RAM
G.Skill Trident X Series 32GB (4 x 8GB) DDR3-2133
Hard Drive
Samsung 840 Pro
Hard Drive
Western Digital BLACK SERIES 7200RPM
Hard Drive
San Disk Ultra II
Hard Drive
Seagate 4TB Gaming SSHD
Optical Drive
LG Blu Ray 16x Multi Disc
Power Supply
EVGA G2 1000w Gold Plus
Cooling
Swiftech H 240-X
Cooling
Watercool Heatkiller IV Pro Clean Acrylic
Cooling
Swiftech H 140-X
Cooling
Watercool Heatkiller IV Pro Nickel/Black 1070
Case
Phantom 820 Black
Operating System
MS Windows 10 Pro
Monitor
Vizio 24" 1080p TV
Monitor
AOC G2460PG 24" 1ms (GTG) 144 Hz Gaming Monitor, NVIDIA G-SYNC
Keyboard
Corsair K95 RGB
Mouse
Logitech G502 Proteus Core
Mouse
None
Audio
Sound Blaster Zx
Audio
Logitech z906 5.1 surround speaker system
Other
NZXT Hue+
Other
NZXT Grid+ V2
▲ hide details ▲
Madmaxneo is offline  
post #6007 of 6017 (permalink) Old 11-05-2019, 06:49 PM
New to Overclock.net
 
umeng2002's Avatar
 
Join Date: Jul 2010
Location: Florida
Posts: 3,141
Rep: 170 (Unique: 106)
Quote: Originally Posted by EarlZ View Post
I installed the latest drivers and I can now get the Smart Volume to work via optical out to my desktop DAC.
Mmmm... I've never had issues using the DSP effects over optical.

CPU
AMD Ryzen 2700X
Motherboard
Asus Prime X470-Pro
GPU
EVGA GeForce RTX 2070 XC Ultra
RAM
TeamGroup T-Force 16 GB (2x8) Pro Dark (B-die TDPGD416G3200HC14ADC01)
Hard Drive
Samsung 840 EVO 250 GB
Power Supply
Seasonic Focus Plus Platinum SSR-750PX
Cooling
Corsair H80i (not V2 or GT)
Monitor
LG 34UC80-B
Keyboard
Logitech G413
Mouse
Logitech G503 RGB
Audio
Creative SoundBlaster Z (OEM)
▲ hide details ▲
umeng2002 is offline  
post #6008 of 6017 (permalink) Old 11-06-2019, 02:00 AM
New to Overclock.net
 
Join Date: Nov 2019
Posts: 5
Rep: 0
Quote: Originally Posted by Madmaxneo View Post
Have you completely uninstalled all creative drivers, restarted, then reinstalled the driver?
Yes, I did.

But this is a problem that has realized a lot longer. Same happened with the drivers of 2017.
phython is offline  
post #6009 of 6017 (permalink) Old 11-06-2019, 03:36 PM
New to Overclock.net
 
PainKiller89's Avatar
 
Join Date: Apr 2012
Posts: 588
Rep: 7 (Unique: 6)
What driver is everyone using for sound blaster z? Please let me know.

PainKiller89 is offline  
post #6010 of 6017 (permalink) Old 11-06-2019, 05:22 PM
Windows 10 Gamer
 
Join Date: Jun 2014
Location: NW Indiana
Posts: 2,499
Rep: 45 (Unique: 37)
Quote: Originally Posted by phython View Post
Yes, I did.

But this is a problem that has realized a lot longer. Same happened with the drivers of 2017.
I have the Zx and I had an issue somewhat like this a while back with a couple of games but I honestly do not remember what I did to fix it. I believe it had to do with uninstalling the drivers a few times and finally doing it in safe mode. Then I installed both patches (which according to many they are the same patch) but only one of the patches ever worked for me. I haven't had any issues with my Zx card in well over a year I believe.

Quote: Originally Posted by PainKiller89 View Post
What driver is everyone using for sound blaster z? Please let me know.
I am running driver 6.0.102.50

The Dark Knight
(25 items)
CPU
i7 4930k
Motherboard
ASUS Rampage IV Black Ed
GPU
EVGA GTX 1070 SC ACX 3.0
RAM
G.Skill Trident X Series 32GB (4 x 8GB) DDR3-2133
Hard Drive
Samsung 840 Pro
Hard Drive
Western Digital BLACK SERIES 7200RPM
Hard Drive
San Disk Ultra II
Hard Drive
Seagate 4TB Gaming SSHD
Optical Drive
LG Blu Ray 16x Multi Disc
Power Supply
EVGA G2 1000w Gold Plus
Cooling
Swiftech H 240-X
Cooling
Watercool Heatkiller IV Pro Clean Acrylic
Cooling
Swiftech H 140-X
Cooling
Watercool Heatkiller IV Pro Nickel/Black 1070
Case
Phantom 820 Black
Operating System
MS Windows 10 Pro
Monitor
Vizio 24" 1080p TV
Monitor
AOC G2460PG 24" 1ms (GTG) 144 Hz Gaming Monitor, NVIDIA G-SYNC
Keyboard
Corsair K95 RGB
Mouse
Logitech G502 Proteus Core
Mouse
None
Audio
Sound Blaster Zx
Audio
Logitech z906 5.1 surround speaker system
Other
NZXT Hue+
Other
NZXT Grid+ V2
▲ hide details ▲
Madmaxneo is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off