[NVIDIA] NVIDIA GPU DRIVER SECURITY WARNING - Page 3 - Overclock.net - An Overclocking Community
Forum Jump: 

[NVIDIA] NVIDIA GPU DRIVER SECURITY WARNING

Reply
 
Thread Tools
post #21 of 58 (permalink) Old 08-05-2019, 10:16 AM
Waiting for 7nm EUV
 
tpi2007's Avatar
 
Join Date: Nov 2010
Posts: 11,469
Rep: 898 (Unique: 504)
For those that don't want telemetry phoning home even after you've selected only the driver for install (i.e., no GFE) or used the older method of slimming down the install folders before installing, delete these in the following order (note: this applies to the regular driver installer):


1. Delete the folder "DisplayDriverRAS" from C:\Program Files\NVIDIA Corporation\Display.NvContainer\plugins\LocalSyste m\

2. Delete the folder "DisplayDriverRAS" from C:\Program Files\NVIDIA Corporation\


The reason why a basic driver install still phones home is that NVDisplay.Container.exe now has a plugin system (at least since driver 430.39) and can phone home telemetry with the help of a DLL that contains the telemetry portion. Deleting the above gets rid of the relevant DLL.


Talking about the topic, keeping a phone home routine in a basic driver component that then calls a DLL doesn't seem like a secure design. Companies will seemingly do anything to get telemetry these days unfortunately.



Last edited by tpi2007; 08-05-2019 at 10:42 AM.
tpi2007 is offline  
Sponsored Links
Advertisement
 
post #22 of 58 (permalink) Old 08-05-2019, 10:37 AM
Overclocker
 
JackCY's Avatar
 
Join Date: Jun 2014
Posts: 10,343
Rep: 345 (Unique: 244)
Those folders do not exist on DCH driver install.

They are under ProgramData and Users/All Users/. These are a copy of each other and there are no DLLs or executables there.

The only NV telemetry DLLs I found were in DriverStore, probably old Windows backups.
JackCY is offline  
post #23 of 58 (permalink) Old 08-05-2019, 10:39 AM
Waiting for 7nm EUV
 
tpi2007's Avatar
 
Join Date: Nov 2010
Posts: 11,469
Rep: 898 (Unique: 504)
Yeah, I'm talking about the regular driver installer, fetched from Nvidia's site. I'm using Windows 7 anyway, I don't have to deal with that additional regular / DCH mess.


tpi2007 is offline  
Sponsored Links
Advertisement
 
post #24 of 58 (permalink) Old 08-05-2019, 03:01 PM
New to Overclock.net
 
KCDC's Avatar
 
Join Date: Jan 2017
Posts: 1,015
Rep: 27 (Unique: 23)
Quote: Originally Posted by speed_demon View Post


Trying to install the DCH package mentioned tells me to contact Dell for appropriate drivers. It's dumb.
This happens to me after 1903 update, then installing new 2080ti cards. Not a dell, total custom build. Had to use DDU in Safe Mode, disable internet access so windows wouldn't auto-install their drivers, restart, then I could install whatever nvidia driver I wanted.

ZMT watercool setup -- Phanteks Enthoo Elite -- hwlabs gtr 420 x 2 -- -- xspc tx360 crossflow -- noctua A14 PWM x9 -- 9900x -- x299 TUF Mk1
Corsair Hydro X XC9 -- 64gb 3200 tridentZ Royal CL14 -- AX1500i -- 2x 7600p on hyper m.2 VROC 4TB -- EK ZMT Tubing -- Ek Fittings -- dual Aorus Waterforce xtreme 2080ti -- asus PG279UZ monitors x3 7680x1440 surround
Bertha5.5
(21 items)
CPU
9900x
Motherboard
X2399 TUF Mk1
GPU
Aorus 2080ti Waterforce Xtreme
GPU
Aorus 2080ti Waterforce Xtreme
RAM
TridentZ Royal 3200 CL14
Hard Drive
VROC 7600P x2
Power Supply
Ax1500i
Cooling
HWL GTR 420 x2
Cooling
XSPC TX360 Crossflow
Cooling
EK ZMT 10/16
Cooling
Corsair XC9
Cooling
Corsair XD5
Cooling
EK 10/16 Fittings
Cooling
Noctua A14 PWM x9
Cooling
Noctua NF-P12 PWM redux x3
Case
Enthoo Elite
Operating System
Win 10 Pro 64
Monitor
Asus PG279QZ x3
Keyboard
Corsair K95 RGB Platinum
Mouse
Corsair Nightsword
Mousepad
Corsair MM800
▲ hide details ▲
KCDC is offline  
post #25 of 58 (permalink) Old 08-05-2019, 03:24 PM
New to Overclock.net
 
Aussiejuggalo's Avatar
 
Join Date: May 2010
Location: Queensland, Australia
Posts: 3,462
Rep: 65 (Unique: 47)
Personally I'll wait till scumvida release a proper "stable" driver (if they can ever do that) before updating. The amount of problems I've had with Nvidia drivers since switching from my 290 to a 1070 are beyond annoying, constant black screens and driver and game crashes, even some BSOD .

Humble SM5 MK2
(23 items)
CPU
AMD Ryzen 7 1800X
Motherboard
MSI B350M Mortar Arctic
GPU
MSI GTX 1070 ARMOR OC
RAM
G.Skill Trident Z F4-3200C14D-32GTZKW 32GB
Hard Drive
Samsung 960 EVO NVMe M.2 250GB
Hard Drive
Samsung 850 EVO 1TB
Hard Drive
Western Digital Blue WD10EZEX 1TB
Power Supply
EVGA Supernova G2 850W
Cooling
Corsair H100i V2
Cooling
Corsair ML120 Pro x5
Case
CaseLabs SM5
Operating System
Windows 10 Enterprise 2016 LTSB 64-Bit
Monitor
Dell U2414H
Monitor
Dell U2414H
Monitor
Asus VG248QE
Keyboard
WASD CODE 87-Key - Cherry MX Clear
Mouse
Zowie FK1
Mousepad
Artisan ZERO MID Black Large Mouse Pad
Audio
JDS Labs Element
Audio
Sennheiser HD 599
Audio
Samson Q2U
Audio
Swan M50W Powered 2.1 System
Audio
Rode AI1
▲ hide details ▲
Aussiejuggalo is offline  
post #26 of 58 (permalink) Old 08-05-2019, 03:44 PM
New to Overclock.net
 
skupples's Avatar
 
Join Date: Apr 2012
Location: Fort Lauderdale
Posts: 21,612
Rep: 623 (Unique: 341)
interesting... I've had tons of black screen/fail to fully launch issues on sli in 10 gen, and its a tech i'd say I know pretty well, been using it consistently since fermi...

certain games won't launch, period anymore.

pretty sure mines related to board damage though, so I've gotta replacement at home that i'm installing this weekend.

if the sum of all parts bench fine individually, but fail to play nicely in real world 3D... what's the issue?

R.I.P. Zawarudo, may you OC angels' wings in heaven.
If something appears too good to be true, it probably is.
skupples is offline  
post #27 of 58 (permalink) Old 08-05-2019, 05:06 PM
Overclocker
 
JackCY's Avatar
 
Join Date: Jun 2014
Posts: 10,343
Rep: 345 (Unique: 244)
Quote: Originally Posted by KCDC View Post
This happens to me after 1903 update, then installing new 2080ti cards. Not a dell, total custom build. Had to use DDU in Safe Mode, disable internet access so windows wouldn't auto-install their drivers, restart, then I could install whatever nvidia driver I wanted.
Again a standard vs DCH driver. You're trying to install wrong version of driver (standard) after Windows already updated your system with a newer driver format version (DCH). People don't learn or like changes, that's the whole problem.
It should have been handled better by NV, yes, auto detect in the installer instead of only giving a download option on web. Hey at least the option on web is there, that wasn't always the case for some drivers and then you had to hunt down manually or make a support request for it when DCH was released. But it's been a long while since.

If you only search the driver install error message, you will find the explanation that you need to select standard vs DCH correctly pretty much instantly.
JackCY is offline  
post #28 of 58 (permalink) Old 08-05-2019, 08:01 PM
New to Overclock.net
 
KCDC's Avatar
 
Join Date: Jan 2017
Posts: 1,015
Rep: 27 (Unique: 23)
Quote: Originally Posted by JackCY View Post
Again a standard vs DCH driver. You're trying to install wrong version of driver (standard) after Windows already updated your system with a newer driver format version (DCH). People don't learn or like changes, that's the whole problem.
It should have been handled better by NV, yes, auto detect in the installer instead of only giving a download option on web. Hey at least the option on web is there, that wasn't always the case for some drivers and then you had to hunt down manually or make a support request for it when DCH was released. But it's been a long while since.

If you only search the driver install error message, you will find the explanation that you need to select standard vs DCH correctly pretty much instantly.

Ok... downloaded the latest studio driver from nvidia.. got that error.. did what I did and it worked. Why is the DCH driver not on the download page if that's supposed to be the new norm and I'm forced to take extra steps just to find it? And how does that mean I don't learn or like changes exactly? No reason to get rude over a driver.

ZMT watercool setup -- Phanteks Enthoo Elite -- hwlabs gtr 420 x 2 -- -- xspc tx360 crossflow -- noctua A14 PWM x9 -- 9900x -- x299 TUF Mk1
Corsair Hydro X XC9 -- 64gb 3200 tridentZ Royal CL14 -- AX1500i -- 2x 7600p on hyper m.2 VROC 4TB -- EK ZMT Tubing -- Ek Fittings -- dual Aorus Waterforce xtreme 2080ti -- asus PG279UZ monitors x3 7680x1440 surround
Bertha5.5
(21 items)
CPU
9900x
Motherboard
X2399 TUF Mk1
GPU
Aorus 2080ti Waterforce Xtreme
GPU
Aorus 2080ti Waterforce Xtreme
RAM
TridentZ Royal 3200 CL14
Hard Drive
VROC 7600P x2
Power Supply
Ax1500i
Cooling
HWL GTR 420 x2
Cooling
XSPC TX360 Crossflow
Cooling
EK ZMT 10/16
Cooling
Corsair XC9
Cooling
Corsair XD5
Cooling
EK 10/16 Fittings
Cooling
Noctua A14 PWM x9
Cooling
Noctua NF-P12 PWM redux x3
Case
Enthoo Elite
Operating System
Win 10 Pro 64
Monitor
Asus PG279QZ x3
Keyboard
Corsair K95 RGB Platinum
Mouse
Corsair Nightsword
Mousepad
Corsair MM800
▲ hide details ▲
KCDC is offline  
post #29 of 58 (permalink) Old 08-05-2019, 08:34 PM
sudo apt install sl
 
Join Date: Dec 2009
Posts: 5,860
Rep: 182 (Unique: 125)
Quote: Originally Posted by KCDC View Post
Ok... downloaded the latest studio driver from nvidia.. got that error.. did what I did and it worked. Why is the DCH driver not on the download page if that's supposed to be the new norm and I'm forced to take extra steps just to find it? And how does that mean I don't learn or like changes exactly? No reason to get rude over a driver.
There isn't any extra steps to find the DCH driver. It's also the default driver when downloading them.

Source: https://www.geforce.com/drivers
Attached Thumbnails
Click image for larger version

Name:	DCH.png
Views:	9
Size:	30.7 KB
ID:	286518  

Click image for larger version

Name:	DCH2.png
Views:	10
Size:	20.1 KB
ID:	286522  


Silent
(20 items)
CPU
Core i9 9900K... CoffeeTime! @ 5.1Ghz w/ 1.36v
Motherboard
Maximus VIII Formula
GPU
Radeon VII @ 2100Mhz/1250Mhz w/ 1218mV
RAM
TeamGroup Xtreem 32GB 3200Mhz CL15
Hard Drive
HP EX950 2TB
Hard Drive
Samsung 850 Evo 1TB
Hard Drive
Samsung 850 Evo 1TB
Power Supply
EVGA SuperNova 1200w P2
Cooling
EK Supremacy Full Copper Clean
Cooling
XSPC D5 Photon v2
Cooling
Black Ice Gen 2 GTX360 x2
Cooling
EK-Vector Radeon VII - Copper + Plexi
Case
Thermaltake Core X5 Tempered Glass Edition
Operating System
Clear Linux
Monitor
Acer XF270HUA
Keyboard
Cherry MX Board 6.0
Mouse
Logitech G600
Mouse
Alugraphics GamerArt
Audio
Definitive Technology Incline
Audio
SMSL M8A
▲ hide details ▲

Last edited by WannaBeOCer; 08-05-2019 at 08:38 PM.
WannaBeOCer is online now  
post #30 of 58 (permalink) Old 08-05-2019, 08:36 PM
New to Overclock.net
 
skupples's Avatar
 
Join Date: Apr 2012
Location: Fort Lauderdale
Posts: 21,612
Rep: 623 (Unique: 341)
componentized. i learned a new word today.

R.I.P. Zawarudo, may you OC angels' wings in heaven.
If something appears too good to be true, it probably is.
skupples is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off