Overclock.net - An Overclocking Community - View Single Post - [Solved] Wireless suddenly stopped working in Ubuntu 14.04

View Single Post
post #14 of (permalink) Old 10-11-2014, 12:42 PM
vpex
New to Overclock.net
 
vpex's Avatar
 
Join Date: Jun 2014
Posts: 548
Rep: 89 (Unique: 69)
The reason why the interface isn't appearing is because of a driver issuer, that is my take on it thus far; it could just as easily be a hardware switch that has been accidently knocked to the off position but not every laptop has this, some have sliders while others use a combination of fn and the f keys, left this in here but I have seen your reply above.

While it does show in lspci that is from the PCI configuration space and is not enough for working networking. Thats just the computer saying - 'yup its come into work today'.

Hop onto the computer and setup eth0, if you already have network access on the computer you can skip this step but if you haven't you can acquire a dhcp lease from your router, this is either 'sudo dhcpcd eth0' or 'sudo dhclient eth0;. You can do it from out of the terminal but those are the ways I know how to do it.

With network access on the computer you can download the driver for your broadcom card, on ubuntu this can be done simply as settings -> software and updates -> additional drivers and then setup the wireless driver.

If you wanted to do this from the command line you could:
Code:
sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source && sudo apt-get install b43-fwcutter firmware-b43-installer

It is also possible that this isn't a driver issue, the lspci command I got you to run earlier isn't perfect as it could have cut kernel modules out, lsmod is better for that. If you don't have network access it can be done another way but that takes more time and is slightly more complex.
vpex is offline