Overclock.net - An Overclocking Community - View Single Post - Displayport working intermittently (Out of Range and No Signal)

View Single Post
post #7 of (permalink) Old 02-15-2019, 08:58 PM
Falkentyne
New to Overclock.net
 
Falkentyne's Avatar
 
Join Date: Dec 2007
Location: Riverside
Posts: 5,565
Rep: 365 (Unique: 260)
Quote: Originally Posted by HeWhoDared View Post
Hey,

Running into an issue with my Benq Zowie XL2720 and my Asus Strix RTX 2060 where the display port is being weird and not working consistently. I have received both the no signal and out of range messages from my monitors before it boots into Windows, or if I do get into windows I'll turn the monitor off and then try to turn it back on and receive no signal detected, the only thing that has consistently remedied this was unplugging the display port and reconnecting it.

My resolution is 1920x1080 @ 144hz, I never had an issue with my GTX 1050ti at the same settings, but I was using exclusively Dual Link DVI to my monitor, I unfortunately don't a have a Dual Link DVI port to try on my new card.

I have tried updating drivers for the card, drivers for my monitor (also used the generic pnp monitor driver), got a new display port cable..same thing, tried both display ports on my card, same thing. What I find interesting is when I view BenQ Display Pilot, it shows that my refresh rate is at 144hz - same as nvidia control panel and windows; but below it says the recommended timing is 60hz? Odd, but my monitor should support 144hz.

Please share any and all ideas.. it's getting kind of annoying unplugging the display port cable every 5 or so boots..its weird that its not a consistent thing; it happens a couple times a week really.

As far as I know I have turned off any and all power saving related functions too, I have used the last few iterations of the nvidia drivers and have done the clean install option through nvidia experience.

I feel like I am running out of ideas to spitball and troubleshoot - I should have a hdmi cable somewhere I could see if I have issues at 60hz

Thanks in advance

Gabe
You may want to call Benq on the phone and ask for their engineering department in Taiwan to file a bug report.
This issue may be related to the original displayport problems that were fixed in the XL2420Z / XL2720Z" Benq V004 firmwares (before they ever were Zowie). Before v004 firmware, the XL2720Z was not even usable over displayport at anything higher than 60hz. This bug went all the way back to the old lightboost only "T" series monitors.

I assume your monitor is on v007 firmware? Can you check?
Power off the monitor, hold button #4 for 5 seconds and press the power button without releasing button #4. Release button #4 after you get a screen. The "ZOWIE" logo will not appear if you did this right. You can then press button #4 to enter the service menu. The strobe duty, strobe phase and single strobe settings are also there (for blur reduction).

The fixes implemented may still be having issues on newer cards. You can check blurbusters' forums but i haven't seen anyone with a RTX card with one of these yet (I guess for good reason, wouldn't you want Gsync or adaptive sync?).

[email protected] ghz, RX Vega 64, 32GB DDR4, Gigabyte Aorus Master, Seasonic Platinum 1000W, Corsair 760T
Alt: MSI GT73VR Throttlebook with 7820HK @ 4.7 ghz, GTX 1070 MXM TDP mod to 230W, 32 GB RAM
Falkentyne is offline