Bought a powersupply from newegg, comes with Non USA plug - Page 2 - Overclock.net - An Overclocking Community
Forum Jump: 

Bought a powersupply from newegg, comes with Non USA plug

Reply
 
Thread Tools
post #11 of 11 (permalink) Old 05-20-2020, 12:24 PM - Thread Starter
New to Overclock.net
 
andyroo89's Avatar
 
Join Date: Oct 2007
Posts: 4,176
Rep: 80 (Unique: 67)
Quote: Originally Posted by ThrashZone View Post
Hi,
Should be fine just flip the switch to multi-rail instead of single and good for 15 amp input.
Should be on a backup battery with gfi ground anyway.
Do you mean use single rail while using the 10 amp cord, and switch to multi when i get the 15 amp?


If you come across cute ginger girls and have pics pm me them :3
<In my avatar, IDK but TheODDone gave me this one <33
andyroo89 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off