FIX: AHCI/SATA drives showing in "Safely Remove Hardware" - Page 4 - Overclock.net - An Overclocking Community

Forum Jump: 

FIX: AHCI/SATA drives showing in "Safely Remove Hardware"

Reply
 
Thread Tools
post #31 of 57 (permalink) Old 03-31-2013, 07:47 PM
New to Overclock.net
 
qcktthfm1's Avatar
 
Join Date: Jul 2010
Location: BC, Canada
Posts: 891
Rep: 24 (Unique: 21)
I don't have Marvell controller. I can only disable similar thingy by each drive? Are they the same? thank you in advance redface.gif

qcktthfm1 is offline  
Sponsored Links
Advertisement
 
post #32 of 57 (permalink) Old 04-01-2013, 01:24 AM
New to Overclock.net
 
therock003's Avatar
 
Join Date: Apr 2009
Posts: 616
Rep: 4 (Unique: 4)
You need to go to your sata controllert and see if its there. On the picture you seem to be on the disk drives.

therock003 is offline  
post #33 of 57 (permalink) Old 04-01-2013, 10:57 PM
New to Overclock.net
 
qcktthfm1's Avatar
 
Join Date: Jul 2010
Location: BC, Canada
Posts: 891
Rep: 24 (Unique: 21)
qcktthfm1 is offline  
Sponsored Links
Advertisement
 
post #34 of 57 (permalink) Old 08-18-2013, 02:00 PM
New to Overclock.net
 
TexanByBlood's Avatar
 
Join Date: Aug 2013
Location: Aurora, Colorado
Posts: 1
Rep: 0
My question would be this: By making these changes in the registry how would that effect hot swapping? I have a Vantec hotswap bay for hot swapping drives, and then I also have the Thermaltake Level G10 which is set up for hot swapping drives. I can pull drives out and swap with other drives and the machine detects and reads them and adds them to my Computer tree. I have an AsRock FATAL1TY Professional motherboard which supports hot swapping. Im not sure what I did but it wasn't until recently that all my hard drives showed up in the Remove Hardware and eject media safely functionality of the system. I never had them down there before. It was always just thumb drives or some other mobile media like my cell phone etc. So by making these registry changes am I going to be blowing away my hot swap capabilities with the Vantec Hot Swap bay and the Hot Swap capabilities of the Level 10 GT case?

-=[Texanbyblood]=-
Quote:
Texan by blood, American By Birth, Coloradan By Choice, Southern By the Grace of God, & Gamer By Love
gunner2.gifsniper.gif
TexanByBlood is offline  
post #35 of 57 (permalink) Old 09-26-2013, 11:41 AM
Impossible is Nothing
 
felix's Avatar
 
Join Date: Jan 2008
Posts: 458
Rep: 14 (Unique: 14)
Has anyone found a similar registry fix for amd_sata driver ?

Sick.Dope.Sweet - Epic Extreme Sports Pictures
Quote:
Originally Posted by DooRules go_quote.gif

Windows on a spinner drive constitutes cruel and unusual punishment. biggrin.gif
felix is offline  
post #36 of 57 (permalink) Old 10-20-2013, 10:37 PM
New to Overclock.net
 
Join Date: Oct 2013
Posts: 1
Rep: 0
So I was in the same boat as others here and the registry tweak was not working for me. Like another poster earlier, I too have an AsRock Z77 motherboard.

I found this little work-around and haven't seen anyone else mention it, so I'll post it here in the hopes that it helps someone with the same problem I had. Basically there is an option under your ASmedia Sata Controller properties that let's you straight up disable this functionality. Just go in there and un-check the box:


Dralger is offline  
post #37 of 57 (permalink) Old 10-23-2013, 03:05 AM
New to Overclock.net
 
vishwas's Avatar
 
Join Date: Oct 2013
Posts: 1
Rep: 0
It is really excellent explanation from TOAD and really it is working. Now my "Safely remove" is not showing my internal hard disk drives( C,D,E). A million thanks to TOAD. You are rocking brother. Toad I have one small doubt that when we edit the registry instead of Channel0 if we type channel 0 what happens?
Difference is there is a space between Channel and Zero(0)..
vishwas is offline  
post #38 of 57 (permalink) Old 11-12-2013, 03:37 PM
New to Overclock.net
 
Join Date: Dec 2008
Location: Canada
Posts: 12
Rep: 0
Quote:
Originally Posted by therock003 View Post

Why dont i have this storage controllers on my device manager?

I don't have this option either.

I have a Rampage III Black Edition, also it doesn't seem to have installed the Marvell software, so it's stuck using Windows' own.

Michael

mlauzon is offline  
post #39 of 57 (permalink) Old 01-18-2014, 08:09 AM
New to Overclock.net
 
NoThreat's Avatar
 
Join Date: Jan 2014
Posts: 5
Rep: 0
I just found this topic and want to thanks t0adphr0g for this fix, it worked perfectly.

My only concern is after editing the registry now when I go to Device Manager/Disk drives/right click on a drive, properties and then click the Policies tab.

The "Removal Policy" section is gone from the menu where it said "Better performance (default)". I'm wondering if this effects the performance at all?


Before Fix
http://i1017.photobucket.com/albums/af296/nothreat1/Before-Fix_zps02662db3.jpg

After Fix
http://i1017.photobucket.com/albums/af296/nothreat1/After-Fix_zpsf5da89dc.jpg
NoThreat is offline  
post #40 of 57 (permalink) Old 01-27-2014, 07:35 PM
New to Overclock.net
 
NoThreat's Avatar
 
Join Date: Jan 2014
Posts: 5
Rep: 0
I guess not....
NoThreat is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off