Picked up a TCL 43S515 to replace the Seiki SE42UM I've been using as a monitor... - Page 2 - Overclock.net - An Overclocking Community

Forum Jump: 

Picked up a TCL 43S515 to replace the Seiki SE42UM I've been using as a monitor...

Reply
 
Thread Tools
post #11 of 11 (permalink) Old 05-28-2020, 04:44 PM
Overclocking Enthusiast
 
ozlay's Avatar
 
Join Date: Aug 2009
Location: USA
Posts: 5,911
Rep: 289 (Unique: 227)
After using the Custom resolution utility i was able to get 1440p 120hz to work. So it does overclock. But i had to use CRU. NVIDIA's kept failing to set it a custom refresh rate.

Rikka
(9 items)
CPU
Intel I5-7600k
Motherboard
Asrock Z270M Extreme 4
GPU
Titan X
RAM
Gskill Royal
Hard Drive
970 Evo
Hard Drive
Optane 900p
Power Supply
Seasonic Prime Snow
Case
enthoo evolv matx tempered glass
Operating System
windows 10 pro
▲ hide details ▲


ozlay is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off