Found Samsung SM951 for sale - Page 16 - Overclock.net - An Overclocking Community

Forum Jump: 

Found Samsung SM951 for sale

Reply
 
Thread Tools
post #151 of 486 (permalink) Old 04-14-2015, 06:11 PM
New to Overclock.net
 
Join Date: Apr 2015
Posts: 12
Rep: 0
Yeah, that's what I was thinking too. If you look at the full description, it says "We offer the next generation of high speed storage support through M.2 and SATA Express. M.2 and SATA Express transfer data through a PCI Express 2.0 x2 interface up to 10 Gb/s, making it 67% faster than SATA 3.0 solutions." However, right from the start, and several times in the manual, it says it offers Turbo M.2 to run it at 3.0 x4.

So either there's a setting somewhere, or there's misinformation. I bought this board specifically to run M2 @ 3.0 x4.
zylicyde is offline  
Sponsored Links
Advertisement
 
post #152 of 486 (permalink) Old 04-14-2015, 06:18 PM
New to Overclock.net
 
RamCity's Avatar
 
Join Date: Nov 2014
Posts: 19
Rep: 3 (Unique: 3)
Quote:
Originally Posted by garikfox View Post

Those are typical PCIe 2.0 x2 speeds, Hmmm...

Here below is some info about that boards PCIe config.

"Note that next to the PCIe slots is the M.2 x4 connector which pulls lanes from what would be the final PCIe slot. This means that with a 40 PCIe lane CPU, a user has to choose between tri-GPU (x16/x16/x8) + M.2 x2 from the chipset, or 2x GPU (x16/x16) + M.2 x4. 5820K users will get M.2 x4 in any configuration (x16/x8, x8/x8/x8)."

I was thinking the same thing. The only time we ever see speeds like that posted from an XP941 or SM951 is if the M.2 socket is only being fed 2 PCIe lanes.

zylicyde, can you post your GPU and CPU setup? ie. how many GPU's, and which particular CPU installed?

cheers, Rod
RamCity is offline  
post #153 of 486 (permalink) Old 04-14-2015, 06:25 PM
New to Overclock.net
 
Join Date: Apr 2015
Posts: 12
Rep: 0
CPU - Intel Core i7 5820k
GPU - (1) MSI GTX 780 ti
zylicyde is offline  
Sponsored Links
Advertisement
 
post #154 of 486 (permalink) Old 04-14-2015, 06:31 PM
Linux Lobbyist
 
garikfox's Avatar
 
Join Date: Jan 2012
Location: Queen Creek, AZ
Posts: 2,582
Rep: 270 (Unique: 198)
From what I read your board can run it at full 3.0 x4, aka. Turbo M.2, Youll have to double check the manual something isnt setup correctly in BIOS most likely.

ASRock X99 Taichi / Intel i7-6800K / G.SKILL 4x4GB DDR4-2400 / Samsung SM961 128GB / RX Vega 56 / EVGA SuperNOVA G2 750W / Acer ED323QUR / Windows 10 Enterprise LTSC
-----------------------------------------------------------------------
"Humans aren't the only species on Earth, We just act like it..."
garikfox is offline  
post #155 of 486 (permalink) Old 04-14-2015, 06:44 PM
New to Overclock.net
 
Join Date: Apr 2015
Posts: 12
Rep: 0
I've looked through the BIOS four times now at every single option, and there are only two related to M.2, and all of the PCIe stuff is set to gen 3. *shrugs*
zylicyde is offline  
post #156 of 486 (permalink) Old 04-14-2015, 06:53 PM
New to Overclock.net
 
RamCity's Avatar
 
Join Date: Nov 2014
Posts: 19
Rep: 3 (Unique: 3)
Quote:
Originally Posted by zylicyde View Post

I've looked through the BIOS four times now at every single option, and there are only two related to M.2, and all of the PCIe stuff is set to gen 3. *shrugs*

The devil is always in the details with this stuff. On page 1-7 of the MSI X99S SLI PLUS manual there is a diagram that shows how the PCIe lanes are divided up from the CPU. However in the 'fine print' you can see the diagram applies to a 40-lane CPU only.




The 5820K is a 28-lane CPU, so I'm thinking that the board is only feeding 2 PCIe lanes to the M.2 socket, even though you've only got 1 GPU installed. Perhaps it's not even feeding any PCIe lanes from the CPU in your configuration, just 2 lanes from the PCH switch.

You would need a 40-lane CPU (5930K or 5960X) to get the results you are looking for on that MSI board. frown.gif

Edit: I just received an update on this issue from Luke, one of our Amazon.com customers who was noticing low performance numbers on his SM951. Now I'm 100% certain that this board WILL support M.2 x4 lanes when using a 28-lane 5820K cpu.

Here's what he said:
Quote:
The name of the option is "M.2 Source Link", and the two values are "Auto" and "PCH", and you can see the option description in the picture attached.

I now recall that I might have changed the value of this when I was diagnosing a seagate HDD some days ago, and forgot to change it back to the proper value, causing the lane downgrade issue.
To my surprise, the proper value for SM951 to work at maximum speed is "Auto" instead of "PCH". I thought that PCH should represent something related to PCI-E and chose that, but "Auto" is the value that gives 4x lane to SM951.

Thus, X99s SLI Plus with a 28-lane 5820K does work well with SM951.

PS.
My desktop's configuration is:
Core i7 5820K, 4x4 RAM, MSI X99S SLI PLUS, MSI GTX 970 4G GAMINGx1, SM951 256G on M.2 slot, 850 EVO 500G on SATA. An Intel 7260ac WiFi card is plugged to a PCI-E slot.





Rod
RamCity is offline  
post #157 of 486 (permalink) Old 04-14-2015, 06:56 PM
New to Overclock.net
 
Join Date: Apr 2015
Posts: 12
Rep: 0
Aw man...

So would I be able to use something like the aforementioned Lycom DT-120 m.2 PCIe card to achieve those speeds? I really don't want to drop even more money into a processor just for faster SSD speeds...
zylicyde is offline  
post #158 of 486 (permalink) Old 04-14-2015, 06:57 PM
New to Overclock.net
 
RamCity's Avatar
 
Join Date: Nov 2014
Posts: 19
Rep: 3 (Unique: 3)
Quote:
Originally Posted by zylicyde View Post

Aw man...

So would I be able to use something like the aforementioned Lycom DT-120 m.2 PCIe card to achieve those speeds? I really don't want to drop even more money into a processor just for faster SSD speeds...

you got it. smile.gif
RamCity is offline  
post #159 of 486 (permalink) Old 04-14-2015, 06:58 PM
New to Overclock.net
 
Join Date: Apr 2015
Posts: 12
Rep: 0
Well thanks for the help everyone, it's much appreciated!
zylicyde is offline  
post #160 of 486 (permalink) Old 04-15-2015, 01:01 AM
Linux Lobbyist
 
garikfox's Avatar
 
Join Date: Jan 2012
Location: Queen Creek, AZ
Posts: 2,582
Rep: 270 (Unique: 198)
Don't worry I'll be a Lycom DT-120 man soon too. biggrin.gif

ASRock X99 Taichi / Intel i7-6800K / G.SKILL 4x4GB DDR4-2400 / Samsung SM961 128GB / RX Vega 56 / EVGA SuperNOVA G2 750W / Acer ED323QUR / Windows 10 Enterprise LTSC
-----------------------------------------------------------------------
"Humans aren't the only species on Earth, We just act like it..."
garikfox is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off