My left "ALT" key on my CM quickfire rapid (MX red) just stopped working.... - Overclock.net - An Overclocking Community

Forum Jump: 

My left "ALT" key on my CM quickfire rapid (MX red) just stopped working....

Reply
 
Thread Tools
post #1 of 23 (permalink) Old 11-29-2012, 03:40 PM - Thread Starter
New to Overclock.net
 
wompwomp's Avatar
 
Join Date: Apr 2011
Posts: 616
Rep: 15 (Unique: 15)
What happened? How do I fix this? I didn't spill anything into it; it just stopped working for no apparent reason.
wompwomp is offline  
Sponsored Links
Advertisement
 
post #2 of 23 (permalink) Old 11-29-2012, 03:44 PM
 
Join Date: Apr 2008
Location: Planet Earth
Posts: 4,124
You are now the 5th one I've seen with this.

I'm beginning to think they have a PCB layout problem.
ripster is offline  
post #3 of 23 (permalink) Old 11-29-2012, 03:49 PM
 
Join Date: Feb 2010
Posts: 916
you got 2 alt keys to work with
Clipze is offline  
Sponsored Links
Advertisement
 
post #4 of 23 (permalink) Old 11-29-2012, 03:52 PM - Thread Starter
New to Overclock.net
 
wompwomp's Avatar
 
Join Date: Apr 2011
Posts: 616
Rep: 15 (Unique: 15)
It's kind of difficult to play my MOBAS holding down my right alt key and pressing the "QWE" keys at the same time...

And regardless, if I'm paying $90 for a keyboard, I expect for all of these to work...
wompwomp is offline  
post #5 of 23 (permalink) Old 11-29-2012, 03:53 PM
 
Join Date: Feb 2010
Posts: 916
its got 2 year warranty on it..
Clipze is offline  
post #6 of 23 (permalink) Old 11-29-2012, 03:58 PM
 
Join Date: Apr 2008
Location: Planet Earth
Posts: 4,124
"you got 2 alt keys to work with
"

Hey, the mobile OCN app doesn't have a "troll" button!
ripster is offline  
post #7 of 23 (permalink) Old 12-03-2012, 02:19 PM
New to Overclock.net
 
TomatoBasket's Avatar
 
Join Date: Dec 2012
Posts: 8
Rep: 0
I have to add myself to that list. The left-alt key just failed on my CM Quickfire with brown switches. Seems like a small batch of Brown, Blue and Reds have faulty left alt-keys.

From the CM rep in the Quickfire thread:
Quote:
Unfortunately, there was a very small concentrated batch Costar apparently had issues with left ALT. All issues have been fixed and it will not happen on any further board. We are able to track down the exact order these came in on, unfortunately it affects Blue, Red & Brown switches but in a very limited fashion. Also its impossible to recall the whole shipment because only about 1 out of 20 boards suffer the issue.

Please understand this was something we didnt catch, but do apologize, and assure you we have tightened up QC BIG time on our Costar boards.
TomatoBasket is offline  
post #8 of 23 (permalink) Old 12-03-2012, 05:57 PM
New to Overclock.net
 
mmontag's Avatar
 
Join Date: Nov 2012
Posts: 6
Rep: 0
Hi guys,
just got another Quickfire Rapid with broken Left Alt key.
The first one amazon sent had a broken left alt.
The second one they sent was a Spanish layout with a working left alt.
The third one they sent was again a US layout with broken left alt key.
I dunno what to do.

/matt
mmontag is offline  
post #9 of 23 (permalink) Old 12-11-2012, 03:16 AM
New to Overclock.net
 
tikshow's Avatar
 
Join Date: Dec 2012
Posts: 1
Rep: 0
Quote:
Originally Posted by mmontag View Post

Hi guys,
just got another Quickfire Rapid with broken Left Alt key.
The first one amazon sent had a broken left alt.
The second one they sent was a Spanish layout with a working left alt.
The third one they sent was again a US layout with broken left alt key.
I dunno what to do.
/matt

Mine arrived with a broken one too, but I remapped the Left Windows to Left Alt, and the Right Windows key to Left Windows key with KeyTweak. I will send it back 1 month before the 3 year warranty will expire -> I will have another 3 years of warranty. If they can't tests these things out in the factory then they deserve it.
tikshow is offline  
post #10 of 23 (permalink) Old 12-11-2012, 06:10 AM
 
Join Date: Apr 2008
Location: Planet Earth
Posts: 4,124
They COULD hALT shipments of bad keyboards.
ripster is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off