Deathadder 2013 not working right - Overclock.net - An Overclocking Community

Forum Jump: 

Deathadder 2013 not working right

 
Thread Tools
post #1 of 8 (permalink) Old 11-19-2013, 06:33 PM - Thread Starter
New to Overclock.net
 
zrocker's Avatar
 
Join Date: Nov 2013
Posts: 4
Rep: 0
So i got a Deathadder 2013 a little while ago, registered, and downloaded the synapse 2.0 software. Whenever i plug the mouse in however, it seems to install the driver, but the mouse doesnt work right.

What happens is that parts of my screen don't work with the mouse. Either the start bar will not respond (mouse overs on the icons do not respond, clicking doesn't do anything). Or the main screen doesnt work (above the start bar, same issue).

It seems like a driver issue but why is this messing up on my computer? I've looked it up and found nothing on this issue, was hoping someone here could help me out. Do i need to manual DL the driver?
zrocker is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 11-19-2013, 07:21 PM
 
Join Date: Aug 2013
Posts: 864
You didn't unplug the mouse while synapsys is updating did you?.........
CptDanko is offline  
post #3 of 8 (permalink) Old 11-19-2013, 07:51 PM - Thread Starter
New to Overclock.net
 
zrocker's Avatar
 
Join Date: Nov 2013
Posts: 4
Rep: 0
No, even when i restart my computer with it plugged in or plug it in after restart it does this. SOMETIMES i got it to work ok but then it stopped working again
zrocker is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 11-19-2013, 07:58 PM
 
Join Date: Aug 2013
Posts: 864
Are you running win 8.1?
CptDanko is offline  
post #5 of 8 (permalink) Old 11-19-2013, 08:02 PM - Thread Starter
New to Overclock.net
 
zrocker's Avatar
 
Join Date: Nov 2013
Posts: 4
Rep: 0
Windows 7
zrocker is offline  
post #6 of 8 (permalink) Old 11-19-2013, 08:42 PM
 
Join Date: Aug 2013
Posts: 864
Its probably a software conflict
In any case try the windows 7 legacy driver, that's what I use. Synapsys was giving me issues where it wouldn't load a boot up sometimes.
CptDanko is offline  
post #7 of 8 (permalink) Old 11-20-2013, 03:22 PM - Thread Starter
New to Overclock.net
 
zrocker's Avatar
 
Join Date: Nov 2013
Posts: 4
Rep: 0
Where can i get the legacy driver?

Was on Razer's website and didnt see anything other than synapse 2.0

Also, i tried reinstalling synapse twice and it still didnt work. Plugging the mouse in without synapse and nothing happened...
zrocker is offline  
post #8 of 8 (permalink) Old 11-21-2013, 03:36 AM
 
Join Date: Aug 2013
Posts: 864
Quote:
Originally Posted by zrocker View Post

Where can i get the legacy driver?

Was on Razer's website and didnt see anything other than synapse 2.0

Also, i tried reinstalling synapse twice and it still didnt work. Plugging the mouse in without synapse and nothing happened...

Its on the website under mice then select deathadder, its the 3rd option after synapsys
CptDanko is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off