Mouse keeps disconnecting and reconnecting - Overclock.net - An Overclocking Community

Forum Jump: 

Mouse keeps disconnecting and reconnecting

 
Thread Tools
post #1 of 6 (permalink) Old 03-21-2019, 11:48 AM - Thread Starter
New to Overclock.net
 
Join Date: Mar 2019
Posts: 2
Rep: 0
Mouse keeps disconnecting and reconnecting

My mouse keeps disconnecting and reconnecting again and again, it used to be rare but now it's every 30 seconds or so. It only happens in games, like IN game, i can be at the menu of the game and it wont happen but when im IN a match it will happen.
It's a uRAGE mouse (don't remember the name) with a dpi button which resets the color (to the one i don't use with a higher dpi) whenever it reconnects. It's annoying and i can't play a game.

Things i tried to do to fix it:
1. replug and plugged to a different usb input.
2. update driver
3. i changed the power management settings for USB Root Hub.

nothing. I really need help soon to fix it, i wanna avoid getting a new mouse, i'm lazy to actually go buy one, it costs money (im cheap), i would have to changed my sensitivity settings in game to what i used to play with (which will take time) and i love this mouse.
Bittex is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-21-2019, 03:03 PM
New to Overclock.net
 
munchzilla's Avatar
 
Join Date: Jun 2014
Posts: 1,772
Rep: 57 (Unique: 50)
does it happen when the mouse is still or when moving? I had that happen a bunch with broken cables. if I moved it a certain way it would disconnect and reconnect. or if the cable was too strained.
munchzilla is offline  
post #3 of 6 (permalink) Old 03-21-2019, 03:54 PM
Kill Confirmed
 
speed_demon's Avatar
 
Join Date: Nov 2006
Posts: 1,056
Rep: 61 (Unique: 51)
I had my Logi G5 mouse constantly keep connecting and disconnecting as well. I replaced the usb cable and have not had the issue since. Cost was around $7 and took 10 minutes of my time - might be something to look into.


speed_demon is online now  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 03-21-2019, 07:57 PM
New to Overclock.net
 
TranquilTempest's Avatar
 
Join Date: Aug 2011
Posts: 1,577
Rep: 75 (Unique: 60)
Almost certainly broken wires inside the cable. It's a very common issue if you wrap the cable around the mouse to store it or put it in a laptop bag.

If you order a new cable, good idea to order new feet at the same time, because you'll almost certainly have to peel them off to get the mouse open.

TranquilTempest is online now  
post #5 of 6 (permalink) Old 03-22-2019, 01:28 AM
Mouse Junkie
 
vanir1337's Avatar
 
Join Date: Dec 2014
Location: localhost
Posts: 1,330
Rep: 32 (Unique: 30)
I'd say replace the cable, but these Hama mice are so bad that you should just get a new one instead.

Logitech G PRO Wireless | Custom Huado Mousepad | Sharkoon PureWriter TKL Blue | HyperX Cloud

Mouse & mouse pad reviewer at TechPowerUp
vanir1337 is offline  
post #6 of 6 (permalink) Old 03-22-2019, 01:41 AM
Graphics Junkie
 
UltraMega's Avatar
 
Join Date: Feb 2017
Location: USA
Posts: 697
Rep: 13 (Unique: 13)
Feed it to a snake.

i7 7700kK @4.2ghz
16GB DDR4 3200mhz
GeForce 1080 Ti
UltraMega is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off