Asus Sabertooth Z77 USB Problems, Need Help - Overclock.net - An Overclocking Community

Forum Jump: 

Asus Sabertooth Z77 USB Problems, Need Help

 
Thread Tools
post #1 of 4 (permalink) Old 07-31-2013, 11:11 AM - Thread Starter
New to Overclock.net
 
tohrchur's Avatar
 
Join Date: Jul 2012
Location: Maryland
Posts: 88
Rep: 1 (Unique: 1)
Ive had this motherboard for just a few months and just last month I got an error that "The USB device is not recognized" and I just had my peripherals plugged in, all the drivers up to date and working 100%. So I reinstalled my OS (Windows 7) and that did not fix the problem. Recently my devices have just stopped working and I have to unplug and plug them in for them to work. Then today I switched them all to the back USB 3.0 on the board, and the notification went away, so is there a driver to download for usb 2.0 on the back of the board? Any ideas/advice?

I turned on my computer this morning and the notification is back. Then if I click the notification:


If I open up device manager this shows up:

and also this:

BUT! The device manager is constantly refreshing and the "Unknown Composite Device" will go away then refresh in a few seconds and then come back then go away then come back. And I have no clue what to do.

My rig:
i5-3570K
Asus Sabertooth Z77
8GB Kingston RAM
Radeon 7970 GPU
250GB SSD for boot drive and a 2 TB HDD for random storage.
tohrchur is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-13-2013, 04:12 AM
New to Overclock.net
 
CODELESS's Avatar
 
Join Date: Jan 2013
Location: Cape Town South Africa
Posts: 126
Rep: 1 (Unique: 1)
had the same problem, my USB3 ports would do that.
i tried to fix it but gave up and reinstalled my OS, i cant remember how i got it working in the end, i think it was downloading the latest drivers and installing them in a specific order. or i think i updated the usb drivers and pointed to where the usb drivers were extracted to.

but thats different to your problem, after installing the OS, update the usb drivers via device manager ?
or try uninstalling your USB. restart and let windows install them again

i5 3570k @ 4.6
Sabertooth Z77
Vengeance 8GB 2400Mhz
2x OCZ V4 128GB in Raid 0
Gigabyte GTX 970 G1 Gaming
Corsair TX850M PSU
H100i CPU Cooler
CODELESS is offline  
post #3 of 4 (permalink) Old 08-13-2013, 08:12 AM - Thread Starter
New to Overclock.net
 
tohrchur's Avatar
 
Join Date: Jul 2012
Location: Maryland
Posts: 88
Rep: 1 (Unique: 1)
Quote:
Originally Posted by CODELESS View Post

had the same problem, my USB3 ports would do that.
i tried to fix it but gave up and reinstalled my OS, i cant remember how i got it working in the end, i think it was downloading the latest drivers and installing them in a specific order. or i think i updated the usb drivers and pointed to where the usb drivers were extracted to.

but thats different to your problem, after installing the OS, update the usb drivers via device manager ?
or try uninstalling your USB. restart and let windows install them again

I've done all of that, and Windows says the driver could not be found. I contacted Asus and they said I have a faulty usb chipset, so when school starts again i'm going to RMA my board. :/
tohrchur is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 08-15-2013, 12:04 AM
New to Overclock.net
 
CODELESS's Avatar
 
Join Date: Jan 2013
Location: Cape Town South Africa
Posts: 126
Rep: 1 (Unique: 1)
damn, sorry to hear that.

i5 3570k @ 4.6
Sabertooth Z77
Vengeance 8GB 2400Mhz
2x OCZ V4 128GB in Raid 0
Gigabyte GTX 970 G1 Gaming
Corsair TX850M PSU
H100i CPU Cooler
CODELESS is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off