Z390 Pro wolnt power on - Overclock.net - An Overclocking Community

Forum Jump: 

Z390 Pro wolnt power on

 
Thread Tools
post #1 of 3 (permalink) Old 02-16-2019, 12:22 PM - Thread Starter
New to Overclock.net
 
Join Date: Feb 2019
Posts: 2
Rep: 0
Z390 Pro wolnt power on

Motherboard model: Z390 Pro
CPU: i7 8700k
PSU: EVGA 650
CPU Cooler: EVGA CLCC 280MM
PC CASE: Corsair 460

Ive tried everything. Only thing plugged in at this point is the 24 pin connector and the power button. I hit the power switch. The board LEDS flash. Then dead in the water. power button does nothing. HELP!
JR_Nasty is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-16-2019, 12:33 PM
9 Cans of Ravioli
 
The Pook's Avatar
 
Join Date: May 2006
Posts: 15,470
Rep: 952 (Unique: 587)
Quote: Originally Posted by JR_Nasty View Post
Ive tried everything. Only thing plugged in at this point is the 24 pin connector and the power button.

uhhhhhhhh, 8-pin EPS?

Intel i9 9900K Coffee Lake @ X8 5309mhz (+47.5%)
AMD FX-8320 Vishera @ X4 5022mhz (+43.5%)
Intel i5 4690K Haswell @ X4 5013mhz (+43.2%)
AMD X4 960T Zosma @ X6 4870mhz (+62.3%)
Intel i7 6700 Skylake @ X4 4709mhz (+38.5%)
Intel i5 6400 Skylake @ X4 4588mhz (+69.9%)
2 OP pls nerf
(24 items)
NUC U
(7 items)
CPU
i9 9900K
Motherboard
AsRock Z390 Taichi
GPU
MSI GTX 1080 Ti
RAM
G.Skill 16GB DDR4 4133
Hard Drive
Mushkin Pilot NVMe 1TB
Hard Drive
Samsung 860 Evo 1TB
Hard Drive
Sandisk Ultra II 480GB SSD
Hard Drive
Toshiba X300 5TB
Hard Drive
Western Digital EZRZ 3TB
Power Supply
Seasonic Focus Plus Gold 750w
Cooling
Corsair H115i Pro
Case
Fractal Design Meshify S2
Operating System
Windows 10 Education x64
Monitor
Acer XF270HU
Monitor
Dell E2311H
Keyboard
CoolerMaster MasterKeys Pro S
Mouse
Logitech G502
Mousepad
X-Ray XL 26" x 14"
Audio
SMSL SA50 + FiiO E10K
Audio
Philips SHP9500S
Audio
Audio Technica ATH-M50X
Audio
Monoprice Modern Retro
Audio
AudioSource LS100
Audio
Polk Audio PSW111
CPU
i3 8109U
Motherboard
Intel NUC8i3BEH
GPU
Iris Plus 655
RAM
Kingston 8GB DDR4 2400
Hard Drive
Dierka K1 120GB
Keyboard
Rii RKM709 Wireless
Mouse
Logitech M510
CPU
i7 860
Motherboard
Advantech AIMB 280 ITX
GPU
EVGA GTX 950 2GB
RAM
Kingston 2GB DDR3 1333
Hard Drive
Seagate Momentus 2.5" 500GB
Hard Drive
Western Digital Blue 2.5" 320GB
Power Supply
Silverstone SFX-L Gold 500w
Cooling
Arctic Alpine 11 GT 2
Case
Silverstone Milo Z ML07B
Operating System
Windows XP x86 SP3
Keyboard
Velocifire TKL01 Outemu Browns
Mouse
Logitech M512
▲ hide details ▲


The Pook is offline  
post #3 of 3 (permalink) Old 02-16-2019, 12:38 PM - Thread Starter
New to Overclock.net
 
Join Date: Feb 2019
Posts: 2
Rep: 0
Tried that too. Took the mobo out of the case and its still doing the same thing.
JR_Nasty is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off