Problems installing the backplate for my CPU blocl - Overclock.net - An Overclocking Community

Forum Jump: 

Problems installing the backplate for my CPU blocl

 
Thread Tools
post #1 of 3 (permalink) Old 09-11-2019, 01:39 PM - Thread Starter
New to Overclock.net
 
Cuenda's Avatar
 
Join Date: Mar 2017
Posts: 36
Rep: 0
Problems installing the backplate for my CPU blocl

Hello, im installing my first custom loop and im having some problems that i dont understand why are happening and what can i do to not break anything.

My CPU block is the EK Velocity and im installing it in a Asus IX Formula.

The Screws goes in really well when i dont have the mobo in the middle, but when i put the rubber gasket, the metal backplate with the motherboard it will just not screw well, only one out of 4 goes in well, other 2 doesnt fully screw in and another one does not look straight, i dont know what else i can do, my fingers already hurts a lots and dont want to break anything.

Hope those pictures helps to understand what i mean.

https://imgur.com/gallery/ACh0LOp


https://imgur.com/gallery/7LyhQw6

Hope i can have some help or tips to make it work 😩
Cuenda is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-12-2019, 04:37 AM
New to Overclock.net
 
GAN77's Avatar
 
Join Date: Feb 2016
Posts: 190
Rep: 2 (Unique: 2)
You removed inner core during installation ?

Tighten each screw gradually, and not immediately to the end.
Attached Thumbnails
Click image for larger version

Name:	Снимок экрана (1281).jpg
Views:	7
Size:	198.4 KB
ID:	295002  

GAN77 is online now  
post #3 of 3 (permalink) Old 09-12-2019, 04:59 AM
New to Overclock.net
 
Shawnb99's Avatar
 
Join Date: Dec 2011
Location: Crackatoea
Posts: 822
Rep: 22 (Unique: 14)
Try mounting it vertical instead of horizontal.
I’ve had issues with a few Asus boards that required mounting it that way.

My Baby
(24 items)
CPU
Delidded Direct Die I9 9900K
Motherboard
ASUS Maximus XI Apex
GPU
EVGA FTW3 Hydro Copper GeForce RTX 2080 Ti
RAM
G.SKILL TridentZ Series 16GB DDR4 3600 F4-3600C15D-16GTZ
Hard Drive
2x Samsung 970 EVO Plus 1TB
Hard Drive
Asus Hyper M.2 card
Hard Drive
2 x Intel 660P 2TB
Power Supply
Seasonic PRIME Ultra 1000 Titanium
Cooling
Watercool HEATKILLER IV PRO
Cooling
2x Swiftech MCP35X2 with MCP35X2 Heat Sink
Cooling
2x Hardware Labs Black Ice Nemesis 360GTR
Cooling
2x Hardware Labs Black Ice Nemesis 360GTS
Cooling
Aquacomputer aqualis XT 450 ml with nano coating
Cooling
9x Noctua NF-S12A PWM
Cooling
2x Noctua NA-A15 PWM
Cooling
24x EK Vadar F4120ER
Case
Case Labs Magnum M8 with Pedestal
Monitor
Asus PG28Q
Keyboard
Das Keyboard 5Q
Mouse
Swiftpoint Z
Audio
Mr. Speakers Aeon Closed
Audio
Geek Pulse Inifnity DAC/AMP
Audio
Cavalii Audio Liquid Carbon HPA
Other
Aquacomputer Aquaero XT
▲ hide details ▲
Shawnb99 is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off