5700XT Liquid Devil - Page 7 - Overclock.net - An Overclocking Community
Forum Jump: 

5700XT Liquid Devil

Reply
 
Thread Tools
post #61 of 68 (permalink) Old 02-09-2020, 07:51 PM
New to Overclock.net
 
sf101's Avatar
 
Join Date: Jun 2012
Posts: 83
Rep: 1 (Unique: 1)
and if amd is going to start pushing bios updates they should just include a verified updater in their drivers so its more simplified.

Evga X299 FTWK - Intel 7900X (@4.8GHZ) - 64GB Corsair Vengence RGB Pro @ 3400mhz - PC-5700XT Liquid Devil - WB Black 1TB NVME -EVGA 1300W G2
Full loop 2x480mm Radiator Equivalence - XSPC RX Rads in use Full copper XSPC Raystorm CPU Block
SF101 HW BOT
sf101 is offline  
Sponsored Links
Advertisement
 
post #62 of 68 (permalink) Old 02-11-2020, 02:39 PM
New to Overclock.net
 
Join Date: Feb 2020
Posts: 2
Rep: 0
Quote: Originally Posted by jfrob75 View Post
Hey guys,
Noticed powercolor has a "new" bios out for the liquiddevil via their devilclub website. Not sure if the 2 bios's are newer or different from what I downloaded earlier this year. The method for uploading the new bios is different than before as this one requires creating a MSDOS USB drive and booting into DOS and executing the appropriate batch file.


If anyone with a liquiddevil tries the new bios let us know if it resolved the 2020 driver issue(s).

Hi,

I was that one. The problem was that with the update exe the old bios was deleted und the new one I cant install. So the Card was brick! After 48h PowerColor give me a new tool and it worked. So the bios and the timestamp of it are the Same!

New bios works with 2020.
But! You still not able for doing some morepower tool stuff!

Best regards Markus
Markus_ is offline  
post #63 of 68 (permalink) Old 02-11-2020, 04:31 PM
New to Overclock.net
 
sf101's Avatar
 
Join Date: Jun 2012
Posts: 83
Rep: 1 (Unique: 1)
Quote: Originally Posted by Markus_ View Post
Hi,

I was that one. The problem was that with the update exe the old bios was deleted und the new one I cant install. So the Card was brick! After 48h PowerColor give me a new tool and it worked. So the bios and the timestamp of it are the Same!

New bios works with 2020.
But! You still not able for doing some morepower tool stuff!

Best regards Markus
Well that's disappointing is amd just purposely crippling mpt? because if they are then whats the point in upgrading drivers who wants to buy gpu's that you cant OC with on current drivers.. kind of ridiculous since MPT basically saved the enthusiast scene for R7 and 5700/xt.

I was wondering why it didn't work when i tried it last night and ended up going back to 19.12.1.

This nonsense needs to stop amd.

Evga X299 FTWK - Intel 7900X (@4.8GHZ) - 64GB Corsair Vengence RGB Pro @ 3400mhz - PC-5700XT Liquid Devil - WB Black 1TB NVME -EVGA 1300W G2
Full loop 2x480mm Radiator Equivalence - XSPC RX Rads in use Full copper XSPC Raystorm CPU Block
SF101 HW BOT
sf101 is offline  
Sponsored Links
Advertisement
 
post #64 of 68 (permalink) Old 02-12-2020, 12:05 AM
New to Overclock.net
 
Join Date: Feb 2020
Posts: 2
Rep: 0
Hi,

same story on my side.
I bought this card to use also MPT. Why someone should bought a card 100€ more then others with a very good waterblock.

Yes okay silent stuff and so on. But this card offers a marketing with OC.

I know PowerColor is not the problem and the support was really fast!

But the new strategy from AMD I don’t like also.
Why we buy AMD? And not a 2070 super IChill that cost exact the same in Europe.

Yes because of no limit in the drivers.
Without that feature why not think about the greens?

Markus

Markus
Markus_ is offline  
post #65 of 68 (permalink) Old 02-13-2020, 10:08 AM
New to Overclock.net
 
Join Date: Jul 2019
Posts: 111
Rep: 0
Quote: Originally Posted by Markus_ View Post
Hi,

same story on my side.
I bought this card to use also MPT. Why someone should bought a card 100€ more then others with a very good waterblock.

Yes okay silent stuff and so on. But this card offers a marketing with OC.

I know PowerColor is not the problem and the support was really fast!

But the new strategy from AMD I don’t like also.
Why we buy AMD? And not a 2070 super IChill that cost exact the same in Europe.

Yes because of no limit in the drivers.
Without that feature why not think about the greens?

Markus

Markus

Can you be more specific about the issue(s) you have when trying to use MPT? When I had my Liquid Devil installed, with the updated vBIOS supplied back in December and choosing the 5700 XT anniversary driver, I was able to apply a change to frequency, voltage and power settings using MPT but if tried to increase the voltage above 1200mv it would not take with the 2020 drivers nor would a power increase above 50%. I could OC the memory the same as under 19.12.1 drivers.

Ryzen 3950X Build
(17 items)
CPU
3950X
Motherboard
ASUS X570 Crosshair VIII Hero
GPU
PowerColor RX 5700XT Liquid Devil
GPU
MSI RX 5700 XT Water cooled
RAM
GSkill F4-3600C16D-32GTZN
Hard Drive
Samsung NVMe EVO 970
Hard Drive
Samsung SSD 850 Pro
Hard Drive
GB Aorus NVMe Gen4 SSD
Optical Drive
LG BDDVDRW
Power Supply
Seasonic
Cooling
Optimus Foundation water block/custome loop with 360 rad.
Case
Corsair Graphite Series 780T
Operating System
MS Win10 Pro
Monitor
Samsung LC27HG70QQNXZA
Monitor
Samsung LC27HG70QQNXZA
Keyboard
Logitech G910
Mouse
Logitech G502
▲ hide details ▲
jfrob75 is offline  
post #66 of 68 (permalink) Old 02-15-2020, 11:07 PM
New to Overclock.net
 
Join Date: Jul 2019
Posts: 111
Rep: 0
Liquid Devil working with 2020 drivers

I got bored today so I decided to reinstall my Liquid Devil into the second PCIe slot. Once installed I updated both the unleashed and OC vBIOS to the latest provided by Powercolor. The unleash VBIOS was already at the latest. Next did some evaluation of it under the currently installed 2020 drivers. Behavior was as before, maybe even worse as I could not get any OC change to take effect.


At this point I decided to boot into safe mode and DDU the drivers. Next I installed the latest drivers 20.2.1 Feb 3. I then check the cards behavior under this driver and I was able to make changes to the clock, memory and power settings and have them be accepted, this is without MPT at this time. Feeling emboldened I decided to use MPT and up the max power,frequency and voltage. Rebooted and went back into the performance settings and was able to further increase the frequency and voltage above default values without the software rejecting them.


I have run some benchmarks successfully with the card OC'd which I was not able to do before. I have been able to set the voltage to the max of 1350mv which previously I could not exceed 1200mv. I did see improvement in my superposition scores and timespy scores but it appears I am not able to overclock as high as I was under the 19.12.1 drivers.


Anyway it would appear that with a clean install of the latest 2020 drivers that the Liquid Devil now behaves as it should.


FIY: I am running with my MSI reference 5700 XT as before, so essentially 2 liquid cooled 5700 XT are installed in my system.


One other thing. I went into device manager and changed the driver for the Liquid Devil to use the 50th anniversary driver since that what the NAVI chip actually is as defined by the revision C0 designation where as my MSI is revision C1.

Ryzen 3950X Build
(17 items)
CPU
3950X
Motherboard
ASUS X570 Crosshair VIII Hero
GPU
PowerColor RX 5700XT Liquid Devil
GPU
MSI RX 5700 XT Water cooled
RAM
GSkill F4-3600C16D-32GTZN
Hard Drive
Samsung NVMe EVO 970
Hard Drive
Samsung SSD 850 Pro
Hard Drive
GB Aorus NVMe Gen4 SSD
Optical Drive
LG BDDVDRW
Power Supply
Seasonic
Cooling
Optimus Foundation water block/custome loop with 360 rad.
Case
Corsair Graphite Series 780T
Operating System
MS Win10 Pro
Monitor
Samsung LC27HG70QQNXZA
Monitor
Samsung LC27HG70QQNXZA
Keyboard
Logitech G910
Mouse
Logitech G502
▲ hide details ▲
jfrob75 is offline  
post #67 of 68 (permalink) Old 02-16-2020, 02:41 PM
New to Overclock.net
 
MSIMAX's Avatar
 
Join Date: Feb 2014
Posts: 118
Rep: 4 (Unique: 4)
Quote: Originally Posted by jfrob75 View Post
I got bored today so I decided to reinstall my Liquid Devil into the second PCIe slot. Once installed I updated both the unleashed and OC vBIOS to the latest provided by Powercolor. The unleash VBIOS was already at the latest. Next did some evaluation of it under the currently installed 2020 drivers. Behavior was as before, maybe even worse as I could not get any OC change to take effect.


At this point I decided to boot into safe mode and DDU the drivers. Next I installed the latest drivers 20.2.1 Feb 3. I then check the cards behavior under this driver and I was able to make changes to the clock, memory and power settings and have them be accepted, this is without MPT at this time. Feeling emboldened I decided to use MPT and up the max power,frequency and voltage. Rebooted and went back into the performance settings and was able to further increase the frequency and voltage above default values without the software rejecting them.


I have run some benchmarks successfully with the card OC'd which I was not able to do before. I have been able to set the voltage to the max of 1350mv which previously I could not exceed 1200mv. I did see improvement in my superposition scores and timespy scores but it appears I am not able to overclock as high as I was under the 19.12.1 drivers.


Anyway it would appear that with a clean install of the latest 2020 drivers that the Liquid Devil now behaves as it should.


FIY: I am running with my MSI reference 5700 XT as before, so essentially 2 liquid cooled 5700 XT are installed in my system.


One other thing. I went into device manager and changed the driver for the Liquid Devil to use the 50th anniversary driver since that what the NAVI chip actually is as defined by the revision C0 designation where as my MSI is revision C1.
how did you get the voltage to stick i gave up for a bit and started running my 290x lol
MSIMAX is offline  
post #68 of 68 (permalink) Old 02-16-2020, 05:10 PM
New to Overclock.net
 
Join Date: Jul 2019
Posts: 111
Rep: 0
Quote: Originally Posted by MSIMAX View Post
how did you get the voltage to stick i gave up for a bit and started running my 290x lol
I honestly do not know. I had, in the past, removed previous drivers using DDU followed by installing the latest drivers and it did not work until now. All I can suggest is to try the latest 20.2.1 driver and see if you get the same results I did and if so than that would be further evidence that the latest driver fixed the issue we were having.
Just so you know I am not BS'ing here is a screen shot of my current performance settings for the Liquid Devil.
Spoiler!

Ryzen 3950X Build
(17 items)
CPU
3950X
Motherboard
ASUS X570 Crosshair VIII Hero
GPU
PowerColor RX 5700XT Liquid Devil
GPU
MSI RX 5700 XT Water cooled
RAM
GSkill F4-3600C16D-32GTZN
Hard Drive
Samsung NVMe EVO 970
Hard Drive
Samsung SSD 850 Pro
Hard Drive
GB Aorus NVMe Gen4 SSD
Optical Drive
LG BDDVDRW
Power Supply
Seasonic
Cooling
Optimus Foundation water block/custome loop with 360 rad.
Case
Corsair Graphite Series 780T
Operating System
MS Win10 Pro
Monitor
Samsung LC27HG70QQNXZA
Monitor
Samsung LC27HG70QQNXZA
Keyboard
Logitech G910
Mouse
Logitech G502
▲ hide details ▲
jfrob75 is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off