Old AMD Settings - Overclock.net - An Overclocking Community
Forum Jump: 

Old AMD Settings

 
Thread Tools
post #1 of 5 (permalink) Old 02-28-2020, 12:58 PM - Thread Starter
New to Overclock.net
 
Shonk's Avatar
 
Join Date: May 2014
Posts: 58
Rep: 6 (Unique: 4)
Old AMD Settings

I far prefer the old AMD Settings app

It works fine with newer drivers

e.g.
Install
19.12.1 Complete Package
Then just update the drivers to 20.2.2 from device manager
then uninstall old driver via command line
pnputil -e
pnputil oemxx.inf

Atm im using
2020.q1.1 Complete Package + 20.2.2 drivers

Does anyone know how to edit the installer so i can replace the driver
so i dont have to double install every update

any help appreciated
Attached Thumbnails
Click image for larger version

Name:	1.png
Views:	15
Size:	402.0 KB
ID:	329622  

Shonk is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-28-2020, 01:09 PM - Thread Starter
New to Overclock.net
 
Shonk's Avatar
 
Join Date: May 2014
Posts: 58
Rep: 6 (Unique: 4)
I should have explained the problem a bit better

every driver release the file names in below dir change slightly

Packages\Drivers\Display\WT6A_INF\

C0351676.inf on 2020.q1.1
C0352262.inf on 20.2.2

There will be a config for the installer somewhere that needs editing but havnt had any luck
Shonk is offline  
post #3 of 5 (permalink) Old 02-28-2020, 03:42 PM - Thread Starter
New to Overclock.net
 
Shonk's Avatar
 
Join Date: May 2014
Posts: 58
Rep: 6 (Unique: 4)
Ok i have found it myself

Config\CIMManifest.xml

3 x U0348909 replace with U0352262 (19.12.1 to 20.2.2)

Cosmetics

Search for ProductVersion
26.20.xxxx and replace with current build


InstallManager.cfg

Add
ShowUpdate=false
DisableWebBuilds=true

Edit
EnableDVRTracking=true
UEITracking=true
EnableAnalytics=true
Shonk is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 02-28-2020, 03:49 PM
New to Overclock.net
 
Schmuckley's Avatar
 
Join Date: Jul 2011
Location: FL
Posts: 14,913
Rep: 708 (Unique: 565)
Quote: Originally Posted by Shonk View Post
Ok i have found it myself

Config\CIMManifest.xml

3 x U0348909 replace with U0352262 (19.12.1 to 20.2.2)

Cosmetics

Search for ProductVersion
26.20.xxxx and replace with current build


InstallManager.cfg

Add
ShowUpdate=false
DisableWebBuilds=true

Edit
EnableDVRTracking=true
UEITracking=true
EnableAnalytics=true
I like it!
Using the older settings interface with latest drivers=win!
Schmuckley is offline  
post #5 of 5 (permalink) Old 02-28-2020, 05:36 PM - Thread Starter
New to Overclock.net
 
Shonk's Avatar
 
Join Date: May 2014
Posts: 58
Rep: 6 (Unique: 4)
It didnt work out

The ccc is installed with the drivers and is signed

so all i did was transplant the old installer the new ccc still came with the drivers

this way works

copy ccc2_install.exe from the 19.12.1 to 20.2.2

but i think im going to stick with

Install 19.12.1 then update drivers from device manager
and i will just update the drivers every release

and uninstall the old one with pnputil from cmd

think its the least work in the long run
Shonk is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off