Easy NVFlash Guide with Pictures for GTX 970/980 - Page 6 - Overclock.net - An Overclocking Community
Forum Jump: 

Easy NVFlash Guide with Pictures for GTX 970/980

Reply
 
Thread Tools
post #51 of 97 (permalink) Old 05-18-2015, 10:41 AM
Linux Lobbyist
 
AngryGoldfish's Avatar
 
Join Date: Apr 2014
Location: Ireland
Posts: 1,760
Rep: 68 (Unique: 49)
Quote:
Originally Posted by mykehdoom View Post

How do I backup my stock bios?

You can do it with GPU-Z.

Disable GPU drivers within Windows
Open GPU-Z
Go down BIOS Version in the first tab
Click the Save BIOS button on the right
Save it anywhere you like and name it something you'll remember

AngryGoldfish is offline  
Sponsored Links
Advertisement
 
post #52 of 97 (permalink) Old 06-14-2015, 10:48 AM
New to Overclock.net
 
ar3f's Avatar
 
Join Date: Feb 2011
Posts: 501
Rep: 30 (Unique: 29)
I have the 970 FTW+ installed - it has dual BIOS.

Flashing would write to the active BIOS (2nd in my case) or to the 1st BIOS? I'd guess it'll be flashing the active one, but better ask around smile.gif

1st BIOS is 110% OC with 0RPM fans up to 61 C; 2nd BIOS is 115% OC and active fan.

ar3f is offline  
post #53 of 97 (permalink) Old 06-24-2015, 06:18 AM
New to Overclock.net
 
haXBOXpro's Avatar
 
Join Date: Jun 2015
Posts: 1
Rep: 0
Hi. i have been looking for a clear step by step guide like this one.
i have a question though, would this process work on nvFlashing gtx980m SLi?
This is on windows8 setup using UEFI Boot.
Would your method work ??
haXBOXpro is offline  
Sponsored Links
Advertisement
 
post #54 of 97 (permalink) Old 08-12-2015, 02:00 AM
New to Overclock.net
 
bobytt's Avatar
 
Join Date: May 2011
Location: Miami Beach
Posts: 15
Rep: 1 (Unique: 1)
How long does it take to flash the BIOS?
bobytt is offline  
post #55 of 97 (permalink) Old 08-13-2015, 03:19 PM
New to Overclock.net
 
mrzoo's Avatar
 
Join Date: Dec 2013
Posts: 127
Rep: 1 (Unique: 1)
NEED HELP!!!! I just got another GPU for sli and went to flash bios when I went to device manager and disabled one of the drivers screen went black . PC is still on I just have no picture
mrzoo is offline  
post #56 of 97 (permalink) Old 08-13-2015, 04:25 PM
New to Overclock.net
 
mrzoo's Avatar
 
Join Date: Dec 2013
Posts: 127
Rep: 1 (Unique: 1)
Quote:
Originally Posted by mrzoo View Post

NEED HELP!!!! I just got another GPU for sli and went to flash bios when I went to device manager and disabled one of the drivers screen went black . PC is still on I just have no picture
nevermind i fixed it now just gotta make sure i flash both cards so they have same stock bios
mrzoo is offline  
post #57 of 97 (permalink) Old 08-13-2015, 04:28 PM
New to Overclock.net
 
mrzoo's Avatar
 
Join Date: Dec 2013
Posts: 127
Rep: 1 (Unique: 1)
only problem im having is cprompt says it can not open my rom file any ideas?
mrzoo is offline  
post #58 of 97 (permalink) Old 08-25-2015, 05:42 PM
New to Overclock.net
 
22Green's Avatar
 
Join Date: Aug 2015
Posts: 2
Rep: 0
Hello I didn't see any mention if you get this error and Googling seems to bring up some threads but wanted to see what feedback I would get here.

I have a Nvidia GTX970 with this BIOS recently DL'd: (assume its the latest)

NVIDIA.GTX970.4096.140826.rom

I follow the steps pretty straight fwd and I get this error. (I exited out of cmd prompt I got nervous didn't wanna hose my card)

"Firmware image PCI Subsystem ID xxxx.xxxx does not match adapter PCI Subsystem ID xxxx.xxxx

Another forum says ignore it? "just ignore the error (this error will cause no harm, it's just letting you know you are changing the subvendor on the card from EVGA to NVIDIA."

This from EVGA forum but I have already a Nvidia card so i'm not changing subvendors..

I don't know I just bought the card how old can the BIOS be from this one. Current says 84.04.36.00.01 from GPU-Z

Thoughts?

TIA
22Green is offline  
post #59 of 97 (permalink) Old 08-25-2015, 06:13 PM
New to Overclock.net
 
22Green's Avatar
 
Join Date: Aug 2015
Posts: 2
Rep: 0
I think I have the most recent or very close to it.

From http://station-drivers.com (not sure what the F9 means...)

nVidia GeForce GTX 970 Bios Version 84.04.31.00.F9

Description:
MSINV316MH.1F3 11/21/14 Version 84.04.31.00.F9
Rating:
Total Votes: 0

I have 84.04.36.00.01 -- just form logic and installing drivers my current BIOS looks newer..
22Green is offline  
post #60 of 97 (permalink) Old 09-01-2015, 09:36 AM
New to Overclock.net
 
Hawtkward's Avatar
 
Join Date: Sep 2015
Posts: 1
Rep: 0
Hello guys. Got a really wierd problem, havn't seen someone feedback'd it yet.

Tried all bios versions for my evga gtx970 sc acx2.0 from this thread http://forums.evga.com/Solution-For-quotBlack-Screenquot-Problem-For-GTX-970-SC-ACX20-2974-m2332911.aspx , the card version (or whatever number -2974 means) is correct. Made everything exactly following instructions, even tried different versions of nvflash software. Primary VGA is PCIE in bios setup.

BUT:
After last step, when i have to activate gpu and restart system, after reboot i have black screen, no beeps from m/b, 15-20 second later my devices (keyboard, mouse) get power (led activates on all devices), and 5-10 seconds after i see the "signal not found" alert on the display.

So after that i rolled back to original bios, and i'm literally forced to use it atm.

Any suggestions? Maybe anyone had this problem?
Hawtkward is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off