Overclock.net - An Overclocking Community - Reply to Topic

Thread: Swiftech H220/H320/H220X/H240X/H140X and CM Glacer 240L/360L Owners' Club Reply to Thread
Title:
Message:

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
12-01-2019 03:08 PM
Madmaxneo
Quote: Originally Posted by ciarlatano View Post
Sorry, totally forgot about the old naming scheme for a second. The same holds true for 140mm fans, with the same recommendations in 140mm size - the Phanteks F140MP and Silent Wings 3.
Cool, thanks. I already had those up in Amazon. I may order two of them then maybe one for the H120, or is that an H140?....LOL I really need to look at it...

EDIT: Yeah, that old naming scheme was hard to understand for a lot of people, I think that's why they changed it to a more standard naming scheme...lol.
12-01-2019 12:47 PM
ciarlatano
Quote: Originally Posted by Madmaxneo View Post
The H240-X was 2 140mm fans. I am not even sure there are mounting holes for 120 mm fans.

Are there better 140mm fans for this than the Helix fans?
Sorry, totally forgot about the old naming scheme for a second. The same holds true for 140mm fans, with the same recommendations in 140mm size - the Phanteks F140MP and Silent Wings 3.
12-01-2019 12:41 PM
Madmaxneo
Quote: Originally Posted by ciarlatano View Post
There are a great number of fans better than the 120mm Helix that were included with the H240-X. The Swiftech fans were always the weak link in the package, which is why the Prestige units came with eLoops that improved performance. An inexpensive option would be something like the Phanteks F120MP which has significantly better performance and can be found for ~$12-14 each. Or you could go into best of the best territory with the be quiet Silent Wings 3.
The H240-X was 2 140mm fans. I am not even sure there are mounting holes for 120 mm fans.

Are there better 140mm fans for this than the Helix fans?
12-01-2019 12:31 PM
ciarlatano
Quote: Originally Posted by Madmaxneo View Post
I'm sure there were people from back then who say the customer service was crap at that time...lol.

I upgraded my old X block to a Heatkiller IV Pro and I still use the fans that came with the H 240-X unit (both have been replaced once). Are there a better fans I can use than the ones that came with the H240-X?
I also have an H140 that cools my GPU with a Heatkiller IV pro block. But that one is only maybe 2 years old.
There are a great number of fans better than the 120mm Helix that were included with the H240-X. The Swiftech fans were always the weak link in the package, which is why the Prestige units came with eLoops that improved performance. An inexpensive option would be something like the Phanteks F120MP which has significantly better performance and can be found for ~$12-14 each. Or you could go into best of the best territory with the be quiet Silent Wings 3.
12-01-2019 09:51 AM
KillerBee33 I think i've asked this before but can someone suggest idle RPM for 360X3 pump, i got CPU+GPU loop and added a 240 rad. on top. In order "pump to CPU-Top radiator-GPU-Main radiator"
12-01-2019 08:14 AM
KillerBee33
Quote: Originally Posted by Madmaxneo View Post
I'm sure there were people from back then who say the customer service was crap at that time...lol.

I upgraded my old X block to a Heatkiller IV Pro and I still use the fans that came with the H 240-X unit (both have been replaced once). Are there a better fans I can use than the ones that came with the H240-X?
I still have the unused H320X2 fans plus these new ones from X3. Gonna run my NB-eLoop Series 120 until they burn out. Not sure about the performance, havent tried other fans in 4 years
11-30-2019 10:55 PM
Madmaxneo
Quote: Originally Posted by KillerBee33 View Post
Mine did good for 4 years and back in 2016 their Customer Support was great, so i decided to stick with swiftech for the time bein'. The 360X3 by what i see has no difference from X2, i used old fans Noise Blocker and kept the cpu block from X2.
I'm sure there were people from back then who say the customer service was crap at that time...lol.

I upgraded my old X block to a Heatkiller IV Pro and I still use the fans that came with the H 240-X unit (both have been replaced once). Are there a better fans I can use than the ones that came with the H240-X?
I also have an H140 that cools my GPU with a Heatkiller IV pro block. But that one is only maybe 2 years old.
11-30-2019 11:48 AM
KillerBee33
Quote: Originally Posted by Madmaxneo View Post
I have been waiting on my H-240X to start leaking since the last time (2 or 3 years ago) I changed the window it cracked and one of the screws are stripped out. Been running in my machine with no issues so far. I have changed the fluid out a few times since installing it though. I really really want to get one of the X3's (probably the 360) but it is not in my budget right now...lol.
Mine did good for 4 years and back in 2016 their Customer Support was great, so i decided to stick with swiftech for the time bein'. The 360X3 by what i see has no difference from X2, i used old fans Noise Blocker and kept the cpu block from X2.
11-30-2019 11:27 AM
Madmaxneo I have been waiting on my H-240X to start leaking since the last time (2 or 3 years ago) I changed the window it cracked and one of the screws are stripped out. Been running in my machine with no issues so far. I have changed the fluid out a few times since installing it though. I really really want to get one of the X3's (probably the 360) but it is not in my budget right now...lol.
11-30-2019 06:31 AM
KillerBee33
Quote: Originally Posted by chrisjames61 View Post
Probably would have been very easy to identify the leak and fix it.
It was the the nut inside the reservoir (where it connects with the pump) which got cracked and i wasnt gonna glue anything that already started cracking.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off