Overclock.net - An Overclocking Community - Reply to Topic
Thread: Swiftech H220/H320/H220X/H240X/H140X and CM Glacer 240L/360L Owners' Club Reply to Thread
Title:
Message:

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
03-29-2020 05:48 PM
mush332 Hey been a while. So I just ordered new cpu and mobo and made the switch to the amd ryzen 9 3900x. I currently run a i7-7700k. My question is can I take my sons spare parts from his after market fan and use it to mount my h240 on my new cpu? Or would I have to buy a new cooler entirely?
03-19-2020 09:19 PM
Madmaxneo It seems my temps are starting to climb up again as the days start to get warmer. Not sure but they seem a bit higher than last year.
Right now with about 10% cpu usage I am seeing temps in the low to mid 40's, where they used to be in the low 30's. My temps don't usually start creeping up like this until the summer when higher temps in the 80's and 90's hit. Those temps don't seem that bad because I do have my cpu OC'd at 4.2 ghz.
I replaced my thermal paste like 3 months ago with a system flush and refill because my temps seemed a bit high for the winter. Not sure if I should reapply the paste or look into getting a larger AIO (I use the 240-X with a heatkiller IV pro block on my cpu only) but I do not have the money for one right now. Though it could be my pump is starting to slow down.

I will run a bench or stress test and report back with the temp results in a few.

I am looking for suggestions on what I can do to hopefully improve my temps. I prefer the cheapest route possible because I am currently trying to save some money to upgrade my system.

Edit: I ran OCCT for about 20 mins and my CPU temps peaked at 70, and it has never gotten that high before on the same test. It usually goes no higher than about 63.

Edit 2: I ran Time Spy and it acted weird. My cpu never went above 27% usage and my GPU never went over 2% yet the GPU temp ran up to 54 deg. Which is high, but then when I ran Firestrike and the GPU hit 100% but it never went over 42 deg. The GPU is cooled by a H140 with a heatkiller IV pro block.
03-18-2020 07:45 PM
Veii
Quote: Originally Posted by ciarlatano View Post
I've contacted them
Yes it changed now ~ thank you for doublechecking
Wouldn't else bother to ask, if anything was in stock
Close to all copper CLC options where gone, no alphacool LT solo for own CLC designs
And didn't find any slim formfactor block/pump combos - nor rad-pump combos of the shelf
~ all where out of stock on 5 etailers so far
03-18-2020 10:04 AM
ciarlatano
Quote: Originally Posted by Veii View Post
Can somebody tell me any ETA for when the H240X are gonna be back in stock
http://site.swiftech.com/support/

Also, PPC shows low stock, not out of stock - https://www.performance-pcs.com/wate...io-h240x3.html
03-17-2020 08:56 PM
Veii Can somebody tell me any ETA for when the H240X are gonna be back in stock
Im looking for an ITX build in a tiny Node S + for a 3900X+Asus Impact
Sadly even performance-pc has them out of stock ~ maybe you guys know another e-tailer ?
Location US, this time

@v1ral the Fractal Design Node S , can fit that 240X for example , the 220X shouldn't be different
03-03-2020 01:29 AM
Wam7 I picked up my H220-X from a Dutch company and at the time I think there was at least another place in the E.U. that sold them. I'm thinking of getting the H360 X3 but it seems like previous issues and increased competition has made them near impossible to find at any outlets. Does anybody know of anywhere this side of the pond that sells them? There used to be a Swiftech rep in here, I don't suppose there still is?
02-08-2020 10:39 AM
mfknjadagr8
Quote: Originally Posted by ciarlatano View Post
Quote: Originally Posted by mfknjadagr8 View Post
I have a mcp50x and the h220x (which uses the mcp35x) in the same loop for years now with zero issues...I have a 480 monster and a 420 ek le rad and the 220x with two video cards blocked and have never had a flow issue even running the mcp50x solo they are very good pumps
Agreed, they are excellent pumps. But, the H220X uses and MCP30, which is an MCP50X based pump. The MCP35X is a Laing DDC based pump, and is not compatible (in terms of direct replacement) with the MCP50X or MCP30
The swiftech rep that sent me an email about six years ago must've accidentally told me the wrong pump then when I asked thanks for the clarification....iirc the max speed of the mcp30 is slightly lower than the mcp50x but has shown zero effects in my loop but I also have a pretty non restrictive loop not sure that that would matter but I've only had two loops so far and both I chose non restrictive blocks and fairly non restrictive rads.....

If I showed pictures of my loop right now youde have me banned from ocn it's way overdue a cleaning...I just dont have the time working 7 days a week and having a 2 year old...
02-07-2020 09:31 AM
ciarlatano
Quote: Originally Posted by mfknjadagr8 View Post
I have a mcp50x and the h220x (which uses the mcp35x) in the same loop for years now with zero issues...I have a 480 monster and a 420 ek le rad and the 220x with two video cards blocked and have never had a flow issue even running the mcp50x solo they are very good pumps
Agreed, they are excellent pumps. But, the H220X uses and MCP30, which is an MCP50X based pump. The MCP35X is a Laing DDC based pump, and is not compatible (in terms of direct replacement) with the MCP50X or MCP30
02-07-2020 09:24 AM
mfknjadagr8 I have a mcp50x and the h220x (which uses the mcp35x) in the same loop for years now with zero issues...I have a 480 monster and a 420 ek le rad and the 220x with two video cards blocked and have never had a flow issue even running the mcp50x solo they are very good pumps
01-30-2020 08:51 AM
ciarlatano
Quote: Originally Posted by ntuason View Post
That MCP50X sounds interesting thank you!
Just out of curiosity, if I were to purchase a reservoir + pump (D5) combo and add it to my loop, would I run into trouble mixing H360X3 weaker pump with the D5?
Wouldn’t the weaker H360X3 pump struggle to keep up with the D5?

+Rep.
You can run two pumps that are not alike with no issues.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off