Overclock.net - An Overclocking Community - Reply to Topic

Thread: FIX: AHCI/SATA drives showing in "Safely Remove Hardware" Reply to Thread
Title:
Message:

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-27-2018 05:36 PM
Br0ski
Just a great big THANK YOU

Quote: Originally Posted by t0adphr0g View Post
Ever since I set my BIOS to AHCI, I was plagued with my SATA connected drives showing up in the "Safely Remove Hardware" icon.

I understand that eSata, and USB devices should show up there. However, my internal devices, HDDs, CD/DVD/BluRay are showing up as well.

I didn't want to have to reinstall Windows 7, and set BIOS to SATA/RAID.
I wanted a better solution.
I found it!


This is a Registry fix.
You should ALWAYS back up your registry before you make changes - it only takes a second to do it, and if anything happens to it you'll need to reinstall...
Here we go...

Regedit your way to:
HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ services\ msahci
and create a new KEY called "Controller0"
inside Controller0, create a new KEY called "Channel0"
Now inside Channel0, create a new DWORD called "TreatAsInternalPort"
set this value to "1"
(this sets SATA port 0 (Drive C)to no longer show up in "Safely Remove Hardware")

Now, go back into the Controller0 folder again.
inside Controller0, create a new KEY called "Channel1"
Now inside Channel1, create a new DWORD called "TreatAsInternalPort"
set this value to "1"
(this sets SATA port 1 (Drive D)to no longer show up in "Safely Remove Hardware")

And so on, until all internal SATA ports are set to be treated as Internal.
My motherboard has 6 SATA ports, so I have set Channel0 to Channel5.

Here is an example of my registry change:



Your motherboard may have more or less SATA ports,
just remember to start with 0
6 Ports = 0-5 etc.

Now Reboot to allow changes.

Hooray! only external devices show up now!



Quote: Originally Posted by lollerskates View Post
Quote:Originally Posted by t0adphr0g 

You just need to go into your Device Manager to turn off the "Safely Remove" function.
here I took a picture:

Open Device Manager, open Storage controllers, then just right click "Marvell 91xx...", choose properties, then go to the policies tab, and uncheck the box "Enable safely remove disk."
I would then reboot, to see the change.


DOOOOD I know I am late to the party. I have old ass computers. But you guys just fixed 80% of my problems right now!! So I had to log on and give a great big shout out!!!

Thank you Thank you Thank you (t0adphr0g & lollerskates) in 2018 !!!

(lollerskates if you didn't quote I would have missed the .jpgs, thank you too)
05-27-2017 07:58 PM
realthing
Quote:
Originally Posted by cokker View Post

I found a solution for windows 10 thanks to PCo over at http://superuser.com/a/961242

Backup your registry!

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device
  • Add a new "Multi String Value" called "TreatAsInternalPort" (no quotes).
  • Modify the new entry by adding 0 (press return), 1 (return), 2,3,4,5 (add one more return) this would be for a 6 sata port motherboard)). You should have something that looks like this: http://i.stack.imgur.com/jdPUV.png
  • Exit and reboot, (you may get an error that flashes up while it shuts down, don't panic it only seems to be the once.)

I guess you could edit this "TreatAsInternalPort" entry to exclude any ports you may want to eject in the future.


That worked perfect. Thank you!
03-15-2016 10:21 AM
muradiy Hi there,

i had the same problem and this solution worked for me.
I would like to mention that when you choose DWORD, choose the 32bit variant.
The 64bit option didn't do a thing for me.

Windows 7 Ultimate,
SSD: M4 CT064M4SSD2
MB: Gigabyte GA-P55-UD4 with BIOS version F9

bye
01-16-2016 12:05 AM
exploiteddna
Quote:
Originally Posted by cokker View Post

I found a solution for windows 10 thanks to PCo over at http://superuser.com/a/961242

Backup your registry!

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device
  • Add a new "Multi String Value" called "TreatAsInternalPort" (no quotes).
  • Modify the new entry by adding 0 (press return), 1 (return), 2,3,4,5 (add one more return) this would be for a 6 sata port motherboard)). You should have something that looks like this: http://i.stack.imgur.com/jdPUV.png
  • Exit and reboot, (you may get an error that flashes up while it shuts down, don't panic it only seems to be the once.)

I guess you could edit this "TreatAsInternalPort" entry to exclude any ports you may want to eject in the future.

perfect, this worked very well for me (win 10 pro, evga z87 FTW)
11-12-2015 01:10 AM
benzrvd on marvell controller, i already disable hot-plug safe and remove features, everything work fine but when

shutdown it happen C0 Power-Off Retract Count (Unsafe Shutdown Count) increment every time on my WD 6 TB disk

Marvell® 88SE9172 chip: driver version 1.0.0.1061 how should i do?
10-10-2015 03:22 PM
Herophobic
Quote:
Originally Posted by cokker View Post

I found a solution for windows 10 thanks to PCo over at http://superuser.com/a/961242

Backup your registry!

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device
  • Add a new "Multi String Value" called "TreatAsInternalPort" (no quotes).
  • Modify the new entry by adding 0 (press return), 1 (return), 2,3,4,5 (add one more return) this would be for a 6 sata port motherboard)). You should have something that looks like this: http://i.stack.imgur.com/jdPUV.png
  • Exit and reboot, (you may get an error that flashes up while it shuts down, don't panic it only seems to be the once.)

I guess you could edit this "TreatAsInternalPort" entry to exclude any ports you may want to eject in the future.
It's been a while since I posted here.
Thanks a lot for this tip, it fixed my problem. smile.gif
There should be a link to your post in OP.
09-13-2015 12:08 PM
t0adphr0g HITTI,

This post was written so long ago, and I do admit that in my case I did not have UEFI, nor RAID in my setup when I wrote this.

This "fix" was for Windows 7 registry, and how Internal HDDs would show up in the "Safely Remove Hardware..." thingie.

I am surprised that this post keeps getting woken up occasionally, and I am glad that it helps. Unfortunately, this fix is not a "be all- end all" fix.
This is just something that worked for me, in my situation, and that I hoped I could share.

t0adphr0g
09-13-2015 05:51 AM
HITTI
Quote:
Originally Posted by t0adphr0g View Post

Ever since I set my BIOS to AHCI, I was plagued with my SATA connected drives showing up in the "Safely Remove Hardware" icon.

I understand that eSata, and USB devices should show up there. However, my internal devices, HDDs, CD/DVD/BluRay are showing up as well.

I didn't want to have to reinstall Windows 7, and set BIOS to SATA/RAID.
I wanted a better solution.
I found it!


This is a Registry fix.
You should ALWAYS back up your registry before you make changes - it only takes a second to do it, and if anything happens to it you'll need to reinstall...
Here we go...

Regedit your way to:
HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ services\ msahci
and create a new KEY called "Controller0"
inside Controller0, create a new KEY called "Channel0"
Now inside Channel0, create a new DWORD called "TreatAsInternalPort"
set this value to "1"
(this sets SATA port 0 (Drive C)to no longer show up in "Safely Remove Hardware")

Now, go back into the Controller0 folder again.
inside Controller0, create a new KEY called "Channel1"
Now inside Channel1, create a new DWORD called "TreatAsInternalPort"
set this value to "1"
(this sets SATA port 1 (Drive D)to no longer show up in "Safely Remove Hardware")

And so on, until all internal SATA ports are set to be treated as Internal.
My motherboard has 6 SATA ports, so I have set Channel0 to Channel5.

Here is an example of my registry change:

AHCIregedit.png

Your motherboard may have more or less SATA ports,
just remember to start with 0
6 Ports = 0-5 etc.

Now Reboot to allow changes.

Hooray! only external devices show up now!

Ok, I tried this and it does not work. I followed exactly and rebooted. I am in RAID mode through UEFI. WIndows7 x64.


Edit:
I am also using IRST v14.6.0.1029
09-11-2015 08:42 AM
HITTI
Quote:
Originally Posted by t0adphr0g View Post

I have a ASUS Sabertooth X58 motherboard, this also has a Marvell SATA 6 controller.

You just need to go into your Device Manager to turn off the "Safely Remove" function.

here I took a picture:

453

Open Device Manager, open Storage controllers, then just right click "Marvell 91xx...", choose properties, then go to the policies tab, and uncheck the box "Enable safely remove disk."

I would then reboot, to see the change.

Awesome!

I ordered a second 840 pro, had to move some stuff around "sata port connectors". As my board only has two 6GB/s and the rest 4 are 3GB/s. I've got a marvel raid card 91xx, had to switch a sata III 6GB/s hdd to the marvel raid card, cuz my two 840's are gonna be on my intel chipset as raid in sata 3 thumb.gif.

This solution works perfect, Thanks!
09-06-2015 08:18 AM
cokker I found a solution for windows 10 thanks to PCo over at http://superuser.com/a/961242

Backup your registry!

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device
  • Add a new "Multi String Value" called "TreatAsInternalPort" (no quotes).
  • Modify the new entry by adding 0 (press return), 1 (return), 2,3,4,5 (add one more return) this would be for a 6 sata port motherboard)). You should have something that looks like this: http://i.stack.imgur.com/jdPUV.png
  • Exit and reboot, (you may get an error that flashes up while it shuts down, don't panic it only seems to be the once.)

I guess you could edit this "TreatAsInternalPort" entry to exclude any ports you may want to eject in the future.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off