Overclock.net - An Overclocking Community - Reply to Topic

Thread: Swiftech H220/H320/H220X/H240X/H140X and CM Glacer 240L/360L Owners' Club Reply to Thread
Title:
Message:

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-05-2019 05:13 PM
zila
Quote: Originally Posted by MadGoat View Post
Still rocking my H220 (with a MCP50X pump). Obviously a little modded but still love this cooler.

Love the way it looks. Nice job.
06-15-2019 11:18 AM
MadGoat Still rocking my H220 (with a MCP50X pump). Obviously a little modded but still love this cooler.
06-09-2019 04:55 AM
Unknownm
Quote: Originally Posted by zila View Post
I'm using my Glacer 240L on my 2700X. I just had to get the Swiftech AM4 bracket for it. I have one for my Swiftech H220 too. The coolers work fine and all I needed was the brackets to use them on the newer chips. I wish they still made these.
Yeah I figured theres some type adapter.

But really for what. My 2600X will hit 4.2ghz with 1.375v closer to 1.4v but currently 4.1ghz 1.3v

Attaching h320 just to gain 100mhz and whole 0.1v extra is not worth it.


However it was a great AIO it will be missed

Sent from my SM-G960W using Tapatalk
06-06-2019 08:53 PM
zila
Quote: Originally Posted by Unknownm View Post
I have to say goodbye to my original H320 that had it's liquid replaced after 4 years about 2 months ago

I upgraded to 2600X and the H320 doesn't fit AM4.

Now I'm selling it, thank you swiftech for making a awesome product
I'm using my Glacer 240L on my 2700X. I just had to get the Swiftech AM4 bracket for it. I have one for my Swiftech H220 too. The coolers work fine and all I needed was the brackets to use them on the newer chips. I wish they still made these.
05-26-2019 09:32 AM
NIK1 I have a question for Swiftech owners..Is it OK to use Cool Labs Liquid Ultra Liquid Metal on a Swiftech H220X WaterBlock I have.I am going to delid the CPU anyway and wonder if its safe to put a tad on the waterblock too..I have heard great results from others who have tried this but not sure if they used Swiftech..Would like to ask here first to be certain.
05-09-2019 01:43 AM
Imprezzion
Quote: Originally Posted by Unknownm View Post
Bought my H320 from NCIX Burnaby late 2014

4 years of ownership its about time to replace the liquid. Also because 1 year ago temps got high had to lower the overclock

Never changed liquid AIO before but through some guides and help of posts I FINALLY change it


Its not hard as I was thinking, copper block had good amount of black junk that helped raise those temps one year ago.



Last picture is with high voltage (applied year old overclock again) now sitting strong at 84c prime95 avx 4k

Sent from my SM-G960W using Tapatalk
My old H320 from around the same period is also still running strong.

I had the same residu on my copper as well last time I cleaned it. I cleaned the plate with a toothbrush hehe. Works really well.

Only problem is, I overtightened a screw on the block and it stripped in the pump plastic. Had to replace it with a similar self-tapping screw with coarser thread. It's not leaking but it's a bit of a shame I did that 😞.

Not using it in my main rig but in a server running Minecraft private world and a TS3 server now. Only cooling a 4.5Ghz 2600K now and it never goes above 55c.
05-07-2019 06:29 PM
ciarlatano
Quote: Originally Posted by Madmaxneo View Post
I wonder, can that rad be fitted with the pump from a H240-X? If so how much are you selling it for cause I may be interested.
Not easily. It doesn't have the res, which is what the pump mounts to. It is essentially a standard rad with an extra fill port.
05-07-2019 04:58 PM
Madmaxneo
Quote: Originally Posted by Unknownm View Post
I have to say goodbye to my original H320 that had it's liquid replaced after 4 years about 2 months ago

I upgraded to 2600X and the H320 doesn't fit AM4.

Now I'm selling it, thank you swiftech for making a awesome product
I wonder, can that rad be fitted with the pump from a H240-X? If so how much are you selling it for cause I may be interested.
05-07-2019 03:46 PM
Unknownm I have to say goodbye to my original H320 that had it's liquid replaced after 4 years about 2 months ago

I upgraded to 2600X and the H320 doesn't fit AM4.

Now I'm selling it, thank you swiftech for making a awesome product
05-06-2019 05:24 PM
BobBagels hello hello,
I need to ask a question.

I have an original H240. The one with the bleeder screw going through the plastic window. (that has been long changed, screw removed, window replaced)
Its still running, keeps my 5930K (with a mild oc) nice and cool to this day.

However I see green in there. Now I know I can clean it out (which I will do) . But I am kinda thinking about getting a new one altogether and keeping what I have now for either something else or just as a spare.

Ive been thinking about the H360.
http://www.swiftech.com/drive-x3-aio.aspx
Which I am sure will fit in my case. (Phanteks Entho Primo)

My question is, considering I am already using a Swiftech CPU block would I have to change the back plate? Or would the new block line up & work with the old back plate ?
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off