Overclock.net - An Overclocking Community - Reply to Topic

Thread: Compact Splash Brotherhood Reply to Thread
Title:
Message:

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
03-26-2019 01:09 PM
RPGdesign I might sell mine. I'm in Europe. Contact me in PM.
02-01-2019 11:25 AM
Lutfij Atta boy!
Stick it out no matter what!
01-09-2019 04:20 AM
catbuster Will never sell mine, even tho its in box waiting for better times
01-08-2019 10:22 AM
galletabah someone selling it on europe? I love this case
10-04-2018 02:30 PM
Lutfij This will seem like a double post but, wait, it's not!

I present, something I've stumbled upon on YT:

More options
10-02-2018 12:10 PM
Lutfij Hey bud!

Lovely to read your message here! I'm still holding onto my coveted cases still WIP
10-02-2018 12:08 PM
She loved E Hi y'all! Been ages but wanted to check in. Believe it or not, I still have a small selection of power switches and M3 fasteners used on the case. If anyone needs anything please PM me and I can see if I have what you need. I also had a power switch fail earlier this year and swapped in a new one and that did the trick!

Has anyone heard from golfergolfer lately? Tried to send him an email and it bounced, will PM him as well. Cheers!
08-19-2018 10:56 AM
Lutfij All the screws are M3 threading, If I recall. It's good to have you back with us...after a hiatus
08-16-2018 05:06 AM
concept73 Long time no see guys,

Looking to resurrect #89 and do a fresh build but was wanting to refresh some of the hardware.
I've done a quick search but can't seem to find any information on the screws that are used as i have barely enough.

So good to be back though, can't wait to start the hell and cut hands that was building it the first time.
06-30-2018 01:01 AM
imersa
Quote: Originally Posted by DoctaHuff View Post
Yeah I mean I am gonna guess at a broken switch, as it is pretty much written right there.

Though I've not seen the switch, usually there is + and a - on the switch itself, this is for the LED though, so you can leave that for later, normally inner most terminals are POWER SW, but lots of switches out there.

Ignore the LED ones when testing, POWER SW is the power switch, connect that and you'll be good to go.
If it isn't working, connect the wire and not the switch, then press the two metal ends of the switch together and see if that turns it on. If it does, you've either connected the switch end wrong, or your physical switch is dead.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off