Overclock.net - An Overclocking Community - Reply to Topic

Thread: Ryzen BIOS mods + how to update BIOS correctly Reply to Thread
Title:
Message:

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
12-11-2019 01:23 PM
x58haze A request for Asrock Ab350 fatality k4 Gaming for cpu summit ridge (1st generation ryzen) Cause Asrock doesn't care about 1st ryzen generation they didn't put spread spectrum among others importat features
12-07-2019 05:22 PM
Nicolaj Is there a thread for asrock boards?
11-28-2019 03:13 PM
Mckol Hello, I have tried using this method to flash official BIOS on my MSI B350 PC MATE motherboard after a beta update broke M-Flash, unfortunately it no longer posts, it doesn't support flashback nor does it have dual bios. I have tried taking out the cmos batterry and unplugging the pc for a few minutes but that didn't change anything. More details about what exactly happened are in this thread: https://www.overclock.net/forum/11-a...l#post28215408

Note: I only used Afuefix64 and not Afugan because I figured they both did the same thing and the second one was only used for flashing a BIOS modification.

Is there any way for me to try and fix it myself? Or is sending it to a service center the only option left?

Edit: I have looked around and it seems that you can flash the bios chip externally with an SPI programmer using the JSPI header on the motherboard, I've found the exact bios chip model and the datasheet so I'm gonna look into that.
11-21-2019 09:48 AM
SkyRE Hi Everybody,

I've found BIOS from QNAP for Zen+ series CPUs. HW itself built for Zen series (TS-x77 series).
I updated its microcodes using UBU.
After that I replaced some EPYC microcode (800F12) to Zen2 (870F10) using hexeditor.
I even extracted not latest 870F10 microcode from Gygabyte BIOS and replaced using hexeditor same way and updated it using UBU to latest version. Checked md5 and they have match.
MMTool showed that all 8xxFxx microcodes are placed in Padding section, so no need to look for GUIDs and so on.
I've looked for all blocks from 1usmus and it seems that PMU is 0.0.7.2.

Could somebody check is all was done correctly with these mods. Because brick few $K NAS is not so good perspective.
11-20-2019 04:41 AM
geronimo It's really a laugh when they recommend using RAM from QVL. I mean c'mon the list of mem is very limited at least for my mainboard.
11-20-2019 04:36 AM
evilhf
MSI X370 GAMING PRO CARBON MEMORY LOCKED AT 2133MHz

Hello guys, can you help me?
I have an MSI X370 Gaming Pro Carbon card with G.Skill F4-4000C17-16GTRS memories.
Not 1003 ABBA and earlier bios can run my memory on 3733mhz cl14.
Now, with the latest release of bios 1004 patch B, my memory gets stuck 2133mhz!
If you set XMP the system will not boot and I hear 3 long whistles.
If I put exactly the same timings and frequency I used in the previous bios successfully, in this bios I also have no boot and 3 long whistles.
Could you modify something in bios to correct this problem?
I sent a ticket to MSI about the problem and they informed me that my memory is not in the board's QVL and they recommended me to use the old bios 1003 where it is stable.
11-12-2019 05:15 AM
snipernote Hello

Thank you for this lovely information on how to update bios

I have 2 questions :
1. Can i use Afuefix64 aew.f10c /P /B /N /K /X /CLRCFG or it should be .cap ?
Motherboard is x570 aorus elite wifi and i usually update bios via Qflash ( i have problem with xmp on my motherboard cannot boot when i turn it on ram is 16gbx2 corsair ddr4 3200 cl16 hynix afr on latest update Which is f10c , on bios F3b was working fine )
2. If xmp still have problem on F10c do you recommend i flash F3b back ?


Update : i tried flashing using afuefix64 and afugan and both give error 46 ... Only way i can flash bios without qflash is from dos ans efiflash app from gigabyte
11-05-2019 04:46 AM
nbot
Quote: Originally Posted by Draklord View Post
Been traveling i will get you the photos this week sorry for the delay.
1. my bios is fully unlocked for all features. The down side is once its unlocked you need to manually setup the fan curve in the bios.
2. If i recall right i think its a 24xx.
3. I have patched the micro codes using UBU if you look at what it says it patched you'll find that it did not add the missing micro code for zen+ or zen2.
4. i was able to boot with the patched codes no problem.
5. As the bios still reports the AGESA for the chips it was originally shipped with i have not tried adding a zen+ or zen2 based cpu.
I decided to stop the investigation process for now because it's the only laptop I have currently and I use it for work so if it goes to hell I have nothing to work on
But in my case when I run UBU it actually replaced some microcodes - have you been using the most up to date UBU version?

I'm not sure if replacing microcodes would be enough, because there might be some other modules that need to be replaced too. But as I said I'm a newbie and don't take my word for granted... Maybe somebody more experienced could chime in? I think the ultimate test would be plugging in newer CPUs and see if that works

I found the other chip on the back side of MB as you mentioned but you can still post pictures so others might find it useful in the future

Can you post modified BIOS image somewhere?
11-04-2019 01:14 PM
Draklord
Quote: Originally Posted by nbot View Post
Ok, I'm pretty sure I saw it underneath the GPU heat sink part, but I might be wrong
Any details would be really apprieciated.
Some more questions:
- How far did you go with modding? If you have any pictures showing Bios chip it would be really cool.
- Few pages ago you mentioned you have unlocked Bios. What is exactly unlocked there?
- Is it 25XXX or 24XXX EPROM ?
- Did you try to patch CPU microcodes with most recent UBU and flash it? Did it work?
- Were you able to lunch Windows with microcodes updated? Any BSODs ?
- Have you tried the modded Bios with Ryzen 3rd gen CPU ?

Thanks
Been traveling i will get you the photos this week sorry for the delay.
1. my bios is fully unlocked for all features. The down side is once its unlocked you need to manually setup the fan curve in the bios.
2. If i recall right i think its a 24xx.
3. I have patched the micro codes using UBU if you look at what it says it patched you'll find that it did not add the missing micro code for zen+ or zen2.
4. i was able to boot with the patched codes no problem.
5. As the bios still reports the AGESA for the chips it was originally shipped with i have not tried adding a zen+ or zen2 based cpu.
11-02-2019 10:04 AM
2600ryzen I'm trying to update my b350 asus tuf gaming to a 5007 modded bios but when I tried to update the official 5007 bios in step 1 I get "error 4 signature incorrect" and it wont update. Anyone know why the first step would not be working for me? I updated to the official 5007 bios from ezflasher and it worked fine there.


Edit - Nevermind I got it figured out now.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off