Overclock.net - An Overclocking Community - Reply to Topic
Thread: [150MHz bug] Min Memory Clock at GPU=100% load Reply to Thread
Title:
Message:

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-17-2019 08:10 AM
ruslbug2d Classic theme for Windows 7 with GPU acceleration "Classic AE mod 2019_7" (October 14, 2019)

This theme based on "Classic AE 2.5.3" Classic AE 2.5.3 Final by Saarineames on DeviantArt

Complete list of modifications:
1) Added a gradient to the window title
2) The correct color of the text in the active and inactive window titles
3) Normal Tahoma-font (without ClearType)
4) The correct gray color in all elements of the interface RGB (212, 208, 200)
5) Correct TrackBar
6) Classic menu (fixed color)
7) For a better view, the highlighted item on a gray background is darker than on a white
8) ProgressBar animation is disabled
9) No-skins cursors are used
10) Fixed a bug in ScrollBar
11) Fixed background color Windows Firewall
12) Fixed aero mode crach at 125% font size
13) Darker active window title in non-aero mode
14) Correct resource IMAGE#1136
15) Fixed text captions (white field in Outpost)
16) TaskManager and Calculator with a classic design are attached,
and additional programs recommended for use:
- 7tt_setup - very useful tweaker of the TaskBar
- ClassicShellSetup_4_3_1-ru - for classic "Start" menu
- FONTS_140516 - replaces the font Segoe 9 with Tahoma 8 in all dialogs
- Win7 Style Builder v1.5.0.0 - msstyles file editor, if you want to modify this theme

Theme "Classic AE mod 2019_7":


Theme "Luna Aero":


Install:
1) Install "UniversalThemePatcher" (Recommended) or "UxStyle" for your Windows 7 OS (32- or 64-bit). If "UniversalThemePatcher" or "UxStyle" is already installed - then this step is skipped. This patch allows you to add third-party themes to your system.
2) Unpack the theme "Classic AE mod 2019_7" in the path c:\WINDOWS\Resources\Themes\
3) Go to "Personalization" and switch to "Classic AE mod 2019_7"
4) Restart your PC. Enjoy the classic design Windows 7 with GPU acceleration!

Download (Classic_AE_mod_2019_7_megapack.zip, 20 Mbytes):
https://yadi.sk/d/LRJq25_f1-rGhg
http://ge.tt/4eBdBmy2
https://www25.zippyshare.com/v/ATu9EbYv/file.html
03-15-2019 08:25 AM
ruslbug2d Using "double-buffering patch" increase RADEON driver performance up 10-30 times!

Demonstration on the foobar2000 spectrum with FPS measurement using simpleGLUT.

No patch (WS_EX_COMPOSITED = OFF)
FPS = 25-60 (very big lags)

Used "double-buffering patch" (WS_EX_COMPOSITED = ON)
FPS = 850-920 (no lags)

Video 1 from Camera -


Video 2 -

Source code FIX:

#include <windows.h>
#define WS_EX_COMPOSITED 0x02000000L
static BOOL WINAPI EnumProc (HWND hwnd, LPARAM param)
{
DWORD style;
style = (DWORD)GetWindowLong (hwnd, GWL_EXSTYLE);
// ON
SetWindowLong (hwnd, GWL_EXSTYLE, style | WS_EX_COMPOSITED);
// OFF
//SetWindowLong (hwnd, GWL_EXSTYLE, style & ~WS_EX_COMPOSITED);
return TRUE;
}

void BoostWindows (void)
{
EnumWindows (EnumProc, 0l);
}
int WINAPI WinMain (HINSTANCE hInstance, HINSTANCE hPrevInstance, LPSTR szCmdLine, int nShowCmd)
{
BoostWindows ();
return 0;
}
08-20-2018 09:10 AM
ruslbug2d mattliston

GTA and other games use 3D acceleration.
I'm writing about 2D acceleration problems. Read carefully!



Compare 2D GDI performance - Discrette vs Integrated.

Test #1: Discrette graphic card - Radeon R7 360. Very low performance

Test #2: Integrated CPU Intel i5-6500 - HD 530. Normal performance

Resume: ABSUR!! Integrated CPU i5-6500 HD530 has higher 2D performance than the discrette Radeon R7 360.
08-17-2018 11:55 AM
mattliston
Quote: Originally Posted by ruslbug2d View Post
mattliston

Everyone has this problem.
Set a classic theme Win7 and check it yourself.

I am on classic theme, or at least I think I am.


basic light blue screen background with no orb for a start right?



Aero stuff slows down my AMD FX chip during daily use liek internet browsing or going through my harddrives and organizing. Dunno why, but the fancy theme crap makes it worse.


I do great in intensive games like GTA V with high settings at 1080p, can hit 100fps sometimes. I think the worst its been with the 1080 TI was 50-60 fps because I left some settings far too high
08-17-2018 05:19 AM
ruslbug2d Reduced Windows performance and low FPS from the Radeon driver. On the "Standard VGA Graphics Adapter" - no problems.

Programs for the test:
2D Test with source code - https://github.com/JMKh3r/2DTest/releases/tag/1.3.0.0
SimpleGLUT with source code - http://rgho.st/87wYV9wgB

Radeon driver v15.7.1:
FPS = 4 - 1100 (huge drawdown FPS)
Very large lags when moving windows.

"Standard VGA Graphics Adapter":
FPS = 510-720
There are no lags when you move the window.

Increase 2D performance from nothing. If you place the "Radeon Settings" window underneath the spectrum window, so that at least 1mm of the window is visible outside the spectrum window, then the spectrum is accelerated tens of times and the FPS in simpleGLUT rises from 40-60 to 1100-1300. AMD drivers can not determine the resources, which the program requires, and mistakenly sets the video card to minimum performance.

Short video:
08-16-2018 07:03 AM
ruslbug2d mattliston

Everyone has this problem.
Set a classic theme Win7 and check it yourself.
08-15-2018 08:30 AM
ruslbug2d Переснял это видео более детально. Видно, что производительность в спектре фубара резко возрастает, когда окошко "Radeon Settings" хоть на 1 мм выглядывает. Как только его не видно - так карта впадает в ступор. Вот такие кривые алгоримы у АМД драйверов.
08-10-2018 05:26 PM
mattliston My 370 is collecting dust since I bought a 1080 TI.




I generally owned AMD GPU's, from 5770, 7870, 370, and finally the RX480.


I always did the DDU clean up and install, I wonder if that is what has kept me problem free.




EDIT


I recommend you download the current drivers, perform the DDU driver cleanup, reboot into safemode, and use a program such as ccleaner to clean the registry of any old entries, delete any AMD folders that may still be present, then reboot again, back into safemode, where you install the new drivers.


Upon first boot up with the new drivers, let the system idle at teh desktop for several minutes, then simply perform a normal restart.




Go from there. Please post results.
08-10-2018 06:52 AM
ruslbug2d mattliston

The problem occurs on Windows 7 only with RADEON drivers v15.7 - v18.7.1 (any version).

Let's check with you.What video card and OS do you currently have?

Formula383

I restarted the system many times. This is a 100% bug of AMD drivers.
08-07-2018 06:16 AM
Formula383 this sounds like the software is detecting a clock failure and after such the clock speeds are reduced and the system must be restarted to restore clocks.

edit: what if you leave it in classic and restart the system? does it still perform badly?
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off