Overclock.net - An Overclocking Community - Reply to Topic
Thread: [Official] Heatkiller Club Reply to Thread
Title:
Message:

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-04-2020 11:11 AM
outofmyheadyo This is a brand new heatkiller iv pro full copper after 1 mount on a 2700x, there is a clear indent in the shape of the ihs, is this normal ? Never had something like this with some of the other blocks I`ve had.
07-02-2020 12:36 AM
Watercool-Jakob
Quote: Originally Posted by CantingSoup View Post
My unintentional two-tone 420. I’m still waiting on the fans and power connectors.
Haha, I remember that order This is really unique. I think it looks pretty cool!
07-01-2020 10:23 AM
ciarlatano
Quote: Originally Posted by Madmaxneo View Post
I need a little help in choosing a rad/pump/res combo.

I've only used the configurable AIOs from Swiftech and had a separate loop for my GPU (H140) and my CPU (H240-X). I had my H140 on the back fan mount and the H240-X in the top. Unfortunately this new case (Lian Li Cool 2) only has mounting option for 120 mm fans in the back of the case, so I had to combine my GPU and CPU into one loop with the H240-X, of which it handles just fine. I need more cooling power (AMD build) and was looking at the H360-X3 for the front of the case but the rad mount in the front will not accept the H360-X3 with the res mounted on the rad, plus you can mount a 360 rad in the top of the case.

So I am looking to get a 360 rad (maybe fans also) along with the res and pump. I'd prefer it to be as easy to maintain as possible (which is why I had only gone the Swiftech AIOs prior to this) with something like the pump mounted on top of the res or something similar. I have two of the really good Phanteks fans for the rad so I would need to get another one if I stay with them.
If you don't want to go crazy, why not just add a 240mm or 360mm rad to the existing loop you made with the H240-X? Normally, I would recommend an HWL GTS, but they are very restrictive for a rad and might be a little taxing on the H240-X pump. But an Alphacool ST30 or XSPC EX or TX would do a nice job for you.
07-01-2020 09:37 AM
Madmaxneo I need a little help in choosing a rad/pump/res combo.

I've only used the configurable AIOs from Swiftech and had a separate loop for my GPU (H140) and my CPU (H240-X). I had my H140 on the back fan mount and the H240-X in the top. Unfortunately this new case (Lian Li Cool 2) only has mounting option for 120 mm fans in the back of the case, so I had to combine my GPU and CPU into one loop with the H240-X, of which it handles just fine. I need more cooling power (AMD build) and was looking at the H360-X3 for the front of the case but the rad mount in the front will not accept the H360-X3 with the res mounted on the rad, plus you can mount a 360 rad in the top of the case.

So I am looking to get a 360 rad (maybe fans also) along with the res and pump. I'd prefer it to be as easy to maintain as possible (which is why I had only gone the Swiftech AIOs prior to this) with something like the pump mounted on top of the res or something similar. I have two of the really good Phanteks fans for the rad so I would need to get another one if I stay with them.
07-01-2020 08:33 AM
CantingSoup My unintentional two-tone 420. I’m still waiting on the fans and power connectors.
07-01-2020 08:25 AM
Watercool-Jakob
Quote: Originally Posted by InfoSeeker View Post
@Watercool-Jakob Just received my Mo-Ra3 420 with some optional bits, including the feet. Unfortunately, it looks like a bit used to drill the mounting holes may have been dull, or pushed too fast as the POM material appears to have melted during the process. The residue from the melting has the mounting screw not reaching through the foot, so I cannot get a bite into the radiator mounting hole. I was considering contacting the vendor, but they are out of this item at the moment. Is there a recourse for me?
Please send a mail with a quick description, this picture, and your full shipping address including phone number to [email protected] and we'll send you a new foot.
07-01-2020 07:58 AM
InfoSeeker @Watercool-Jakob Just received my Mo-Ra3 420 with some optional bits, including the feet. Unfortunately, it looks like a bit used to drill the mounting holes may have been dull, or pushed too fast as the POM material appears to have melted during the process. The residue from the melting has the mounting screw not reaching through the foot, so I cannot get a bite into the radiator mounting hole. I was considering contacting the vendor, but they are out of this item at the moment. Is there a recourse for me?
06-29-2020 10:32 AM
Madmaxneo
Quote: Originally Posted by ciarlatano View Post
I've seen a rash of posts stating this recently, where is it coming from? Nowhere does Primochill claim Advanced LRT is plasticizer free. They make statements about "preventing plasticizer from leeching", which is very, very different. So, while Advanced LRT is better than some of the other tubing out there in terms of plasticizer leeching (but far from perfect), it is not plasticizer free.
Interesting. When doing a search for plasticizer free tubing Primoflex is one of the results.

Thanks for pointing that out!
06-29-2020 10:18 AM
ciarlatano
Quote: Originally Posted by Madmaxneo View Post
If that is the case then this is a bit odd because I am using Primoflex Advanced LRT tubing which is supposed to be plasticizer free.
I've seen a rash of posts stating this recently, where is it coming from? Nowhere does Primochill claim Advanced LRT is plasticizer free. They make statements about "preventing plasticizer from leeching", which is very, very different. So, while Advanced LRT is better than some of the other tubing out there in terms of plasticizer leeching (but far from perfect), it is not plasticizer free.
06-29-2020 09:52 AM
Madmaxneo
Quote: Originally Posted by Watercool-Jakob View Post
Of course I cannot make a 100% certain statement, but I agree, it looks like pasticizer washed out of the tubing. Particles, dirt, and corrossive substances usually collect in the areas where there are little to no flow. This is the case in the tiny slit between coldplate and plexi top. Fluid crawls into this tiny gap and can sit there. This is usually not a problem - but when there is contamination with whatever in the loop, this is the place where it becomes visible first.


To solve your problem: I'd suggest opening the block and clean it with soapy water. This should usually clean all of these remains away. After putting the block and the loop back together, we receommend flushing and draining it at least once.
If that is the case then this is a bit odd because I am using Primoflex Advanced LRT tubing which is supposed to be plasticizer free. I also had two loops in my system and the one with the white residue in the block and the tubing (after further investigation) is newer by more than a year than the CPU loop. Plus that particular loop is for my GPU so it stayed pretty cool (no higher than about 42 deg on stress testing or benchmarks). EDIT: The CPU loop is completely clear of any white residue.


I will try to do what you recommend after I get the new tubing. Which will not be easy because of how this loop is installed in this new system.
Now everything is in one loop and it was a pain to get it all in the system as one loop. I dread when the new tubing comes in to change it out. I will probably have to somehow support the case on it's side over something to catch the fluid once I start loosening and pulling off some of the tubing. Drain flush and refill is not really an option with this because of the way it is set up. Maybe I can pull everything off without it issue....lol.

I still need to install some UV lights into this system of which I'm not even sure how that's going to go cause I am still not used to working in a regular ATX case as opposed to an EATX case...lol.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off