Overclock.net - An Overclocking Community - Reply to Topic

Thread: ASUS X299 Motherboard Series - Official Support Thread Reply to Thread
Title:
Message:

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-05-2019 02:22 PM
Pepillo Good news, this latest bios fixes virtualization that was broken in previous bios. Windows Sandbox finally works.
10-05-2019 11:01 AM
ThrashZone
Quote: Originally Posted by tistou77 View Post
For Rampage VI Extreme, bios 2002 indicates



But with Skylake-X, ASUS MultiCore Enhancement is always on AUTO
Hi,
Yep never activates unless xmp is also activated bios will popup with a message asking if one wants to activate.
10-05-2019 10:29 AM
tistou77 For Rampage VI Extreme, bios 2002 indicates

Quote:
ROG RAMPAGE VI EXTREME BIOS 2002
1.Add support for Intel® Core™ X-Series 10000 Processor Family
2.Improve system performance and stability.
3. Change the default setting for ASUS MultiCore Enhancement to disabled.
But with Skylake-X, ASUS MultiCore Enhancement is always on AUTO
10-05-2019 08:04 AM
ThrashZone Hi,
2002 pulled from apex/ prime deluxe never showed for mark 2.
Maybe just asus site update needed no telling.
10-05-2019 08:01 AM
Pepillo Also out for the Prime Deluxe X299. Anybody test it yet?
10-04-2019 07:00 PM
KCDC New 2002 BIOS out


TUF X299 MARK 1 BIOS 2002
1.Add support for Intel® Core™ X-Series 10000 Processor Family
2.Improve system performance and stability.
3. Change the default setting for ASUS MultiCore Enhancement to disabled.
08-20-2019 07:08 PM
ThrashZone
Quote: Originally Posted by JustinThyme View Post
9940X needed what? I lost the convo over the last few posts and running a 9940X of course Im interested.
Hi,
Memory wise needed a bios update 3600C16 wasn't working as it was on prior bios using 7900x 1503 with simply entering default timings... I had to tune quite a bit to get stable at default speed.

Kind of a weird coincidence my psu evga 1200w P2 went bad took out 9940x with it
RMA'ed both and coasting back on 99..x series compatible bios 1704 about the only thing I did before the psu.. went out.
Died at 4.2 all core on startup
Board still good got my old 7900x back and it fired right up with a back up 850 P2 psu I had.

Anyway there it is got a new 9940x and 1200 P2 still haven't oc'ed it yet.
08-20-2019 06:45 PM
JustinThyme
Quote: Originally Posted by ThrashZone View Post
Hi,
Yep 9940x really needed it already flashed seems okay but haven't really set memory like I used to either
Been having more fun with nvidia drivers more than anything
Newest is pretty bad

430.64 seems okay.
9940X needed what? I lost the convo over the last few posts and running a 9940X of course Im interested.
08-20-2019 03:15 AM
tistou77 If I understand correctly, the future Cascade Lake-X will always be on X299 (LGA 2066) ?
And the Xeon on LGA 3647 ?

And a new Rampage VI Extreme Encore motherboard, but I have not seen any difference with the Omega (except aesthetics)

Thanks
07-21-2019 11:34 AM
KCDC Planning to update today, I don't expect much, just hoping the CPU temps stay the same.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off