Overclock.net - An Overclocking Community - Reply to Topic

Thread: [Official] Creative Sound Blaster Z, Zx & ZxR Series Club Reply to Thread
Title:
Message:

Register Now

In order to be able to post messages on the Overclock.net - An Overclocking Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-18-2019 03:20 AM
Vlada011 What can you say about new driver for Windows 10 with SBZxR.
I didn't even knew they launch him.
Maybe they decide to back in life SBZxR.
I only use sound card without daughter board.
10-12-2019 07:47 PM
sngbird Looks like they solved the DDL/DTS issue in this last driver, I have applied the sbx.reg patch and at now no more issues using optical connection with DTS Connect.
10-09-2019 12:03 AM
deskiller
Quote: Originally Posted by sngbird View Post
What's your set in dolby atmos config? I'm testing here with my SBZ, but actually I am thinking that DTS Unbound is better.

I wouldnt know because its not available on my system

for some reason, windows sonic for headphone,dolby atmos and dts unbound are disabled and wont enable at all.
the system is acting like those options are not install an goes to the windows store. but the store says its install and I can run dolby access for headphones but gives error saying it cant change settings.


I currently have windows 10 1909 installed. I am going to clean install 1903, see if it fixes it


edit:
im back, cleaned installed 1903 and now audio is working correctly again.
10-08-2019 11:03 AM
tiagogl
NEW DRIVER FOR SOUND BLASTER Z and ZX 2019

Hello guys,

Here is the link:

https://www.touslesdrivers.com/index...3&v_code=62672
10-02-2019 01:44 PM
sngbird
Quote: Originally Posted by deskiller View Post
hey guys

I have a soundblaster ZxR and dolby atmos for headphone was working with it in august, but then I did a clean install of windows 10 insider and after that spatial audio is greyed out.

on the spatial sound tab it states that spatial sound is not available on this device. which is bull.. because it was workig before I reinstalled the system.

I uninstalled driver and reinstalled drivers. and nothing.
What's your set in dolby atmos config? I'm testing here with my SBZ, but actually I am thinking that DTS Unbound is better.
10-01-2019 09:01 PM
deskiller the window sonic for headphone is supposed to work on the headphone out on the ZxR.

but not giving the option for anything on the ZxR.
09-27-2019 07:25 AM
umeng2002 Set your default device to the toslink out (stereo only), maybe.

MS just released a Win10 patch for some sort of audio issue that occurred in an update from a few weeks back.

I have the spacial option on the normal "speakers" device that the DSP runs on.
09-26-2019 10:14 PM
deskiller hey guys

I have a soundblaster ZxR and dolby atmos for headphone was working with it in august, but then I did a clean install of windows 10 insider and after that spatial audio is greyed out.

on the spatial sound tab it states that spatial sound is not available on this device. which is bull.. because it was workig before I reinstalled the system.

I uninstalled driver and reinstalled drivers. and nothing.
09-24-2019 12:08 PM
umeng2002 Not all the jacks have 192 kHz DACs, probably.
09-23-2019 06:11 PM
EarlZ
Quote: Originally Posted by umeng2002 View Post
Stereo Direct bypasses the DSP and enables 192 kHz output.
Would you know why it would switch to a different jack output after restarting or shutting down the PC ?
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off