Overclock.net - An Overclocking Community

Overclock.net - An Overclocking Community (https://www.overclock.net/forum/)
-   PC Gaming (https://www.overclock.net/forum/78-pc-gaming/)
-   -   Can you turn on Vsync in Crysis? (https://www.overclock.net/forum/78-pc-gaming/1217206-can-you-turn-vsync-crysis.html)

White Fire 02-18-2012 07:51 AM

I've been getting nearly 80-90FPS in that game, but I swear, the micro-stutter is so bad I feel like i'm playing it at 10FPS. I know it fixed it in Batman for me, but can you turn on Vsync in crysis?

The_Rocker 02-18-2012 08:18 AM

Open the console and type r_vsync.

That should do it.

White Fire 02-18-2012 08:52 AM

I typed in r_vsync=1 and it worked. Didn't help as much as I though, but it did help alot. Thanks!

+REP

The_Rocker 02-18-2012 09:04 AM

Quote:
Originally Posted by White Fire View Post

I typed in r_vsync=1 and it worked. Didn't help as much as I though, but it did help alot. Thanks!
+REP

I have another suggestion.

I believe you may not have the patches installed for Crysis because in 1.1 I think they added in a tickbox for Vsync. The patches were also released to aid performance so I think you should go and hunt them down and install them.

One thing Ive also read about with Crysis is that enabling Triple Buffering in your graphics driver control panel can help.

Give it a try?

White Fire 02-18-2012 09:09 AM

Quote:
Originally Posted by The_Rocker View Post

I have another suggestion.
I believe you may not have the patches installed for Crysis because in 1.1 I think they added in a tickbox for Vsync. The patches were also released to aid performance so I think you should go and hunt them down and install them.
One thing Ive also read about with Crysis is that enabling Triple Buffering in your graphics driver control panel can help.
Give it a try?


I had 1.2 installed, but there wasn't a tick box until I typed in your code, now there is.

I also enabled Triple Buffering, but it looks like it's for OpenGL, will it make a difference?

The_Rocker 02-18-2012 09:21 AM

Quote:
Originally Posted by White Fire View Post

I had 1.2 installed, but there wasn't a tick box until I typed in your code, now there is.
I also enabled Triple Buffering, but it looks like it's for OpenGL, will it make a difference?

I have absolutely no idea! Give it a go and see what happens.

EDIT:

Or you can force DX9 to use triple buffering from the console ingame.

To be honest I didn't see much of a difference between DX9 and 10 in Crysis anyway.

Give this page a read:

http://www.tweakguides.com/Crysis_5.html

White Fire 02-18-2012 09:22 AM

Alright, with Vsync enabled, triple buffering enabled in the CCC, it fixed it all. No more micro-stuttering, and it even plays better. +REP again, thanks alot

The_Rocker 02-18-2012 10:04 AM

Quote:
Originally Posted by White Fire View Post

Alright, with Vsync enabled, triple buffering enabled in the CCC, it fixed it all. No more micro-stuttering, and it even plays better. +REP again, thanks alot

Nice to see it worked :-)

White Fire 02-18-2012 10:44 AM

Quote:
Originally Posted by The_Rocker View Post

Nice to see it worked :-)

Works great, in fact, I tried without Vsync and just triple buffering and that fixed it completely, and gameplay is much smoother.. Thanks a million, I was getting very sick of that.

The_Rocker 02-18-2012 10:57 AM

No problem buddy!


All times are GMT -7. The time now is 09:00 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.