Overclock.net - An Overclocking Community

Overclock.net - An Overclocking Community (https://www.overclock.net/forum/)
-   Intel Motherboards (https://www.overclock.net/forum/6-intel-motherboards/)
-   -   How to install ASUS Thunderbolt 3 card on an ASUS X99 MB (https://www.overclock.net/forum/6-intel-motherboards/1638843-how-install-asus-thunderbolt-3-card-asus-x99-mb.html)

JMTH 09-25-2017 11:47 AM

How to install ASUS Thunderbolt 3 card on an ASUS X99 MB
 
6 Attachment(s)
Hello,

UPDATE: 5/2018, Do yourself a favor and don't buy the ASUS ThunderboltEX 3 expansion card. You will save yourself not only the cost, but the hours of troubleshooting! Nonexistent support, driver updates every 2+ years, and RMA after RMA. ASUS should be ashamed of themselves and recall the entire line, but they are not and will not. If you need TB3, and have the header on your motherboard, then get yourself a Gigabyte Gc-alpine Ridge 2.0 and download the latest drivers from ASUS,17.2.71.250. That combination seems to work, it's what I am currently running. I have not needed to contact GB's support so I have no idea how they respond. I will update as the use goes on, but so far so good.

UPDATE: You might be able to skip all the steps below when using the latest ASUS Thunderbolt drivers Version 17.2.71.250. Try following the steps directly below this post before moving on to try the long version below that.

1. Prior to installing the ThunderboltEX 3 adapter into the computer system, install the Version 17.2.71.250 Thunderbolt drivers downloaded from the ASUS support website HERE.
2. Turn off your computer. Note: Remove the power cord from the PSU. Press the power button a few times and/or just wait a bit until all the capacitors have been discharged.
3. Making sure you have your ESD strap on remove the TB3 card from the ESD safe bag and install it in a location where your Motherboard will allow Gen3 and X4 PCIe lanes. Refer to your manual.
4. Install the Thunderbolt_Header cable from your TB3 card 10 pin connector to your motherboards Thunderbolt Header. If your motherboard does not have this connection then the card will not function.
5. Install the HDMI to DP cable that came with the TB3 from your motherboards display port or a spare location on your video card.
6. Button up your computer, plug it in, and turn it on.
7. Go into your BIOS and see if the Advanced\Thunderbolt menu is available, you might have to log into windows first then reboot and get into the BIOS again for it to come up.
8. In the BIOS set the following: Intel Thunderbolt Technology (On), Security Level (Any i think), Wake from TB (Disable unless you have your mouse or keyboard hooked up to it for some reason), TB USB Support (Enabled), TB Boot Support (Disabled), AIC Support (On), AIC Location (NB or SB, depending on what slot you installed it into), AIC Location (The slot you installed it into), GPIO3 Force Pwr (On), Wait time (200), TB PCIe Cache-Line Size (32), SMI/Notify Support (On), SwSMI Support (On may cause q-code bF, still waiting for an answer from ASUS on what that means exactly), Notify Support (On), Ignore TB Option (On), TB SwSMI Delay (humm I wonder if setting this to the default 0 is what is causing the bF q-code, I will need to test it), TB IO resource (On), Mem and PMem per phy slot (32), Reserved IO per phy slot (ASUS said I should set this to 4, but have not given a reason for that yet. So set it at 4 or 20). Save and exit.
9. Boot up windows and if the TB program is not running look in your start menu and start it, your card "should" be up and running.
10. Right click on the TB icon in the system tray and left click About. If your NVM Firmware version is not 18.05 then install the Firmware update located in the same place the driver is on ASUS's website. If everything is working it should look like this! https://www.overclock.net/content/typ...t/700/flags/LL

I cannot take credit for finding out how to get it done, that goes to Andre Flagg and his post on YouTube I will add more details though.

I have no idea if it will work on other manufacturers motherboards using the X99 chipset, it might or it might not.

My New Hardware Motherboard: ASUS Rampage V Edition 10 BIOS: American Megatrends Inc, 1801, 12/10/2017 CPU: i7 6850K System Drive 1: 960 EVO NVME 256 plugged into the M.2 slot. (Windows 7 Pro) System Drive 2: 960 PRO NVME on the ASUS Hyper M.2 x4 Mini in the PCIe_X16/X8_3 Slot. (Windows 10 Pro, Version 1709, OS Build 16299.192) LINK HERE Video Card: Radeon PRO WX 5100 plugged into the PCIe_X16/X8_1 Slot. Thunderbolt: ASUS ThunderboltEX 3 card plugged into the PCIe_X8_2 Slot.

My Old Hardware Motherboard: ASUS X99-Deluxe ii BIOS: American Megatrends Inc, 1701, 3/31/2017 CPU: i7 6850K System Drive 1: 960 EVO NVME 256 plugged into the M.2 slot. (Windows 7 Pro) System Drive 2: 960 PRO NVME on the ASUS Hyper M.2 x4 Mini in the PCIEX16_3 Slot. (Windows 10 Pro, 10.0.15063 Build) LINK HERE Video Card: Radeon PRO WX 5100 plugged into the PCIEX16_1 Slot. Thunderbolt: ASUS ThunderboltEX 3 card plugged into the PCIEX16_5 Slot. Below are the links for the items you need to download.

1. ASUS Thunderbolt 3 drivers. DRIVER LINK
2. ASUS Installation Manual for the Thunderbolt 3 Card, these instructions do not work by themselves (at least not for me). MANUAL LINK
3. Optional: Intel Chipset Drivers for X99-Deluxe ii DRIVER LINK Select your OS, scroll down to Chipset, select latest file. Or if you do not have a X99-Deluxe ii go to your boards driver section and download it.

Andre stated that he looked in the "release notes.txt and under V15339250 and found something about installing each file individually. Its actually under the next release down Version 15.2.32.250. Quote:
  • All drivers must be installed separately to have the complete functionality.
Still rather cryptic, but Andre figured out they were talking about. They are talking about all of the extra files located in the Intel_Thunderbolt_Win7-81-10_V15339250.zip file. The files named like tbt70i.cat, tbt70i.inf, and tbt70i.sys. There are 36 of these files, broken into 6 groups. Here is a list of the instructions, I have formatted them and added any notes that I had.
  1. Windows 10 FULLY UPDATED. Note: Go to settings, Windows Update, Check for Update until it says your device is up to date.
  2. Uninstall all thunderbolt apps, delete folders. Note: Programs Files (x86) \ Intel \ Thunderbolt Software, but check in your Program Files directory as well, just in case.
  3. OPTIONAL: Install Intel Chipset Drivers. I did it at this point, I though I had already installed them when I rebuilt the OS. I did it again anyway just in case. I believe it asks for a reboot after the install.
  4. Reboot to the OS. Wait for it to fully come up. If you did the optional step above you should have already rebooted.
  5. Reboot to the BIOS. Note: Consult your manual for instructions on getting to your BIOS. For me its a nice little program that came with the motherboard software that reboots directly to the BIOS called ASUS Boot Settings. It is the only ASUS software besides AURA that I install on the system.
  6. Turn off thunderbolt in bios. Note: This will be located on the Advanced tab in the BIOS. Look at the bottom of picture 1 below. If you do not see the option "Inter(R) Thunderbolt", don't worry that is as good as turning it off hehe.
  7. Shutdown. Note: Remove the power cord from the PSU. Press the power button a few times and/or just wait a bit until all the capacitors have been discharged.
  8. Uninstall hardware. NOTE: If you never installed the Thunderbolt 3 card just go to the next step. Remove card and cable to motherboard. I have seen some instructions posted where they say to leave the cable attached. I dont recommend that as you may short something out if you place your card on something conductive or it falls over etc... Also I did not use those instructions, so they might work just fine, I just didnt want to chance it.
  9. Default bios. Note: For my motherboard there is a button called CLR_CMOS located to the right of the Q-Code LEDS on the bottom edge. Refer to the manual page 1-13 or if you have another motherboard refer to your manual. NOTE: If you are using any type of RAID make sure to change the Advanced \ PCH Storage Configuration \ SATA Controller 1 Mode Selection back to RAID. If you do not change it and you boot to windows, you will lose your RAID and have to rebuild it, or fix it separately. I will try and find the link on how to fix it. I did this a month or 2 ago when I was working on overclock settings. The fix did work, but I lost about 150MB of space and I couldn't merge the unallocated space back into the RAID. So ultimately I had to rebuild the it. I probably could have using some program like partition magic, but I had to rebuild the OS to get dual boot Win7/10. So I just rebuilt everything. Anyway that's neither here nor there lol... sidetracked myself!
  10. Install each setup file separately i.e., e.g. tbt70i, tbt70x, tbt81x, tp2p70i, tp2p70x, tp2p81x by right clicking and selecting install. Do not reboot !!!! So for this you will need to right click on each of the files mentioned above that have the .inf extension.
  11. Install Thunderbolt software. Note: AsusSetup.exe
  12. Reboot to the OS. Wait for it to fully come up.
  13. Shutdown. Note: Remove the power cord from the PSU. Press the power button a few times and/or just wait a bit until all the capacitors have been discharged.
  14. Install Thunderbolt card and header cable. Note: Per instructions in the ThunderboltEX 3 manual starting on page 6. Step 5 I believe is optional, I dont think Andre did it. I did and it worked so you got me. I will leave it up to you to decide hehe. The location is most likely PCI lane dependent. Both Andre and myself have the 40 lane CPU and both used the PCIEX16_5 slot. I have seen other people post where that option was not available in the Intel(R) Thunderbolt options in the BIOS, I believe they could only use slot 2 or 3? Well anyway, you can first try slot 5 and see how it goes, if it doesn't work move up a slot (Slot 4, then 3, etc...) until it pops up in the BIOS menu and take a look at the pull down menu to see which slots are available for your motherboard. Sorry I cannot be of further help on this part. Maybe someone knows what to do for a 28 lane CPU and will post it below!
  15. Reboot to the OS. Wait for it to fully come up.
  16. Reboot to Bios, turn on thunderbolt and enable all thunderbolt settings. Note: I think it took me about 4 to 5 reboots before the BIOS finally poped up with the Thunderbolt menu. I tried changing many different things in the BIOS, I will try and remember them all and post them below along with my final BIOS settings where the Thunderbolt card is working. Anyway just as I was about to give up again I rebooted once more and Abracadabra it was there... So I would say give it about 10 reboots or a few days of powering off after using it before changing the slot its in. Again sorry, it eventually popped up for me so all I can say is, in the immortal words of Axl Rose "All it takes is patience". I wish that was true, it probably takes a little luck as well.http://files.overclock.net/images/smilies/band.gif
  17. Reboot to OS.
  18. If the Thunderbolt program has not already popped up in the system tray then open it by pressing Start, Thunderbolt(TM) Software, Thunderbolt(TM). Or just type Thunderbolt in the search bar.
  19. Right click on the Thunderbolt icon in the system tray and left click View Available Devices, right click again and look at the details and you should hopefully see whats in Picture 2 Below. If not you can try messing with the same things I listed below and/or changing the slot its in.

Picture 1, showing what and where the menu looks like when it eventually pops up. https://www.overclock.net/content/typ...t/700/flags/LL

Picture 2, Success! Thanks Andre! https://www.overclock.net/content/typ...t/700/flags/LL

Settings I messed with, trying to get the menu to pop up in the approx 5 boots. So this was done at about 1 AM so I am not 100% I have the order correct... Ill put at what boot I put the item like (1, 3, 5) would be first, third, and fifth attempt to boot and have it turn on.

(2, 3, 5) Boot, Fastboot Tried Disabled and Enabled, ended with Enabled.
(2, 3, 4) PCIEX16_(1, 3, 4, 5) Link Speed, Auto, Gen 3, ended with Gen 3.
(2, 4) Boot, Boot \ CSM, Launch CSM, Enabled to Disabled, then back to Enabled.
(3, 5) Boot, Boot \ Secure Boot, OS Type, Windows UEFI mode to Other OS back to Windows UEFI mode.
(4) Boot, Boot \ Secure Boot, Key Management, think I reset the keys.

(1) Advanced, Advanced \ Intel(R) Thunderbolt, AIC Support [On]
(1) Advanced, Advanced \ Intel(R) Thunderbolt, AIC Location Group [CPU0 NB PCIE Slot]
(1) Advanced, Advanced \ Intel(R) Thunderbolt, AIC Location [NB PCIE X16_5]
(1, 5) GPIO3 Force Pwr Disabled, then Enabled. I wasnt sure what it was when I first got the Thunderbolt menu to popup, but I suspect that this is what turns the card on... Dooh http://files.overclock.net/images/smilies/doh.gif I believe after this change it finally started working...

Here are what I believe to be the correct settings for it to turn on. I only list some of these items because they were posted elsewhere in the ASUS X99 Motherboard Series - Official Support Thread (North American users only) LINK and I believe I have some disabled, where others had them enabled. So those ones I will mark with a * as they might not matter at all lol. Also some of the other ones might not make a difference either, sorry it was 1 AM hehe.

*Advanced, Advanced \ System Agent Configuration, NB PCI-E Configuration, PCIEX16_the slot you put it in [Gen3]
*Advanced, Advanced \ Platform Misc Configuration, PCH - PCI Express, PCH DMI ASPM [Disabled]
*Advanced, Advanced \ Platform Misc Configuration, PCH - PCI Express, ASPM Support [Disabled]
*Advanced, Advanced \ Onboard Devices Configuration, PCIEX16_5 Bandwidth [X4 Mode]
Advanced, Advanced \ Intel(R) Thunderbolt, Intel Thunderbolt Technology [On] Advanced, Advanced \ Intel(R) Thunderbolt, Thunderbolt Usb Support [Enabled]
Advanced, Advanced \ Intel(R) Thunderbolt, GPIO3 Force Pwr [Enabled]
Advanced, Advanced \ Intel(R) Thunderbolt, AIC Support [On]
Advanced, Advanced \ Intel(R) Thunderbolt, AIC Location Group [CPU0 NB PCIE Slot]
Advanced, Advanced \ Intel(R) Thunderbolt, AIC Location [NB PCIE X16_5] or wherever you put it.
Advanced, Advanced \ Intel(R) Thunderbolt, Thunderbolt Device IO resource Support [On]
Boot, Fast Boot [Enabled]
*Boot, INT19 Trap Response [Postponed]
*Boot, Above 4G Decoding [Disabled]
Boot, Boot \ CSM (Compatibility Support Module), Launch CSM [Enabled]

Final currently running BIOS settings text file below. After I edit this post! <a class="attachment loginreq" href="/attachments/50030" title="">45CPU_37C_32Mem_092517_setting.txt 35k .txt file

Again a big thanks to Andre Flagg wherever he is! http://files.overclock.net/images/smilies/thumb.gif

I know some of you may have questions, or the above might not work. All I can say is this has been the most frustrating thing so far in dealing with this build. This was my first full custom water loop with full custom sleeved cables (why didn't I just make extensions!!!) hehe. So it has to be pretty bad if its the worst aspect. Everything I know has been posted above. I have no more insight than anyone else after reading this post. If it works Great! If it doesnt I feel your pain and hope someday someone *cough ASUS* releases some actual working instructions for this card. http://files.overclock.net/images/sm...bsupsmiley.png

SpeedyIV 09-25-2017 02:57 PM

Thank you! I may actually give this a try (again). I fought with trying to get my TB-III card working on my X99 Deluxe II for HOURS and HOURS and got it working, sort of, after uncounted hours of frustration. Asus offers next to nothing for instructions about how to do this and I have never found anyone who has posted having an easy time of it. There is no explanation of the BIOS settings having to do with TB configuration. Most people I have seen try to do it eventually give up. I have an 28-lane CPU and at the time I tried to get TB working, was running 2 R9-290X GPUs in crossfire. That did not work out at all. Now, I am running on just 1 GPU so I may give your method a try.

Thanks again!

Testing12 09-26-2017 07:50 AM

Although I am not interested in running Thunderbolt on my X99 Deluxe II, I really appreciate the time and energy you expended to provide a solution for those who have had so much difficulty with doing so. Hopefully, others will give it a try and report back here on their findings.

Lady Fitzgerald 09-26-2017 09:01 AM

subbed

Dev24670 10-07-2017 08:09 PM

Thanks for your honesty and appreciation of my hard work and effort. I was very happy to share this information. I have always visited OverClock.net but never joined until now. Its a true honor to be recognized an to be considered amongst all of you. Over the years I read several post that have helped me in many situations. Thanks for all the help over the years!!! Signed Andre Flagg

JMTH 10-07-2017 10:00 PM

Hey great to hear from you! And thank you again your information. I was banging my head against the wall for weeks trying to get it to work. Stumbled upon your instructions and bam WORKED! Glad you joined the forum and look forward to seeing your posts.

Dev24670 10-11-2017 12:11 PM

You are most welcomed, and thank you for the warmest of welcomes!!!

JMTH 01-02-2018 05:50 PM

Hello again all, its been a while since I posted here. I thought I would update everyone!

New drivers and a firmware update have been posted on ASUS's site. LINK

It also looks like they posted a Hotfix on 12/27/2017.

I was having a lot of problems with my Deluxe II board (bF and 01 q-codes from Thunderbolt Card, VCCSA voltage wouldnt show up in the BIOS or software) so I ended up having to RMA it. While it is in the repair shop I purchased a Rampage V Edition 10. Which also has the TB Header. I was also doing a couple of upgrades and just finished getting everything back together a few weeks ago.

When I started working on my Overclock on the new board I started getting strange errors and problems with the TBEX3 card that came with the Deluxe II. I finally had to remove it and purchase a new one as the motherboard would not even detect it no matter what slot I installed it into. I was going to try and update the firmware but never got the chance. It had something to do with the latest update from Microsoft to Windows 10, but since it was not even detected in the BIOS there was something else wrong with it. I am sending it in soon for an RMA. I am going to sell the Deluxe II anyway so I might as well get the TBEX3 card fixed.

Anyway, I installed the new drivers the same way as stated in the first post and everything seems to be working fine. I am still getting the bF or 6F q-code on the motherboard. I did some google-fu last year and it seems that a q-code of 01 means everything is running ok. No luck on 6F or bF yet. I did notice that if I turn the Thunderbolt setting SMI/Notify Support or SwSMI Support off in the BIOS then the q-code returns to AA.

The new TBEX3 card also had the latest firmware installed so I didnt even have to run that.

I have sent a request for information on the issue to ASUS, but it will most likely never be answered. If I hear anything back from them I will post it here!

JMTH 01-02-2018 07:46 PM

I forgot to mention that for Windows 7 it seems like you cannot install each driver separately. So using the asus installation program seemed to work fine in win 7.

watuso 01-19-2018 02:26 PM

Thank you very much for taking the time to do this.
So have you been able to use with no issues the thunderboltex 3 card with your Asus Rampage V edition MB? I have this board and just purchased the thunderboltEX 3 card, together with a g-shuttle speed raid system which I was hoping to connect to the card. But as soon as I did my purchase, I found out about all these issues everybody is having with this thunderbolt card. I am serioulsy thinking about cancelling my whole order, as there seems to be no other options currently in the market apart from the Asus thunderbolt card.

Regarding the hotfix on the asus support page, do we have to install that together with the new drivers. I'm confused.

Again, thanks for your time and effort in putting all this together


All times are GMT -7. The time now is 03:36 PM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.