Overclock.net - An Overclocking Community

Overclock.net - An Overclocking Community (https://www.overclock.net/forum/)
-   Overclock.net BOINC Team (https://www.overclock.net/forum/365-overclock-net-boinc-team/)
-   -   Power hit, Raspberrry Pi corrupt, new CPID for SETI (https://www.overclock.net/forum/365-overclock-net-boinc-team/1641476-power-hit-raspberrry-pi-corrupt-new-cpid-seti.html)

bfromcolo 11-06-2017 05:35 AM

We had a power hit.  My RPi 3 had been running since June 17.  When it booted up it went into some kind of time warp and was running tasks from June 17, not the tasks or the projects, it was running at the time the power went off.  I aborted the running tasks which were well past their due dates.  3 SETI tasks had due dates of 8/8, when Boinc reported the aborted tasks I got this:

 

11/6/2017 6:11:19 AM | [email protected] | Generated new computer cross-project ID: 80a178114d820bec7f2ac2a3263fd74c

 

So now my CPID is hosed.

 

The RPi seems fine, but I guess I need to log off and on periodically to avoid this time warp.

 

Edit -

 

Looks like the memory card is corrupted, I did a update and rebooted and it went right back to June 17.  Even the tasks I had previously aborted came back.

 

My CPID looks OK on the SETI web site, I removed the RPI from the list of computers, hopefully once I get everything reinstalled it will be OK.


mmonnin 11-06-2017 01:23 PM

Is it loading a backup from disk? Like Windows will ask for Last Known Configs.

bfromcolo 11-06-2017 01:57 PM

I don't know what it's doing,  I have tried multiple tools (SDFormatter, EaseUS, Disk Manager, disks, gparted, fdisk) to erase/format/overwrite this card with no success.  It's odd cause I can boot off of it, run updates, etc, but when I reboot its back to where it was.  I contacted Samsung and they are issuing an RMA for the card.  As cheap as these are I don't know why they want the old one back, I guess just proof that I had it, but they are sending me a pre-paid label.

 

I have Raspbian installed and updated on another card, on to setting up BOINC.


bfromcolo 11-06-2017 03:02 PM

Well BOINC is up and running SETI, WUProp and GoofyxGrid.  But [email protected] is instant crashing with this error.  I must have fixed this in the past, I should write this stuff down when I solve some mystery.

 

 

Stderr output

<core_client_version>7.6.33</core_client_version>
<![CDATA[
<message>
process exited with code 127 (0x7f, -129)
</message>
<stderr_txt>
../../projects/albert.phys.uwm.edu/einsteinbinary_BRP4_1.42_arm-unknown-linux-gnueabihf__NEON: relocation error:
../../projects/albert.phys.uwm.edu/einsteinbinary_BRP4_1.42_arm-unknown-linux-gnueabihf__NEON: symbol h_errno, 
version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference

</stderr_txt>
]]>

mmonnin 11-06-2017 03:19 PM

I ran Albert on my Pi2. I don't recall seeing that specific libc error about a link time reference. Might just need an updated version?

bfromcolo 11-17-2017 06:34 AM

I went back to Raspian Jessie and Albert is fine now, that error happens with Stretch.  Looks like a code change is required that has been corrected in Einstein but not Albert.



All times are GMT -7. The time now is 04:36 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.