Overclock.net - An Overclocking Community

Overclock.net - An Overclocking Community (https://www.overclock.net/forum/)
-   Intel Motherboards (https://www.overclock.net/forum/6-intel-motherboards/)
-   -   Realtek HD Audio Manager - Universal Jack (Retasking) - IP35 Pro XE (https://www.overclock.net/forum/6-intel-motherboards/378475-realtek-hd-audio-manager-universal-jack-retasking-ip35-pro-xe.html)

Xechorizo 08-27-2008 07:09 PM

My specs are included in my sig. My Realtek HD Audio Manager no longer asks me which device I have connected to any of the six jacks on the back of the board. This feature has worked before but suddenly stopped sometime after 08/10/08, and is referred to as jack retasking, universal audio jack, or simply the ability to choose the currently connected device.

All jacks plugged in appear in the Manager as their default assignment (Mic on pink rear, line-in on blue rear, front left/right on green rear, etc.)

I have uninstalled the drivers, used CCleaner, rebooted, reinstalled the drivers, rebooted, and used CCleaner again for EACH of the following HD Audio drivers for Vista:


I have tried toggling to AC 97 in the BIOS, but this simply removes some functionality of the HD Audio driver. I have tried checking AND unchecking the "Enable auto popop dialog, when device has been plugged in", and although this has no effect on the program's behavior at all, I can watch the option toggling in the following registry key: HKEY_CURRENT_USER\\Software\\Realtek\\RtHDVCpl\\Ge neral

I have done these steps while completely disabling my security software, Bit Defender Total Security 2008. I have the latest Windows and BIOS updates. I have run virus/spyware scans and also sfc /scannow. I have defragmented and closed every other process I can and attempted to regain this functionality.

I also wonder if it may be some sort of Windows setting that is forcing the Manager to assign the ports to their default devices without prompting me. On this Vista machine, I'm using the hidden Administrator account as my main account, so I doubt it's permissions. I've also tried disabling DEP.

I've managed to backup and reinstall my Vista Ultimate from other causes (new hardware from XP - much cleaner install). This issue STILL exists, nullifying any idea with the install or the software. I'm convinced it's this motherboard or the hardware attached. I've launched it up using the "fail safe" BIOS profile so I'm positive it's not the settings or overclock. I've tried disabling the floppy controller and also unplugged everything except my booting SATA disk, video card, and a stick of 6400 - this issue still happens.

I'm pretty much at my wit's end. If anyone has any ideas PLEASE let me know. I'll respond with anything you may need. Not looking forward to an RMA. Thank you!

Xechorizo 08-27-2008 09:42 PM

It's a shame because every place on the web I find that mentions this always ALWAYS leads to a dead end. Not one person has rectified it and just are using workarounds. If anyone has any clues for resolution or even where to go for more specific Realtek support, please - throw me a bone.

Xechorizo 08-28-2008 07:29 PM

went in, removed all sticks but a 6400, cleared CMOS with the jumper, no battery, a good 10 mins, popped it back in, loaded optimized BIOS, set my voltage to 1.9 as listed for the Corsair model I had in there, and booted up, reinstalled the 2.02 driver for ALC888, rebooted, still nothing.

Does this feature I remember even work for anyone? Does the "Enable popup" checkmark successfully toggle the feature for anyone? Maybe I'm just missing something glaringly obvious. I think I'll pop in my RAM and run an intensive MEMTEST while I'm at work.

S.M. 08-28-2008 07:35 PM

Call realtek. I can't get a microphone to work at all. I'm fixing to give them a call soon.

So far all I have to say is realtek is a pile of crap and I wish I had options.

Xechorizo 09-21-2008 08:06 PM

Been there done that. Their line specifically states in psuedo-English that they don't support their stuff. Classy.

I've also replaced my RAM to some dual Corsair Dominator at 1066 MHz and the problem persists. I think it may be related to my case or AC'97/HD Audio something-or-the-other. In either case, lemme post something useful by my thread on the abit forums. Keep in mind I haven't tried this yet, but searching for Pin07 does pull up similar entries:


Registered User
Forum Newbie

Join Date: Jun 2006
Posts: 3
Re: Realtek HD Audio Manager - Universal Jack (Retasking) - IP35 Pro XE
Not easy to post here nowadays, luckily I found and remembered the password to my old account

Anyways, I'm fairly sure your board is fine, I'm having the same issue on my IP35-Pro (although non-XE), where I get a notification that something has been plugged in, but never a popup asking me what. (Running vista x64 sp1)

I have, however, found out where the mappings are saved in the registry and as such been able to sort of work around the issue.

1. For me, the mappings are saved in: "HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\Co ntr ol\\Class\\{4D36E96C-E325-11CE-BFC1-08002BE10318}\\0000\\Settings\\DevType_0888_SS147b 108 3"

2. binary keys that I have identified are:
"Pin01" = rear black-coded "RR RL" jack
"Pin07" = front green-coded "headphone" jack

3. hex values identified:
"00 00 00 00" = Line-in
"01 00 00 00" = Mic-in
"02 00 00 00" = headphones
"04 00 00 00" = Front speakers
"05 00 00 00" = Rear speakers
"06 00 00 00" = Center/subwoofer
"07 00 00 00" = Side speakers

For me, retasking/mapping the rear audiojack (RR RL) to front speakers was enough and all I wanted to do.

After changing the registry I had to reboot for the settings to take effect, there's probably a more elegant way to do it via some dll, but that'll take more time than I'm willing to spend

Anyways, hope it's of some help.


Tnitro21 07-11-2011 09:04 AM

Managed to figure out the rest of the "pin" assignments smile.gif

"Pin00" = green
"Pin01" = rear black-coded "RR RL" jack
"Pin02" = orange
"Pin03" = grey
"Pin04" = rear pink mic
"Pin05" = front mic
"Pin06" = line in
"Pin07" = front green-coded "headphone" jack

Hope this helps biggrin.gif

jbaird 09-16-2011 06:46 AM

Sorry for posting on an old thread.. but. I have a brand new P8P67 who's back green audio jack is not working. It will only output out of one channel. I can sometimes get two channels by wiggling the jack a little bit. The front audio jack works fine. So, I'm also trying to re-task other back jacks that I don't use to the front-speakers.

I do not have the registry key that you are referring to in this email. I am running of the RealTek drivers (newest from Asus' website). Instead, I have found some "Pin0x" keys in:


I changed all of the Pin01-Pin0X values to 04 as indicated in this thread, but I still can't get front speaker output from any of the jacks.

Does anyone have a suggestion?


Eliah_ 09-24-2011 02:42 PM

I just spend a good hour or so struggling with the same issue. At least for me the instructions above don't work, maybe because something has been changed in an update or something.

Anyway, it appears the pin numbers have changed and the mappings won't appear in the registry unless they differ from the default.

hex values have remained the same:

"00 00 00 00" = Line-in
"01 00 00 00" = Mic-in
"02 00 00 00" = headphones
"04 00 00 00" = Front speakers
"05 00 00 00" = Rear speakers
"06 00 00 00" = Center/sub-woofer
"07 00 00 00" = Side speakers

However the new pin numbers now (mostly)correspond with the hex values!

"Pin10" = Line-in (blue)?
"Pin11" = Mic-in (pink rear pink)?
"Pin14" = Front speakers (green rear)
"Pin15" = Rear speakers (black rear)
"Pin16" = Center/Sub-woofer (Orange rear)?
"Pin17" = Side speakers (rear gray)?
"Pin19" = Front Mic-In (front pink)
"Pin1b" = Front Headphone (front green)

These are the defaults, i am not completely sure about all of these though.

I only wanted to re-task the rear black connector to front speakers, since the front panel on my case is broken and i also have to plug the headphones to the back of the case.

So for example, to re-task "rear speaker" pin as a front speaker you have to add to:

"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\C ontr ol\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings\DevType_0888_SS147b108 3"

This binary value:

Pin15 "04 00 00 00"

or front headphone as side speakers:

Pin1b "07 00 00 00"

Then reboot!

You will have to add these by hand, the mappings don't show up by default, but if they do and correspond to the instruction above follow them.

Hope this helps, and sorry for my potentially bad english.

ingar195 02-16-2012 12:31 PM

i tryed that but it just resets afther reboot

please help

thx in advance

Sonorous 03-14-2012 05:46 PM

I'm also not having any success changing any values in regedit.

I'm currently using an ASUS G53SX with Windows 7 and the version of the Realtek driver I'm using is V6.0.1.6334

As Eliah stated, no Pins show up in my regedit due to what I assume is some recent update to the driver. This is how mine looks:


I've tried adding a variety of pins using the data "02 00 00 00" and "04 00 00 00" and none of them work.

The last time I recall having access to jack retasking was both on a desktop and laptop that initially came with Windows Vista/7 on them but I had reformatted and installed Windows XP on both of them.

It seems that the GUI of the Realtek settings is vastly different on XP than it is from its Vista/7 counterpart - even if the same version of the driver is installed on either operating system.

I have never been able to gain access to jack retasking in the Vista/7 GUI - this one (this is a screenshot of the GUI from my own computer):


But I've always been able to do it in the XP GUI - this one (just a picture from Google but it's the same way it has always looked to me on XP):


Is there any way as far as anyone knows to force an install of the XP version/GUI?

Or perhaps something else can be done in besides changing/adding Pins and binary data in regedit to get retasking to work.

I'm also curious if my case is more complex because of my laptop. You'll notice in the image I posted of my Realtek GUI that my 2 jacks are both black instead of coloured like everyone elses seem to be. I'd just like to state that the laptop itself does in fact have 2 real physical jacks, both are actually coloured/painted black, but 1 has a headphone icon engraved over it, and the other has a mic icon engraved over it.

All times are GMT -7. The time now is 09:42 PM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.