Overclock.net banner

1 - 7 of 7 Posts

·
Overclocker
Joined
·
2,726 Posts
Discussion Starter #1
So I just received a 5820k & a MSI X99S Mpower mobo and I cannot seem to get the system to completely turn off EIST which lowers the multiplier to save energy or w/e. The cpu multiplier is constantly going between 12 & 45 (OC setting).

In the bios EIST is turned OFF, C states are all turned OFF, CPU ratio is set to FIXED. In windows 7 power options, CPU minimum power is set to 100%.

The only way I have found to stop the downclocking while idle is to open up RealTemp and uncheck EIST & C - States boxes and this seems to disable EIST & C states and my cpu sits at a constant 45x multiplier. However I should not have to do this every time I boot into windows, it should be disabled from my bios settings/windows power options. I don't understand why/how windows 7 could be enabling EIST with it disabled in bios.

Never had this issue turning off power saving features with my 2500k....any help would be appreciated completely disabling EIST/C states/idle downclocking.
 

·
Registered
Joined
·
978 Posts
Some Asus motherboards have an EIST (SpeedStep) option in the bios that does not actually do anything. Whether this is enabled or disabled in the bios does not matter. EIST is always enabled when you boot up.

If you want to test for this you can download RW Everything.

http://rweverything.com/

Click on the MSR icon at the top, next click on the User icon and enter 0x1A0 in the box at the top, click on Add and then click on Done. This will let you monitor the register that EIST is located in.

A typical value is 0000000000850089

Bit[16] is the EIST bit which is enabled in the above example. That means EIST was left enabled when the bios handed off to Windows. If EIST was not enabled then it was probably C1E that was left enabled by the bios. MSR 0x1FC - bit[1] is the bit that shows the C1E status. Check these after booting up, before running any monitoring software.

If there is a problem there is not much you can do. You can complain to MSI but it will likely be a while before they fix this.
 

·
Overclocker
Joined
·
2,726 Posts
Discussion Starter #4
@unclewebb

Thanks for the info. It sucks that they wouldn't test these things out before shipping it, and most likely they aren't going to fix it as its a board from 2014 or something like that.

@HelpDatBIOS

Thank you for the bios fix!
 

·
Registered
Joined
·
1,982 Posts
I don't know MSI BIOS but on ASUS ROG Motherboard I didn't touch to many functions, EIST is Enabled, CPU C-State - Auto, Turbo - Enabled.

When I use Windows Power Plan High Performance than CPU Core Frequency and CPU Cache Frequency I set and Max Adaptive voltage I set.
When I use Windows Power Plan Balanced than CPU work on idle mode, Cache Frequency drop on Auto (default frequency) and CPU voltage drop on default as well.
If I start to use some CPU demanding applications even on Balanced Power Mode Frequency will incrase depend how much system need.
 

·
Registered
Joined
·
611 Posts
Hidden power plan advanced settings menu. You must find the registry key that’s associated with the hidden cpu power setting that says “processor energy preference” or something like that. Once you un hide it, you’ll see it on the windows UI power plan advanced settings page side of it and then you just change it from 33% (default value for balanced power plan) and change it to 0%. This will guarantee your cpu never downclocks from max multiplier, regardless of any other windows or bios setting.
 
1 - 7 of 7 Posts
Top