Overclock.net banner

1 - 16 of 16 Posts

·
Premium Member
Joined
·
14,038 Posts
Discussion Starter #1
Single Player, BF3, sig-rig, screenshot is from AB during opening sequence of the first Tank level (you're apparently some dude named Miller). Game is maxed at 1920x1200 at 4xMSAA but no FXAA.

Notice how my GPU usage is never capped, yet my FPS keeps constantly dropping into the 50's. It's not just this level either, happened in the previous levels as well.

My CPU usage is between 25-35% (I have HT on so this would probably be 50-70% in a 4-core/thread config) and there is no correlation between the occasional high CPU usage spikes and the constant FPS dips on the AB graph.

This same thing happens whether the card is OC'd or not. As you can see the core clock is staying at max clocks so it's not a downclocking issue.

Obviously I have v-sync turned on (regular v-sync + triple buffering, OR adaptive v-sync ... same outcome). Doing v-sync through nVCP, it's turned off in the game settings (cause it doesn't work ... just like it seems to almost never work ... but that's for another thread).

I'm really just playing this game for the first time, dunno much about trouble-shooting it nor how it ran on my old cards.

Does this only happen to me? Mostly it's not too noticeable but sometimes it'll go into the 40's which I definitely feel as a small stutter.

700
 

·
Registered
Joined
·
1,536 Posts
Well, I can tell you %99 of my problems with BF3 is from programs running in the background, like afterburner, or some other monitoring software.
 

·
Premium Member
Joined
·
14,038 Posts
Discussion Starter #5
Quote:
Originally Posted by Bosniac View Post

I have the same issue. My brother has the ssme issue also. We both have the GIGA 670 OC 3X. Stutter, and framerate dip. I should've just kept my 680, none of the issues there.
Well, I say it's a bit early to start freaking out
smile.gif


It is a brand new card, brand new driver ... may take a little while to iron out the kinks.

Crysis 2 does something somewhat similar, although it seems specific to certain areas in the game. Notice how in the middle of the graph below, my FPS is not up at 60, it's in the 50's. BUt the GPU never hits 99% during that time.

I suspect one of two causes in this case:
a) The CPU usage graph has a look going on like "I can really only use two cores (out of your eight virtual cores) and I'm actually tapping out during this section", or
b) Something is occupying GPU resources that doesn't get counted in the GPU usage graph ... considering the graph below comes from a section where there's a bunch of water (FDR Freeway section), I suspect perhaps H2O tessellation may happen w/o getting 'counted' in the usage graph... much like happens with PhysX, and the GPU H2O simulation in Just Cause 2.

400

I'm actually really happy w/how C2 runs though overall ... way more consistently better than my 470SLI did. Maybe has something to do with the 1700MB vram usage I'm seeing
wink.gif


However, I do still get a lot of tearing even with v-sync on ... that aspect of this card is starting to bug me ...
 

·
Premium Member
Joined
·
14,038 Posts
Discussion Starter #7
Quote:
Originally Posted by NeoandGeo View Post

Have you checked your CPU usage on a per core/thread basis?
No, because the individual core/thread usage measurement's in task manager don't really tell you anything useful. What they really say is 'this is what Windows would LIKE to do with this workload' ... but it doesn't necessarily reflect the actual, bare-metal usage. So I generally don't bother looking at it.

I may look for another tool though, see if there's anything else out there that's actually somewhat accurate in this regard.
 

·
Premium Member
Joined
·
14,038 Posts
Discussion Starter #8
Additional development ... this problem doesn't seem to occur right when I start up the game. It seems to take time to develop. I'm going to try raising fans a bit, and lowering the OC, just to see if that removes the problem.
 

·
Registered
Joined
·
374 Posts
My GTX670 has done this with just about every game. V-Sync or Adaptive V-Sync enabled and hits 50 fps and GPU never break 65%. The fix I found was to disable any kind of V-Sync and load up the game and getting it to run 60+ fps. I'd then shut it down(the game), reapply all the settings and everything would work fine afterwards. However, I didn't play Skyrim for a week and the problem came back. Sooo I did the same thing and it worked again haha. Seems to be driver issues? It's a odd problem..
 

·
Registered
Joined
·
557 Posts
Quote:
Originally Posted by brettjv View Post

Additional development ... this problem doesn't seem to occur right when I start up the game. It seems to take time to develop. I'm going to try raising fans a bit, and lowering the OC, just to see if that removes the problem.
I tried disabling all monitoring apps like MSi/Evga, etc. all of them. Just run it without any OC apps and such, and turn on the BF3 ingame fps osd and it might help. It completely did with me.

The BF3 command for fps is :

Press tilde, then type: render.drawfps 1
 

·
Premium Member
Joined
·
14,038 Posts
Discussion Starter #11
Does anyone else get really obvious tearing in Crysis 2 even when v-sync is turned on?
 

·
Registered
Joined
·
28 Posts
The only v-sync you should have on is the Adaptive V-sync in the Nvidia control panel. Be sure your games don't have any v-sync enabled. BF3 was a bit stuttery for me until I realized that I had in-game v-sync enabled as well. Smooth as butter with the in-game turned off. I'm running two Giga 670's in SLI.
 

·
Premium Member
Joined
·
14,038 Posts
Discussion Starter #13
Quote:
Originally Posted by MNDan View Post

The only v-sync you should have on is the Adaptive V-sync in the Nvidia control panel. Be sure your games don't have any v-sync enabled. BF3 was a bit stuttery for me until I realized that I had in-game v-sync enabled as well. Smooth as butter with the in-game turned off. I'm running two Giga 670's in SLI.
Do you think you're dealing w/an amateur here?

I know to only have v-sync on in one place
thumb.gif


This being said, in-game v-sync is totally broken on pretty much every game now with this new card. It does NOTHING. I've had to go and turn it on in the game profiles in NVCP for all my games I've played so far, which is like 10 different one (I think C2 may be the only exception) and turn it off in-game cause it simply no longer works.

You'd think I had an AMD card or something
tongue.gif
 

·
Premium Member
Joined
·
5,295 Posts

·
Registered
Joined
·
638 Posts

·
Registered
Joined
·
1 Posts
I have the solution to your problem. Disable windows page filing. I am almost sure this will fix the problem. Give it a shot and let me know if this works. I did this yesterday and it really made a difference in smoothness.
 
1 - 16 of 16 Posts
Top