Overclock.net banner

1 - 16 of 16 Posts

·
Premium Member
Joined
·
4,280 Posts
Discussion Starter #1
Hi all,

I'm trying to get audio to output from my ASUS ATI Radeon 7850 via HDMI to my TV, and I've checked through Catalyst and Windows sound manager, and I can't seem to find an option to output the sound to the TV. In Catalyst, it says that this viideo device doesn't support audio output, which is wrong, it works perfectly with a different computer of mine which a different graphics card.

Anybody else have the similar problem and know how to fix this? I'd really appreciate some help on this issue.
smile.gif
 

·
Premium Member
Joined
·
4,280 Posts
Discussion Starter #3
Quote:
Originally Posted by BeardedJesus View Post

Right click on the sound icon on the taskbar, playback devices and then set AMD HDMI Output as the default device.
Everything in the playback devices menu is disabled except for the Optical input. :/ I tried that already and it didn't work.
frown.gif
 

·
Premium Member
Joined
·
4,280 Posts
Discussion Starter #5
Quote:
Originally Posted by BeardedJesus View Post

Check Device Manager, Sound, video and game controllers and check if AMD High Definition Audio Device is there. It may be a driver problem
I can see that there, and WIndows says that the device is working correctly. Any idea of what I should do next?
 

·
Premium Member
Joined
·
4,280 Posts
Discussion Starter #7
Quote:
Originally Posted by BeardedJesus View Post

Hmmmm thats weird. Does video etc. display correctly on the tv?
The display on the TV works fine, but with no audio output.
 

·
Premium Member
Joined
·
4,280 Posts
Discussion Starter #9
Quote:
Originally Posted by BeardedJesus View Post

In the playback menu if it shows AMD HDMI Output can't you just right click and enable it and if it isn't there right click on the edge and tick "show disabled devices"
It won't let me enable it even when I show disabled devices. Maybe it's just this new line of 7xxx cards and AMD has to fix these drivers. That''s pretty crappy that it doesn't work.
 

·
Registered
Joined
·
693 Posts
Yeah sorry that didn't work I can't really think of anything else other than to wait for new drivers but theres a good chance someone alot smarter than me will see this thread and help you out. Just by chance check and see if your tv has a 3.5mm input next to the PC display input and if it does try a male - male 3.5mm audio cable from your headphone jack on your computer as a temporary fix
smile.gif
Sorry I couldn't be of more help.
 

·
Premium Member
Joined
·
4,280 Posts
Discussion Starter #11
Quote:
Originally Posted by BeardedJesus View Post

Yeah sorry that didn't work I can't really think of anything else other than to wait for new drivers but theres a good chance someone alot smarter than me will see this thread and help you out. Just by chance check and see if your tv has a 3.5mm input next to the PC display input and if it does try a male - male 3.5mm audio cable from your headphone jack on your computer as a temporary fix
smile.gif
Sorry I couldn't be of more help.
I'll try that later today. Hopefully it'll work.
 

·
Registered
Joined
·
1,961 Posts
hey try puling the 7950 this is the cripto rig we are troble shooting right??
 

·
Premium Member
Joined
·
4,280 Posts
Discussion Starter #16
Quote:
Originally Posted by sedure View Post

Hi!
Did you get your HDMI sound to work?
I have the exact same problem with the same card.
I don't think I ever got it working unfortunately. Maybe with a newer driver release it would have worked, but I can't try it anymore with my current setup.
 
1 - 16 of 16 Posts
Top