Overclock.net banner

1 - 20 of 21 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Trying to tune a brand new 9700K on a Maximus XI board. Done all the basics, manual, sync all, 1.3v, etc. Basically I've followed all the usual guides out there to get to 5.0. It accepts '50' in the multiplier field and saves, shows it on reboot to the BIOS. In windows however it's always 45. It's always 45 unless I put something less than 45 in there... It'll run at 40 for instance. 49 shows 45... CPU-Z shows (8-49) in the multiplier field regardless of what's set. So I've never had a chance to have a failed overclock or crash, it works fine at 45 it just won't apply anything higher.

Tried different BIOSs for the board. Same thing. Tried XMP I & II and manual.

Is it possible the newest 9700ks are capped at 45? Anyone ever seen this?
 

·
9 Cans of Ravioli
Joined
·
20,820 Posts
Is it possible the newest 9700ks are capped at 45?

you think Intel would sell an unlocked CPU and then quietly limit that CPU to 45x without mentioning it and you'd be the first one to notice? lol.

assuming you haven't edited Windows Power Plan rules either your motherboard is faulty (unlikely) or you goofed somewhere.
 

Attachments

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Another observation... Returned everything to default, pulled the coin battery and reset CMOS... Changed nothing from default after restart and being prompted to enter setup. In windows the CPU is locked at x45. All cores, all the time. This is a 3.6 gHz CPU by default right? Why is it persistently in this weird mid range turbo mode on all cores with default settings? I just grabbed this thing yesterday from bestbuy, I'm tempted to go swap it out. Can't say I've ever seen anything like this.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
you think Intel would sell an unlocked CPU and then quietly limit that CPU to 45x without mentioning it and you'd be the first one to notice? lol.

assuming you haven't edited Windows Power Plan rules either your motherboard is faulty (unlikely) or you goofed somewhere.
Yeah no changes to windows power plan. I agree the board being bad seems unlikely and it exhibits no other odd behavior. Which is more likely, bad board or bad chip? I've retraced my steps and started over a bunch of times at this point as far as implementing the overclock goes. No matter what I do this thing wants to live at x45.
 

·
Registered
Joined
·
271 Posts
How long does it take to post? Perhaps loading fail safe values?

Ignore misread loo

Id prob try a different bios firmware if ur still troubleshooting...
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
Id prob try a different bios firmware if ur still troubleshooting...
Yeah tried 2 now.

Seems like you didn't disable turbo.
This issue persists regardless of BIOS settings. All default or otherwise. At this point I just want to see the chip run the default configuration correctly, which it doesn't. It should boost a single core to 4.9, boost all 8 to 4.6, and have a default multiplier of 36. As it stands it persistently runs all 8 cores at 4.5 regardless of what BIOS settings are loaded. I just tried one of the canned OC profiles in the Maximus XI (5.0 OC for 9 series) and it does exactly the same thing, everything is locked at 4.5

BIOS has been flashed with two different iterations, battery has been pulled... I'm leaning toward bad CPU.
 

·
Registered
Joined
·
983 Posts
I'm leaning toward bad CPU.
That is not very likely. It is possible that the bios is not setting your CPU up correctly. Run CPU-Z, click on the About tab and then click on the Save Report (.TXT) button. Attach that file to your next post or copy and paste the data to www.pastebin.com and I will have a look for you.

The 9700K uses Intel Turbo Boost to reach any multiplier higher than 36. If you are hitting the 45 multiplier, turbo boost is working so you need to check to make sure the maximum turbo ratio limits are being set correctly. Did you adjust the individual turbo ratios in the bios? Some motherboards do this automatically while other motherboards might force you to do this.

Open the report that CPU-Z created and have a look for this line:

Code:
MSR 0x000001AD
That register contains the turbo ratio limits that were set by the bios. Scroll the CPU-Z file and make sure that register is being set consistently for all 8 CPU cores. Post the contents of that register and I will decode it for you.

You can also try using Intel XTU or ThrottleStop. Both programs should show you what your default turbo multipliers are set to.

Can you also post a screenshot of CPU-Z?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #9
That register contains the turbo ratio limits that were set by the bios. Scroll the CPU-Z file and make sure that register is being set consistently for all 8 CPU cores. Post the contents of that register and I will decode it for you.
Thanks for your help.

MSR 0x000001AD 0x32323232 0x32323232 And that appears to be consistent across all 8 cores.

Throttlestop shows that the multiplier is 50, which is what is presently set in the BIOS. Screenshots of TS and CPU-Z attached and CPU-Z txt is here: https://pastebin.com/S2yWTkVp

Thanks again
 

Attachments

·
OG AMD
Joined
·
8,927 Posts
Says it is set to 49.0 (45 effective) ???
 

Attachments

·
Registered
Joined
·
13 Posts
Discussion Starter #11
So this appears in fact to be a Windows problem, specifically I think it's related to this piece of **** Asus AI suite that is near impossible to get rid of without wiping the drive and starting from scratch.

The CPU runs correctly under Ubuntu, cores scale independently between 800-4,900 mHz.

The m.2 drive was previously used on an Asus X99 board with a 5930K. In a moment of poor judgement early this year I installed Ai suite and was tooling around with a 4.5 gHz overclock (hence x45) just to see if Ai suite had any real value outside of the traditional BIOS overclock method. It does not. The 5930k chip was never stable at 4.5 and I settled on 4.3 via BIOS overclocking.

I installed the m.2 on the new board hoping the windows install would figure everything out and I could avoid a fresh install. I've done this a lot in the past and windows 10 is pretty decent about it. It's clearly not a good idea if this Ai suite gibberish is present.

I've deleted every trace I can find of Ai suite including in the registry, but there's still something on the drive that is forcing this x45 multiplier in windows. I believe a fresh install will correct it but would like to avoid it if possible. I know it's a good idea for a host of reasons to reinstall but aside from this multiplier thing everything runs great.
 

·
Registered
Joined
·
983 Posts
Your CPU-Z Report shows exactly what is going on. If you do not want to properly install Windows, you should be able to use ThrottleStop to get your CPU running at its full rated speed.

MSR 0x1AD shows the number 32 hex (50 decimal) so your CPU is set to use the 50 multiplier whether 1, 2, 3, ... or all 8 cores are active. That register looks good.

Here's the problem.

Code:
    MSR 0x00000770      0x00000000  0x00000001
    MSR 0x00000774      0x0000019E  0x00002D01
Intel's 6th Gen and newer CPUs support a feature called Speed Shift. This is used to control the CPU speed. It is commonly used on newer laptops but not so much on desktop computers.

In MSR 0x770, the digit 1 at the far right side confirms that Speed Shift is enabled. MSR 0x774 is the control register for Speed Shift. The digits at the far right contains 2D01. The 2D is the maximum multiplier and 01 beside it is the minimum multiplier. 0x2D hex is equivalent to 45 decimal. That register is limiting your CPU to the 45 multiplier.

As mentioned, most desktop boards are not using Speed Shift. There are 3 ways that Speed Shift can be enabled. The bios can enable Speed Shift, or Windows can enable Speed Shift or you can use a tool like ThrottleStop to enable Speed Shift. I do not think you can blame ThrottleStop since you were having this problem before you started using ThrottleStop. I am not familiar with Ai Suite. I do not think it gives you access to the Speed Shift registers.

It is possible that the bios enabled Speed Shift. Check your bios for this setting. Sometimes this setting will be hidden so you will not be able to access or control it in the bios. It is possible that Windows 10 decided to help you out and enabled Speed Shift for you. This is common with laptops and the latest versions of Windows 10.

The problem with Speed Shift is that once it is enabled, it is not possible to disable Speed Shift. If you boot up and get into Windows and Speed Shift is enabled, it remains enabled until you reboot. Obviously if Windows or the bios is enabling Speed Shift, then each time you boot up, it is going to be enabled again and again.

The CPU runs correctly under Ubuntu
That means the bios is probably fine and it is Windows that is enabling Speed Shift. If you do a clean install of Windows 10, maybe this problem will go away but maybe not.

With ThrottleStop, you should be able to click on the TPL button and in that window, you can adjust the Speed Shift Max value from 45 up to 50. Hit OK and problem solved. If your computer crashes, you will need to increase the voltage in the bios. 5.0 GHz all cores might need a little more voltage compared to the 4.5 GHz that you have been running at.

The Speed Shift EPP (Energy Performance Preference) variable can be accessed on the main screen of ThrottleStop. A setting of 0 is for maximum performance. A setting of 80 is similar to the Windows Balanced power profile and a setting of 255 will make your CPU run like a slug. The CPU-Z report shows that Speed Shift EPP is set to 0 for maximum performance so that is OK.

Can you post some more screenshots of ThrottleStop? If the main ThrottleStop screen shows SST in green, this confirms that Speed Shift Technology is enabled within your CPU. HWiNFO can also be used to report the SST status.
 

·
Facepalm
Joined
·
9,499 Posts
Your CPU-Z Report shows exactly what is going on. If you do not want to properly install Windows, you should be able to use ThrottleStop to get your CPU running at its full rated speed.

MSR 0x1AD shows the number 32 hex (50 decimal) so your CPU is set to use the 50 multiplier whether 1, 2, 3, ... or all 8 cores are active. That register looks good.

Here's the problem.

Code:
    MSR 0x00000770      0x00000000  0x00000001
    MSR 0x00000774      0x0000019E  0x00002D01
Intel's 6th Gen and newer CPUs support a feature called Speed Shift. This is used to control the CPU speed. It is commonly used on newer laptops but not so much on desktop computers.

In MSR 0x770, the digit 1 at the far right side confirms that Speed Shift is enabled. MSR 0x774 is the control register for Speed Shift. The digits at the far right contains 2D01. The 2D is the maximum multiplier and 01 beside it is the minimum multiplier. 0x2D hex is equivalent to 45 decimal. That register is limiting your CPU to the 45 multiplier.

As mentioned, most desktop boards are not using Speed Shift. There are 3 ways that Speed Shift can be enabled. The bios can enable Speed Shift, or Windows can enable Speed Shift or you can use a tool like ThrottleStop to enable Speed Shift. I do not think you can blame ThrottleStop since you were having this problem before you started using ThrottleStop. I am not familiar with Ai Suite. I do not think it gives you access to the Speed Shift registers.

It is possible that the bios enabled Speed Shift. Check your bios for this setting. Sometimes this setting will be hidden so you will not be able to access or control it in the bios. It is possible that Windows 10 decided to help you out and enabled Speed Shift for you. This is common with laptops and the latest versions of Windows 10.

The problem with Speed Shift is that once it is enabled, it is not possible to disable Speed Shift. If you boot up and get into Windows and Speed Shift is enabled, it remains enabled until you reboot. Obviously if Windows or the bios is enabling Speed Shift, then each time you boot up, it is going to be enabled again and again.


That means the bios is probably fine and it is Windows that is enabling Speed Shift. If you do a clean install of Windows 10, maybe this problem will go away but maybe not.

With ThrottleStop, you should be able to click on the TPL button and in that window, you can adjust the Speed Shift Max value from 45 up to 50. Hit OK and problem solved. If your computer crashes, you will need to increase the voltage in the bios. 5.0 GHz all cores might need a little more voltage compared to the 4.5 GHz that you have been running at.

The Speed Shift EPP (Energy Performance Preference) variable can be accessed on the main screen of ThrottleStop. A setting of 0 is for maximum performance. A setting of 80 is similar to the Windows Balanced power profile and a setting of 255 will make your CPU run like a slug. The CPU-Z report shows that Speed Shift EPP is set to 0 for maximum performance so that is OK.

Can you post some more screenshots of ThrottleStop? If the main ThrottleStop screen shows SST in green, this confirms that Speed Shift Technology is enabled within your CPU. HWiNFO can also be used to report the SST status.
It's nice to see you, Unclewebb.
I wish I could donate a 9th gen board and CPU to you, but you said that you were only doing throttlestop part time now, plus Microsoft's OS shenanigans and signing stuff makes development impossible.
 
  • Rep+
Reactions: unclewebb

·
The last VRM burner
Joined
·
2,590 Posts
Install this Asus utility, install Revo Uninstaller and uninstall the utility using this RU with most aggressive scanning. Delete everything it finds.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #15
Can you post some more screenshots of ThrottleStop? If the main ThrottleStop screen shows SST in green, this confirms that Speed Shift Technology is enabled within your CPU. HWiNFO can also be used to report the SST status.
This is extremely helpful and educational, thank you.

These screenshots are before making any modifications to TS. As you can see Speed Shift is unchecked but has the green SST and 128 as EPP value.

I checked the Speed Shift box and re ran CPU-Z.

MSR 0x00000774 0x0000019E 0x00003101

So now it's running up to x49. I've used ThrottleStop with laptops but have never had a need with a desktop, this appears to have partially fixed my issue. (I also changed the EPP to 0).

When I uncheck Speed Shift and rerun CPU-Z it goes back to x45. So there's something in windows setting that and my hunch is it's some remnant of asus Ai suite.

At least now I can tune a proper overclock in the BIOS and get on with my life. I don't mind Speed Shift enabled so long as the CPU will throttle up when called for.

Thanks again.
 

Attachments

·
Registered
Joined
·
13 Posts
Discussion Starter #16
Install this Asus utility, install Revo Uninstaller and uninstall the utility using this RU with most aggressive scanning. Delete everything it finds.
The issue I see with that is the version of AI Suite that was on the machine is nowhere to be found online, it's since been replaced by what I assume is more terrible Asus software. Anecdotally it appears people have tried to install the newer version in hopes of correcting issues with previous versions only to find they now have two pieces of really hard to uninstall junk. So RU may uninstall the new version but may not even see traces of the old as I've deleted files and keys manually.
 

·
Registered
Joined
·
983 Posts
Autoruns is a good utility to use to find out what is starting up when Windows starts up.

https://docs.microsoft.com/en-us/sysinternals/downloads/autoruns

It might help you find any remnants of Ai Suite that are still running in the background. Be careful when using this program. It also might just be Windows 10 that is changing the Speed Shift control register. If you are using the Windows High Performance power profile, there should be less interference between Windows and ThrottleStop over control of EPP.

The Energy Performance Preference (EPP) variable controls what Speed Shift does. Open up the ThrottleStop FIVR window and in the monitoring table at the top right, it will show you what value the CPU is currently using for EPP. The data in this table is constantly being updated.

Run something simple like the built in TS Bench test. Put some load on the CPU, partial load or full load doesn't matter. Watch the reported multiplier. Does it show a steady 49.00 or does it occasionally drop to 45.00? If it drops occasionally, it might be a good idea for ThrottleStop to watch this register a little closer.

Edit - Almost forgot. In the FIVR window, clear the Unlock Adjustable Voltage options for the core and cache. This way, ThrottleStop should not interfere with the voltage adjustments that you are setting in the bios.

I don't mind Speed Shift enabled so long as the CPU will throttle up when called for.
No need to worry about throttling up. If Speed Shift EPP is checked and set to 0, the CPU should constantly run at full speed.

Edit - If Speed Shift is being enabled by Windows 10, you can try disabling it by entering this command into a command window that has Administrator privileges.

Code:
powercfg -setacvalueindex SCHEME_MIN SUB_PROCESSOR PERFAUTONOMOUS 0


Use SCHEME_MIN if you are using the Windows High Performance power profile. You can change SCHEME_MIN to SCHEME_BALANCED if you are using the Windows Balanced power profile. You will need to reboot after you make any changes.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #18
Autoruns is a good utility to use to find out what is starting up when Windows starts up.

https://docs.microsoft.com/en-us/sysinternals/downloads/autoruns

It might help you find any remnants of Ai Suite that are still running in the background. Be careful when using this program. It also might just be Windows 10 that is changing the Speed Shift control register. If you are using the Windows High Performance power profile, there should be less interference between Windows and ThrottleStop over control of EPP.

The Energy Performance Preference (EPP) variable controls what Speed Shift does. Open up the ThrottleStop FIVR window and in the monitoring table at the top right, it will show you what value the CPU is currently using for EPP. The data in this table is constantly being updated.

Run something simple like the built in TS Bench test. Put some load on the CPU, partial load or full load doesn't matter. Watch the reported multiplier. Does it show a steady 49.00 or does it occasionally drop to 45.00? If it drops occasionally, it might be a good idea for ThrottleStop to watch this register a little closer.

Edit - Almost forgot. In the FIVR window, clear the Unlock Adjustable Voltage options for the core and cache. This way, ThrottleStop should not interfere with the voltage adjustments that you are setting in the bios.


No need to worry about throttling up. If Speed Shift EPP is checked and set to 0, the CPU should constantly run at full speed.

Edit - If Speed Shift is being enabled by Windows 10, you can try disabling it by entering this command into a command window that has Administrator privileges.

Code:
powercfg -setacvalueindex SCHEME_MIN SUB_PROCESSOR PERFAUTONOMOUS 0


Use SCHEME_MIN if you are using the Windows High Performance power profile. You can change SCHEME_MIN to SCHEME_BALANCED if you are using the Windows Balanced power profile. You will need to reboot after you make any changes.
That command didn't work, still boots with speed shift enabled and limited to x45. Thanks for the Autoruns tool, that is very useful. I found several asus related services that were starting and disabled them but no changes, speed shift persists after reboot.

Now... As I mentioned before this is an older windows install from a Haswell-E rig. I had installed Process Lasso years ago and decided to open it up and look around. It was not autostarting, there was nothing in Autoruns. However it did apparently create a windows power profile called "Bitsum Highest Performance" when I select that the chip appears to run as designed.

When in "Windows High Performance" mode speed shift is enabled and limited to x45. So I guess something, whether it be AI suite or Process Lasso has written something into that profile that limits speed shift to x45. TS can over ride it, and switching to "Bitsum Highest Performance" yields the following from CPU-Z:

MSR 0x00000770 0x00000000 0x00000001
MSR 0x00000774 0x0000019E 0x0000FF24

Which if I'm converting correctly gives a max multiplier of 255, or system max?

I haven't tried uninstalling process lasso yet, but I did reset it to defaults, which changed nothing.

Another observation... In "Power saver" mode the chip scales up to x47 under load (per core max) which is weird as CPU-Z shows:


MSR 0x00000770 0x00000000 0x00000001
MSR 0x00000774 0x0000019E 0x9900FF01

So the min is dropped but the max should still be going to whatever the BIOS limit is.

So I tend to think a clean install will fix this, but I'm also inclined to chase down whatever has contaminated "highest performance" and correct it.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #19
you think Intel would sell an unlocked CPU and then quietly limit that CPU to 45x without mentioning it and you'd be the first one to notice? lol.

assuming you haven't edited Windows Power Plan rules either your motherboard is faulty (unlikely) or you goofed somewhere.
So yeah. That was the answer all along. Immediately after I posted the response above this one, I clicked "Restore default settings for this plan" under edit plan settings and everything works as designed now.

Educational for sure, but time consuming, and the thread has come full circle.

And I will not be reinstalling windows anytime soon. I may just keep moving this install from machine to machine. It's already seen 3 different MB and CPU combos and is as stable as it's ever been. Just threw me for a loop for a few days.

Thanks again everyone.
 

·
9 Cans of Ravioli
Joined
·
20,820 Posts
So yeah. That was the answer all along. Immediately after I posted the response above this one, I clicked "Restore default settings for this plan" under edit plan settings and everything works as designed now.

Educational for sure, but time consuming, and the thread has come full circle.

And I will not be reinstalling windows anytime soon. I may just keep moving this install from machine to machine. It's already seen 3 different MB and CPU combos and is as stable as it's ever been. Just threw me for a loop for a few days.

Thanks again everyone.

:laughings

at least you got it sorted.
 
1 - 20 of 21 Posts
Top