Overclock.net banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,486 Posts
Discussion Starter · #1 ·
Just installed MySQL, and now the Apache service won't start.

I have:

Code:

Code:
extension_dir="C:/PHP/ext"
extension=php_mysql.dll
set in the php.ini file.

Apache will only start after I comment out the "extension=php_mysql.dll" line.

What's wrong?

EDIT: Figured it out. The entry was duplicated; for some reason a bunch of extensions were enabled by default at the end of my PHP file. Every reference I've looked at said they'd be under "Dynamic Extensions" commented out by default.
 

·
Premium Member
Joined
·
1,592 Posts
Quote:
Originally Posted by dzalias;11979733
Just installed MySQL, and now the Apache service won't start.

I have:

Code:

Code:
extension_dir="C:/PHP/ext"
extension=php_mysql.dll
set in the php.ini file.

Apache will only start after I comment out the "extension=php_mysql.dll" line.

What's wrong?

EDIT: Figured it out. The entry was duplicated; for some reason a bunch of extensions were enabled by default at the end of my PHP file. Every reference I've looked at said they'd be under "Dynamic Extensions" commented out by default.
It is possible the install may have automatically enabled them for you.
 

·
Registered
Joined
·
809 Posts
Yes, I noticed that too when I was setting up PHP with MySQL. They have the actual directory extension commented out in favor of declarations at the bottom that include every possible extension. I don't understand the point of it actually, but maybe it's so that people don't have to manually edit the .ini file
 
1 - 3 of 3 Posts
Top