Overclock.net banner

8801 - 8806 of 8806 Posts

·
Registered
Joined
·
173 Posts
You can enable ReBAR with either BIOSv (6.61/6.62), gpu reports it enabled (even on my V56 Pulse), there are some minor gains (less than 1% in 3dMark TS/FS, around 1% in SotTR bench etc), but they're consistent and as soon as I disabled it I was back to normal.
I noticed some weird glitches playing BFV (a bluish tint when I made a sharp turn/direction change) but this could be a lot of things.

Anyway, the only real problem is that my gpu (cross flashed to XFX V64) won't give any signal until the Win10 login screen comes up, so I can't get to BIOS (or even on safe mode).
Just an update:

The reason for the signal loss is the flashed XFX V64 BIOS (Sapphire Pulse 56 gpu). It may not be UEFI compatible (gpu-z reports it is, but still...) or it may be some other glitch.

Using the original BIOS everything works as it should (reBAR included).
 

·
Registered
Joined
·
72 Posts
I'm not finding the option for ReBar on the bios, also could you guys point out a trusty 6.62 bios link? I want to check if the one I downloaded has the same CRC as the ones everyone else are using.
 

·
Registered
Joined
·
157 Posts
  • Rep+
Reactions: Veii and ericorg87

·
Overclock the World
Joined
·
2,502 Posts
Wait you want to simply flash a bios from other motherboard without any modificatios to adapt different controllers? That is a terrible idea. I thought someone would modify the x470 bios to make sure it works.
The only difference between both Taichi's is the Ethernet controller
Both are promontory and use the same chipset
ASRock always ported the X470 Taichi bios down to other boards with some module changes
(which created bugs , soo the X470 bioses where always the best to use)

As for both Taichi's
They are identical , only the X470 has a soldered Type-C header
Even the RGB controller firmware is identical , with a subtle different layout - because more "links" are attached to it
This board is a pure exception and is not a different controller issue

As for other boards, for example crosshair Hero 6 to asrock pro 4, or any B550 board to B550 boards
The only thing you need to be worried about - is that the PWM controller has the same configured phases
The Mosfets adapt to the PWM controller
I've played with a gigabyte, two asrock bioses (reskins) and a biostar bios - on the B550 ITX/AX
All of them work and post.
The only difference is that the controller might not recognize the layout and read out 1.7v into the CPU (which is not applying)
or not detecting PCIe configured ID and or having broken XHCI USB 3.0 controller layouts

It still will post and push you into the bios - just getting away from it with flashrom, very likely won't work
As you will miss a correctly configured APCI table there for your board layout

But as for the Taichi, which is a special case
They are perfectly identical and continue to work
Both Chipset IDs and the same FW are in there, and will continue to load
This is an exception and only applies to this board only
using X370 bioses on X470 might disable 5gbit ethernet functionality or 10gbit
But it doesn't have to ~ there is no issue having "foreign" efi modules , but there is an issue having "lacking" modules for a bios to operate

The X370<->X470 Convert will remain always working , as both PCBs are identical
The Taichi to CH6 mod can work, but i never finished research
The ext voltage controller of the CH6 creates incompatibility
Else the PCBs and the dual crystal oscilators for BLCK finetuning, are existing and identical (both PCBs)

That's about it :)
Hope this hybrid success, never dies and remains "correctly" remembered
As it was a one time only thing.
B550 ITX/AX to X570 ITX/AX - could work with a bit of work
But ASRock learned from their mistake and cuts away unused modules from their bioses
Also stopped going the open CBS route - which made them the preferred choice before on 3xx & 4xx days.
Now they appear to have the cleanest , most bugfree bios on 5xx series. But also the most booring one without any AMD CBS & PBS access
They fired the wrong bios-engineer or he was very underpaid and left. Sad :cry:
 

·
Registered
Joined
·
329 Posts
The only thing we have to verify in order not to brick the board is that the BIOS file that we download from ASRock in case we want to update, respect the size of 16MB .
AMD blocked zen3 support since AGESA 1.2.0.0 for x370 mobo's, my C6H can handle A LOT of Asrock and Biostar bioses using Zen3 nice and stable, but jumping from 1.1.0.0 to 1.2.x.x+ - it's total game over for every compatible model which worked before, and all with same error on post code. But in case of Zen2 everything works fine after update, even ResizeBar now works with Zen2 gen
 
8801 - 8806 of 8806 Posts
Top