Overclock.net banner

1 - 20 of 20 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Getting a good frame rate but getting some minor but definitely noticeable micro stutter. I've tried a variety of different solutions to no avail, but I'm curious to see what solutions the community has successfully implemented. Also interested to see what Nvidia control panel settings people have found to optimize games across the board.

Sent from my SM-N950U using Tapatalk
 

·
Graphic Card Addiction
Joined
·
4,031 Posts
Getting a good frame rate but getting some minor but definitely noticeable micro stutter. I've tried a variety of different solutions to no avail, but I'm curious to see what solutions the community has successfully implemented. Also interested to see what Nvidia control panel settings people have found to optimize games across the board.

Sent from my SM-N950U using Tapatalk
All I ever change in the nVidia control panel:
Adjust Image Setting w/Preview
Use my preference emphasizing Performance

Global
Adaptive Power Management
Texture Filter Quality: High Performance

Program settings(If your game is not listed, click Add and see if it's in the recent list. If not you will have to add it manually, or run it and then it should show up in the list):
Maximum Power Management


On a different note, you can try enabling/disabling HPET. It seems some Ubisoft games do a bit better with it disabled. At least that's my experience.

I use Timerbench 1.5 to check which should give you the best performance. In fact just ran it a bit ago.

Timerbench 1.5.jpg
 

·
Not a linux lobbyist
Joined
·
2,304 Posts
I've gotten more consistent frames with AC Origins and Oddysey with an Intel/Nvidia build by lowering the environment details one step below max and then reducing other settings so that my gpu isn't maxed out at my desired framerate. I also use blur busters style low lag vsync at 60 fps, but I'm not losing out on many frames since I just have a 1080ti for 4k. But I would see my gpu near maxed, then it would pull in the cpu and everything would bog down. If I left that gpu just a little space things would stay fine.

This fix is pretty particular to these two games though.
 

·
Vermin Supreme 2020
Joined
·
25,774 Posts
the fps sinks in these titles are nearly all CPU anyways. this is why you can achieve 90-100FPS @ 1440p outside of cities, while bogging down into the low 40s inside the cities.like, this game kicks the living crap outta my 9700K.

as for stutter prevention - not sure what frame rate you're targeting, but be sure to set your frame rate cap to 2-3FPS below your monitor's max refresh rate. (this can usually be done in the game's settings .cfg, or via custom resolution, or Rivatuner via MSI Afterburner)



conjecture - if the above doesn't help, & changing graphics settings doesn't help, and reinstalling drivers doesn't help, then you might wanna inspect your CPU overclock stability. benchmark stable & game stable are quite different.



hard to help without knowing more about your hardware.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5 (Edited)
All I ever change in the nVidia control panel:
Adjust Image Setting w/Preview
Use my preference emphasizing Performance

Global
Adaptive Power Management
Texture Filter Quality: High Performance

Program settings(If your game is not listed, click Add and see if it's in the recent list. If not you will have to add it manually, or run it and then it should show up in the list):
Maximum Power Management


On a different note, you can try enabling/disabling HPET. It seems some Ubisoft games do a bit better with it disabled. At least that's my experience.

I use Timerbench 1.5 to check which should give you the best performance. In fact just ran it a bit ago.

View attachment 362410

First and foremost thank you for providing me with some assistance on this matter, not to mention how fast you replied. I am new to forums and I was surprised by the speed at which people replied to this thread, I am grateful. As for settings, I have maximum performance set globally, should I tick it back to adaptive as you've suggested? Could I turn off HPET temporarily in the game by just changing the affinity of the application in device manager? Big thank you as well for making me aware of Timerbench, that looks like a super cool piece of software, something I will definitely add to my arsenal now. I also wasn't aware that changing texture filter quality had that big of an impact. I heard that the FXAA setting in the nvidia control panel is also potentially to blame here. Thanks once again, cheers.

P.S. just realized you meant high precision event timer instead of hyperthreading lolol
 

·
Registered
Joined
·
28 Posts
Discussion Starter #6
I've gotten more consistent frames with AC Origins and Oddysey with an Intel/Nvidia build by lowering the environment details one step below max and then reducing other settings so that my gpu isn't maxed out at my desired framerate. I also use blur busters style low lag vsync at 60 fps, but I'm not losing out on many frames since I just have a 1080ti for 4k. But I would see my gpu near maxed, then it would pull in the cpu and everything would bog down. If I left that gpu just a little space things would stay fine.



This fix is pretty particular to these two games though.
Fascinating! Thank you I will give this a try and report back

Sent from my SM-N950U using Tapatalk
 

·
Graphic Card Addiction
Joined
·
4,031 Posts
First and foremost thank you for providing me with some assistance on this matter, not to mention how fast you replied. I am new to forums and I was surprised by the speed at which people replied to this thread, I am grateful. As for settings, I have maximum performance set globally, should I tick it back to adaptive as you've suggested? Could I turn off HPET temporarily in the game by just changing the affinity of the application in device manager? Big thank you as well for making me aware of Timerbench, that looks like a super cool piece of software, something I will definitely add to my arsenal now. I also wasn't aware that changing texture filter quality had that big of an impact. I heard that the FXAA setting in the nvidia control panel is also potentially to blame here. Thanks once again, cheers.

P.S. just realized you meant high precision event timer instead of hyperthreading lolol
I keep my set to adaptive in global so the card will downclock when not under load. I think it will with it set to maximum anyway, iirc I just set it to that when I was using multiple monitors, and it kept the memory clock high. I set it out of habit I guess. lol

HPET is a bit of hit or miss. Some games/apps it doesn't matter, some it does. Very strange. Just something to maybe try. I know this game is a lot better than it was at release. It was a stuttering mess. You will just have to try a few things and see what help. As for HPET, you should be able to enable/disable via the bios, or windows elevated command prompt. TimeBench also has a toggle switch in it to do that. I normally just change it in the bios.

Another tip, not really related to this thread...but all threads where you might post. Go to the "Rigbuilder" tab, and put in your hardware that you are using, that will save time when people are trying to help you, they'll know what hardware you are using.

Let us know how it goes...:thumb:
 

·
Registered
Joined
·
28 Posts
Discussion Starter #8
I keep my set to adaptive in global so the card will downclock when not under load. I think it will with it set to maximum anyway, iirc I just set it to that when I was using multiple monitors, and it kept the memory clock high. I set it out of habit I guess. lol



HPET is a bit of hit or miss. Some games/apps it doesn't matter, some it does. Very strange. Just something to maybe try. I know this game is a lot better than it was at release. It was a stuttering mess. You will just have to try a few things and see what help. As for HPET, you should be able to enable/disable via the bios, or windows elevated command prompt. TimeBench also has a toggle switch in it to do that. I normally just change it in the bios.



Another tip, not really related to this thread...but all threads where you might post. Go to the "Rigbuilder" tab, and put in your hardware that you are using, that will save time when people are trying to help you, they'll know what hardware you are using.



Let us know how it goes...:thumb:
I'll definitely add my rig info! Lol I saw that all you guys had the info in the profile below the message, so I thought to myself I better add that so I don't stick out like a sore thumb . That's handy to know there is a button for that in timerbench. And yeah I think adaptive is more my jazz, I'm all about the longevity of my parts .

Sent from my SM-N950U using Tapatalk
 

·
Vermin Supreme 2020
Joined
·
25,774 Posts
I just wanna interject on the adaptive/maximum performance thing.


I'd absolutely not use adaptive mode since you're trying to push 4K out of a 1080ti. you need every frame.



Also - be sure to set a custom frame rate @ 57, slamming up against 60 from 40-45 (city fps) will cause stutters.



You really wanna tackle this from the simplest & least complex angles first, before moving onto tweaking clocks, timers, affinities, etc. Not to mention, attempting to research fact from fiction on that side of the world is far from easy. You quickly transcend into a universe of "feels better" with zero proof/evidence, etc.



so remember to do a Guru3D Display Driver uninstaller driver purge, then re-install the driver without GeForce Experience, then set the driver to prefer maximum performance in NVCP, leaving everything else at global default.


this guide covers a ton of minutia for min-maxing this game engine as well, and should cover one of many ways to set you frame rate cap to 59 - https://www.tomshardware.com/reviews/assassins-creed-odyssey-low-end-hardware,5849.html
 

·
Registered
Joined
·
28 Posts
Discussion Starter #10
Well I'm happy to report that on the basis of a hunch, I decided to restore all of my Nvidia control panel settings to default, including recent changes such as

Global
Maximum performance
Input latency
Maximum frame rate (so my GTX 1070 didn't have to work so hard when the refresh rate of my panel is only 75hz)

Also some per game settings such as
Negative LOD bias clamp
Thread optimization

I ran the game only to be horrified at even worse freezing LOL but then I found a thread after searching "AC Origins freezing" turns out the new Death Stranding driver update for Nvidia cards was the culprit. Halfway through my testing I updated the graphics card driver like a noob, sometimes newer isn't always better lol.

On behalf of the advice on this thread I found on AC Origins freezing, they said to rollback to 446.14 and I'm happy to report that this game is running like a dream now at ultra high on all settings with an in game frame cap of 60 fps. It's hard to believe my trusty old i7-2600k at 4ghz is still kicking so much ass. Mad grateful for all of the assistance. But if anybody has any further recommendations I'm all ears. I found turning off dynamic resolution looks so much better.

Sent from my SM-N950U using Tapatalk
 

·
Premium Member
Joined
·
15,028 Posts
You should set the graphics options manually.
Shadows 1 down from highest
details highest, environment highest..

no vsync..
No in-game antialiasing at all. None or as low as it gets
And use ReShade 1.0 with the mediator with SweetFX for aliasing and graphics enhancement.. You get your aliasing from the reshade, and it looks great!
Set Nvidia settengs to default..MAYBE negative LOD bias @ -1..(I likes dat dere)
Not sure if I've done that one, but I've done some.. AC games.

Damn! This thing is hard to find, and it makes games better! https://www.mediafire.com/folder/8ar1jhh1809cl/R...sitory#9dd4f84o9l99n

You gotta play with it some, see what kind of sharpening and coloring the game will take.

https://www.mediafire.com/folder/8ar1jhh1809cl/R...sitory#9dd4f84o9l99n
 

·
Registered
Joined
·
28 Posts
Discussion Starter #12
the fps sinks in these titles are nearly all CPU anyways. this is why you can achieve 90-100FPS @ 1440p outside of cities, while bogging down into the low 40s inside the cities.like, this game kicks the living crap outta my 9700K.

as for stutter prevention - not sure what frame rate you're targeting, but be sure to set your frame rate cap to 2-3FPS below your monitor's max refresh rate. (this can usually be done in the game's settings .cfg, or via custom resolution, or Rivatuner via MSI Afterburner)



conjecture - if the above doesn't help, & changing graphics settings doesn't help, and reinstalling drivers doesn't help, then you might wanna inspect your CPU overclock stability. benchmark stable & game stable are quite different.



hard to help without knowing more about your hardware.
It's assuring to see that even modern CPUs are having trouble tackling this game. Because my i7-2600k plays the Witcher on max settings no problem. Thank you for this info!

Sent from my SM-N950U using Tapatalk
 

·
Vermin Supreme 2020
Joined
·
25,774 Posts
It's assuring to see that even modern CPUs are having trouble tackling this game. Because my i7-2600k plays the Witcher on max settings no problem. Thank you for this info!

Sent from my SM-N950U using Tapatalk

their engine is stupidly overdue for an overhaul, but we already know its not coming as the new Viking chapter has a 30FPS target.


It's nice that it's multi-threaded, now they just need to optimize it.
 

·
Graphic Card Addiction
Joined
·
4,031 Posts
Glad you got it worked out. I get the same fps without hitching on all the driver sets. I keep a spreadsheet on them and AC:Origins is one that I test.

Cool on the Rigbuilder though....that will help when you ask something and don't have to answer...what are you running x/y/z over and over.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #15
You should set the graphics options manually.

Shadows 1 down from highest

details highest, environment highest..



no vsync..

No in-game antialiasing at all. None or as low as it gets

And use ReShade 1.0 with the mediator with SweetFX for aliasing and graphics enhancement.. You get your aliasing from the reshade, and it looks great!

Set Nvidia settengs to default..MAYBE negative LOD bias @ -1..(I likes dat dere)

Not sure if I've done that one, but I've done some.. AC games.



Damn! This thing is hard to find, and it makes games better! https://www.mediafire.com/folder/8ar1jhh1809cl/R...sitory#9dd4f84o9l99n



You gotta play with it some, see what kind of sharpening and coloring the game will take.



https://www.mediafire.com/folder/8ar1jhh1809cl/R...sitory#9dd4f84o9l99n
Thank you for sharing, I'm gonna look into this! Good looking out

Sent from my SM-N950U using Tapatalk
 

·
Registered
Joined
·
154 Posts
Unfortunately there doesn't seem to be any magic setting to make this game run smoothly. The best I could find was just to cap frames to 60. However the in-game frame limiter is not very precise for some reason.
You can use Rivatuner but sometimes it does not register the game running so it won't limit frames. All I could find about that was that Ubisoft said there is a conflict between the game and Rivatuner.
I haven't tried the new limiter options in the Nvidia drivers but that could be worth looking into.
 

·
The last VRM burner
Joined
·
2,590 Posts
Just use a crack or anything to erase Denuvo in this title.
 

·
Registered
Joined
·
154 Posts
Just use a crack or anything to erase Denuvo in this title.
Far as I can tell, removing Denuvo will improve load times. But any other benefits depends entirely on your system. Many see no change at all. Worth a shot though I suppose.
I think the main culprit, and this is just a guess, is the hitching we sometimes get is the CPU being overloaded by many npc's being loaded at once and all their required simulations.
 

·
The last VRM burner
Joined
·
2,590 Posts
Seen a video, I think on RandomGamingHD channel, comparing Denuvo stripped version to equipped with it. Smooth gameplay vs drunken hiccups.
 

·
Registered
Joined
·
154 Posts
You've probably seen Overlord Gaming's video.
I just watched 5 different Youtubers comparing before and after and his video is the only one showing problems with Denuvo. In fact I have never experienced anything close to the kind of hitching he does so there most likely is some kind of issue with his specific setup.
 
1 - 20 of 20 Posts
Top