Overclock.net banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello all,

So a few months ago, when I was building my computer, I bought the Asus PCE-AC66 Network Adapter. I had a clean install of windows 7 x64 and everything was working fine. When I installed the drivers for the PCE-AC66 I thought at first everything was working fine.

About a few days later, I started to realize my internet connection wasn't always stable (I do have the antennas in a open area). When i double clicked on the ASUS PCE-AC66 WLAN Control Center shortcut on my desktop it says: "Asus Wireless Adapter is not installed on your computer yet!" with the only option to click "OK". So, I re-installed the drivers, it seemed to have worked until I did a reboot. Same problem.

I checked to see if it was connected properly, it is. I do have it connected to a PCI-E x16 slot, but as far as I know, there should not be a problem about that.

I want to install the drivers they have at the Asus website, but I don't know where to extract the files!? Can't find any information about it.

I could go and exchange it a Memory Express, but I want to make sure it's not a driver issue first.

I'm currently with Telus high speed plan (4Mb/s - 15 Mb/s). According to www.speedtest.net my internet connection varies from 0.4Mb/s to 5 Mb/s on some days, other days its running fine at 10-15. The upload speed is irrelevant as my plan only supports up to 1 Mb/s (total garbage, I know).

2923616954.png

Does anyone have this issue? Can somebody tell me where to extract the drivers?

Thanks, Phil.
 
1 - 2 of 2 Posts
Top