Overclock.net banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3,304 Posts
Discussion Starter #1
well, the issue is that i can't see any server. every search i do take a long time and always come empty.

i logged my account, redeemed some code, but i can't find any server.

my friend can, he even played while talking to me on the phone.

i added my friend to my friend list, and when i try to join a game he's in, it says that i can't connect to EA server.

can it be my router?

help me.
 

·
Registered
Joined
·
3,304 Posts
Discussion Starter #4
Quote:


Originally Posted by Noir
View Post

Try disabling your firewall it worls for me

disabling the ENTIRE firewall? i don't know much, but wouldn't it be dangerous.

Quote:


Originally Posted by Klue22
View Post

EA has taken down a lot of the Bad Company 2 servers till tomorrow. They claim to be installing new hardware. There official Twitter Page:

http://twitter.com/OfficialBfbc2

my friend was playing while i was trying to connect. i should be able to see some server too, no?
 

·
Registered
Joined
·
1,059 Posts
Quote:


Originally Posted by Klue22
View Post

EA has taken down a lot of the Bad Company 2 servers till tomorrow. They claim to be installing new hardware. There official Twitter Page:

http://twitter.com/OfficialBfbc2

This is already done. Unless they did it again today. i just played it a while ago.

Hmmm using my ESET security i just click disable firewall and it solves some issues.

You may also try port forward the BC2 ports since you use a router.

I forgot the list.

can someone post the ports
 

·
Premium Member
Joined
·
5,092 Posts
EA states on their twitter that some servers will be down until SATURDAY morning.
Chances are he's on different servers, and you shouldn't need to disable the entire firewall, just make sure that BFBC2 is added as an exception. As a side note I got kicked off early this morning (around 2:00 AM Central Time) and it wouldn't let me connect to ea online. Same with some of my friends.
 

·
Registered
Joined
·
3,304 Posts
Discussion Starter #7
problem is not my router. i tried plugging directly into my modem and i have the same issue.

i do remember my friend having an update when he installed it, i didn't.

next, reinstalling the game (and starting the SP campain all over)
 
1 - 7 of 7 Posts
Top