Overclock.net banner

Battlefield 2142 won't boot, error :(

550 Views 10 Replies 2 Participants Last post by  headcracker
I just downloaded BF2142 Deluxe Edition with EADM, but when i try to launch it i get this error. Any ideas ? :/
See less See more
1 - 11 of 11 Posts
That could mean a few things, either you have something like Daemon Tools or another optical drive emulator active, or Securom didn't install properly.
Forgot to mention, it worked fine at first. Then i D/L and installed the patch now I'm getting this error. I do have Daemon Tools installed but its not running.
Even if it is not running, it will look for it, and registry entries related to it.
Hmmm i will unstall Daemon Tools an clean reg with Ccleaner an try again.
I wouldn't recommend using CCleaner's registry cleaner, as much as I like CCleaner, registry cleaners cause nothing but trouble (and I've experienced it with CCleaner's time and time again).
  • Rep+
Reactions: 1
Well you should trust it
it just worked and problem solved.

Thanks. +1
See less See more
Glad to hear it worked.
See less See more
Now another problem. I can only Choose 800x600 , 1024x768 , and 1600x1200 Resolution. I want to play at 1920x1080. Is this not possible?
Add the following command line options to the shortcut:

+widescreen 1 +szx 1920 +szy 1080
See less See more
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.